Bug 469628 - Include a bundled dynamic SCSI rescan script
Summary: Include a bundled dynamic SCSI rescan script
Status: CLOSED DUPLICATE of bug 427259
Alias: None
Product: Fedora
Classification: Fedora
Component: sg3_utils   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dan Horák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 467713
TreeView+ depends on / blocked
 
Reported: 2008-11-03 08:02 UTC by Dan Horák
Modified: 2008-11-27 16:46 UTC (History)
7 users (show)

Fixed In Version: 1.26-2.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-03 08:40:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan Horák 2008-11-03 08:02:24 UTC
+++ This bug was initially created as a clone of Bug #467201 +++

Feature request:
Dynamic SCSI rescan functionality can be currently implemented by manually echoing values into the SCSI sysfs files. This is an extremely useful feature in enterprise scenarios, as a reload of the underlying driver(which does a SCSI rescan) is not practical as it is disruptive.

It would be ideal if the RHEL kernel provides a bundled SCSI rescan script which performs the following dynamic SCSI rescan functionalities:

1) Detect luns added to the host.

2) Remove luns from the host.

3) Resize existing luns on the host.

--- Additional comment from dhorak@redhat.com on 2008-10-16 07:07:19 EDT ---

Are you looking for something like the rescan-scsi-bus.sh script from http://www.garloff.de/kurt/linux/scsidev/ ?

--- Additional comment from marting@netapp.com on 2008-10-16 07:39:56 EDT ---

Exactly.

Comment 1 Dan Horák 2008-11-27 14:48:38 UTC
*** Bug 427259 has been marked as a duplicate of this bug. ***

Comment 2 Juha Tuomala 2008-11-27 16:46:51 UTC

*** This bug has been marked as a duplicate of bug 427259 ***


Note You need to log in before you can comment on or make changes to this bug.