Bug 479525 - Kernel .29 doesn't complete booting in Rawhide
Kernel .29 doesn't complete booting in Rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 471804
  Show dependency treegraph
 
Reported: 2009-01-10 12:24 EST by antonio montagnani
Modified: 2009-02-19 16:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-19 16:14:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg from kernel-2.6.29-0.19.rc0.git9.fc11.x86_64 (30.89 KB, text/plain)
2009-01-10 18:43 EST, Michal Jaegermann
no flags Details
part of dmesg (16.95 KB, application/octet-stream)
2009-01-15 16:06 EST, antonio montagnani
no flags Details

  None (edit)
Description antonio montagnani 2009-01-10 12:24:28 EST
Description of problem:
kernel doesn't start booting procedure

Version-Release number of selected component (if applicable):
kernel-2.6.29-0.24.rc0.git13.fc11.i686

How reproducible:
always

Steps to Reproduce:
1.just boot machine with investigated kernel
2.
3.
  
Actual results:
the only lines that I get are:

Booting....
root....
[Linux-bzImage, setup=0x3000, size 0x2b18f0]
initrd /initrd.......
[Linux-initrd @ 0x37cc5000, 0x329315 bytes]

and system freezes

Precedent kernel boot fine, I am writing from that machine.
Tested also with 25 kernel from koij...
this is my grub.conf but I do not see any problem..


Expected results:


Additional info:
Comment 1 Michal Jaegermann 2009-01-10 18:41:06 EST
This looks really the same on x86_64 too.  With all stuff eating boot messages turned off after lines of the sort like the above this kernel prints
"crc error" and "System halted" and that is it.  Turning off efi scanning, which happens before that does not change anything.
Comment 2 Michal Jaegermann 2009-01-10 18:43:36 EST
Created attachment 328643 [details]
dmesg from kernel-2.6.29-0.19.rc0.git9.fc11.x86_64

The previous rawhide kernel, 2.6.29-0.19.rc0.git9.fc11.x86_64, boots for me. Attached is dmesg from that one for comparison.
Comment 3 Michal Jaegermann 2009-01-11 16:54:56 EST
2.6.29-0.25.rc0.git14.fc11.x86_64 is afflicted by the same disease.  An immediate
"crc error" on an attempt to start and "System halted".
Comment 4 antonio montagnani 2009-01-12 12:49:57 EST
kernel-2.6.29-0.28.rc1.fc11.i686 is affected by same problem

I removed rhgb and quiet and last line seen during booting are:

ata2.00: configured for UDM/33
ata2.01: configured for MWDMA2

What does it mean???
Comment 5 Michal Jaegermann 2009-01-12 20:03:18 EST
kernel 2.6.29-0.28.rc1.fc11.x86_64 boots again for me although it is not
entirely happy (cf. bug 479778) and sometimes booting will not finish.
Comment 6 antonio montagnani 2009-01-13 17:16:23 EST
kernel-2.6.29-0.31.rc1.git2.fc11.i686 has same problems.
I don't know how to debug it......
Comment 7 antonio montagnani 2009-01-14 13:15:48 EST
kernel-2.6.29-0.35.rc1.git4.fc11.i686 has same problems on my desktop.
On my laptop seem fine.
Comment 8 antonio montagnani 2009-01-15 12:44:57 EST
up to now no kernel 2.6.29.x is able to start system on my 3 F11 boxes.
I am still running on 28 series.
Comment 9 antonio montagnani 2009-01-15 16:06:59 EST
Created attachment 329142 [details]
part of dmesg

this is part of dmesg file on a working boot and where non booting systems idles (or hangs)
Comment 10 antonio montagnani 2009-01-16 04:55:35 EST
I note that when system idles before those two lines
ata2.00: configured for UDM/33
ata2.01: configured for MWDMA2

there is a message that there is a Failure in Unit Clearance, on a different system affected by same problems of system idling boot.
Comment 11 antonio montagnani 2009-01-17 02:41:59 EST
Same problem with o.41 from koij.
Comment 12 antonio montagnani 2009-01-19 09:48:14 EST
Same problem with 0.43 from koij not starting two boxes of my 3 F11 machines: I think that is connected to something related to hardware recognition, the only working machine is a laptop booting off an USB disk, the other two uses IDE disks.

And not being able to start the machine I cannot test whether .29 kernel solves the problem of sparkling audio with intel sound card!!! (see Bug 462026 -  music file play -> sound sparks. or similar)
Comment 13 antonio montagnani 2009-01-22 07:45:25 EST
Same problem with 0.45 from koij not starting two boxes of my 3 F11 machines: I
think that is connected to something related to hardware recognition, the only
working machine is a laptop booting off an USB disk, the other two uses IDE
disks.
Comment 14 antonio montagnani 2009-01-22 14:36:17 EST
http://www.smolts.org/show?uuid=pub_2dabf29b-bd26-4825-b7ed-ac1db85fec24

One of non working machine has this smolt profile
Comment 15 antonio montagnani 2009-01-23 15:13:00 EST
scsi0 : ata_piix
scsi1 : ata_piix
ata1: PATA max UDMA/100 cmd 0x1f0 ctl 0x3f6 bmdma 0xfc00 irq 14
ata2: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0xfc08 irq 15
ata1.00: ATA-7: Maxtor 6L200P0, BAH41E00, max UDMA/133
ata1.00: 398297088 sectors, multi 16: LBA48 
ata1.00: configured for UDMA/100
ata2.00: ATAPI: HL-DT-ST DVDRAM GSA-4163B, A103, max UDMA/33
ata2.01: ATAPI: Hewlett-Packard CD-Writer Plus 7500, 1.0a, max MWDMA2
ata2.00: configured for UDMA/33
ata2.01: configured for MWDMA2

With 29 series system stops here

with 28 series it continues and boots fine

scsi 0:0:0:0: Direct-Access     ATA      Maxtor 6L200P0   BAH4 PQ: 0 ANSI: 5
sd 0:0:0:0: [sda] 398297088 512-byte hardware sectors: (203 GB/189 GiB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
sd 0:0:0:0: [sda] 398297088 512-byte hardware sectors: (203 GB/189 GiB)

With 29 series system stops after
Comment 16 antonio montagnani 2009-01-23 17:34:03 EST
kernel-2.6.29-0.46.rc2.git1.fc11

No way: it doesn't complete booting...exactly same problem of all 29 series.
Comment 17 antonio montagnani 2009-01-27 05:01:37 EST
kernel.i686 2.6.29-0.53.rc2.git1.fc11

No way: it doesn't complete booting...exactly same problem of all 29 series.

At least 10 kernels from 29 series and no improvement.
Comment 18 antonio montagnani 2009-01-28 05:29:16 EST
and of course NFS is not working....
Comment 19 antonio montagnani 2009-01-29 01:51:34 EST
kernel-2.6.29-0.64.rc3.fc11.i686 from koij is affected by same problem.
Any further information required??
Comment 20 antonio montagnani 2009-01-29 01:52:58 EST
Comment #18 is not connected to this bug but already solved by upgarding nfs-utils
Comment 21 antonio montagnani 2009-01-30 05:48:30 EST
kernel-2.6.29-0.66.rc3.fc11.i686 is affected by same problem.
Comment 22 antonio montagnani 2009-01-31 04:33:35 EST
I installed the new kernel and have a look to the first option where there is a /dev/dm-0.
Is this the reason why kernel 29 are not booting????

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
#          initrd /initrd-version.img
#boot=/dev/sda
default 0
timeout 10
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.29-0.73.rc3.git2.fc11.i686)
	root (hd0,0)
	kernel /vmlinuz-2.6.29-0.73.rc3.git2.fc11.i686 ro root=/dev/dm-0 rhgb quiet
	initrd /initrd-2.6.29-0.73.rc3.git2.fc11.i686.img
title Fedora (2.6.28-3.fc11.i686)
	root (hd0,0)
	kernel /vmlinuz-2.6.28-3.fc11.i686 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
	initrd /initrd-2.6.28-3.fc11.i686.img
title Fedora (2.6.28-0.140.rc9.git1.fc11.i686)
	root (hd0,0)
	kernel /vmlinuz-2.6.28-0.140.rc9.git1.fc11.i686 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
	initrd /initrd-2.6.28-0.140.rc9.git1.fc11.i686.img
title Fedora (2.6.28-0.138.rc9.fc11.i686)
	root (hd0,0)
	kernel /vmlinuz-2.6.28-0.138.rc9.fc11.i686 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
	initrd /initrd-2.6.28-0.138.rc9.fc11.i686.img
Comment 23 antonio montagnani 2009-01-31 04:59:34 EST
even 79 is not completing boot also after modification to:
kernel /vmlinuz-2.6.29-0.73.rc3.git2.fc11.i686 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
Comment 24 antonio montagnani 2009-02-01 01:34:43 EST
in comment #23 79 should be read as 73.

Anyway also kernel-2.6.29-0.74.rc3.git3.fc11.i686 has same problems.
Comment 25 antonio montagnani 2009-02-03 17:21:38 EST
I don't know if it can help but this is my modprobe.conf

alias eth0 ne2k-pci
alias eth1 skge
alias scsi_hostadapter libata
alias scsi_hostadapter1 ata_piix
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0 ac97_clock=48000
#options snd-intel8x0 index=0 ac97_clock=44100
#options snd-intel8x0 index=0 ac97_clock=41194
#options snd-intel8x0 index=0
alias snd-card-1 snd-mpu401
options snd-card-1 index=1
options snd-mpu401 index=1
Comment 26 antonio montagnani 2009-02-05 16:29:18 EST
even  2.6.28-3.fc11.i686  kernel doesn't boot.
I notice tonight that system is not frozen but something is happening as the red light on the box is on!!!

is this bug connected to:
 Bug 481356 -  kernel-2.6.29-0.35.rc1.git4.fc11 and later won't boot (CONFIG_DMAR + buggy BIOS)  ???
Comment 27 antonio montagnani 2009-02-06 12:55:29 EST
kernel-2.6.29-0.85.rc3.git7.fc11.i686 is suffering of same problems.

Going to disinstall it, again.

I wonder how many computer will nor boot if 29 series is included in Alpha!!!
Reported on January 10
Comment 28 antonio montagnani 2009-02-06 15:58:04 EST
kernel-2.6.29-0.91.rc3.git9.fc11.i586

I will not install any new kernel until flag on this bug will be changed to assigned or duplicate
Comment 29 antonio montagnani 2009-02-09 14:28:55 EST
.96 and .99 have same problem.
Unfortunately updating some xorg package requires at least .96, so now I can't erase all 29 series kernel.

And I can' report if hda-sound issues have been solved completely by 29 series!!!

I understand that is urgent  only for me...good to know :-(
Comment 30 antonio montagnani 2009-02-12 18:33:12 EST
kernel-2.6.29-0.112.rc4.git3.fc11 doesn't boot my boxes (two boxes) either
Comment 31 antonio montagnani 2009-02-14 04:20:40 EST
kernel-2.6.29-0.118.rc5.fc11 doesn't complete booting...

maybe connected to???
ata2.01: ATAPI: Hewlett-Packard CD-Writer Plus 7500, 1.0a, max MWDMA2 ???
Comment 32 antonio montagnani 2009-02-15 05:49:35 EST
same with kernel .119.

Please note that I am running three boxes with F11 and two out of three are not booting with .29, and both of them have not recent hardware...one is more than 8 eight years old and the other about 5. Not uncommon situation, I guess.
Comment 33 antonio montagnani 2009-02-18 18:14:00 EST
kernel-PAE-2.6.29-0.124.rc5.fc11 is causing same problems :-(
Comment 34 Chuck Ebbert 2009-02-18 18:35:32 EST
2.6.29-rc5-git2 has two fixes that may prevent boot hangs.
Comment 35 antonio montagnani 2009-02-19 04:10:33 EST
Chuck

I confirm it: my computer in the office is booting .29 fine.
In a few hours, I will check the computer at home, and I will report back.
Comment 36 antonio montagnani 2009-02-19 12:50:12 EST
o.k. also at home my computer completes booting.

Chuck, I think that it can be closed...shall we wait for a while???
Comment 37 Chuck Ebbert 2009-02-19 16:14:12 EST
reopen the bug if it starts happening again...

Note You need to log in before you can comment on or make changes to this bug.