Bug 472463 - Logitech, Inc. OrbiCam not detected
Logitech, Inc. OrbiCam not detected
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: cheese (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-20 18:39 EST by Benjamín Valero Espinosa
Modified: 2009-02-08 05:04 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-24 07:08:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Running Cheese (5.12 KB, text/plain)
2008-11-24 14:36 EST, Benjamín Valero Espinosa
no flags Details

  None (edit)
Description Benjamín Valero Espinosa 2008-11-20 18:39:02 EST
Cheese in FC10 doesn't detect the webcam integrated in my laptop, as it did in FC9 with gspca modules. I run it from console and get this message on and on:

libv4l2: error dequeuing buf: Error de entrada/salida

Cheese shows the Gnome logo spinning and the green light by the webcam turns on, but no image is displayed. The output of lsusb is:

Bus 001 Device 002: ID 046d:0896 Logitech, Inc. OrbiCam

I have tried 'xawtv' and it works, turns on the green light and shows me, as expected, so I suppose it is a problem of Cheese and not from the kernel.
Comment 1 Hans de Goede 2008-11-21 07:45:05 EST
This is a known problem, can you please try and install the libv4l update available here, this should fix this:
http://koji.fedoraproject.org/koji/buildinfo?buildID=70523

Please report back with your results.

Also see bug 472468 and bug 472217, not sure which one you are seeing here, but both should be fixed by the mentioned update.
Comment 2 Benjamín Valero Espinosa 2008-11-21 15:01:04 EST
No luck. I have tried just running Cheese and doing it with LD_PRELOAD. What info should I send?
Comment 3 Hans de Goede 2008-11-24 07:08:13 EST
Sorry, I misread your initial report, you do not have an UVC cam. So it looks like you have found a bug in the new gspca driver. First of all please try the latest version as described here:
http://hansdegoede.livejournal.com/6630.html

And if that does not help please contact Jean-Francois Moine <moinejf@free.fr>, who is the author and maintainer of the new gspca driver and the zc3xx gspca-subdriver your cam uses.
Comment 4 Benjamín Valero Espinosa 2008-11-24 07:42:04 EST
OK, I will try it this evening in my laptop. Anyway, if my webcam works with 'xawtv' but doesn't work with 'Cheese', wouldn't it be a Cheese's bug instead of a driver's one? Thanks for your patience.
Comment 5 Hans de Goede 2008-11-24 08:09:10 EST
(In reply to comment #4)
> OK, I will try it this evening in my laptop. Anyway, if my webcam works with
> 'xawtv' but doesn't work with 'Cheese', wouldn't it be a Cheese's bug instead
> of a driver's one? Thanks for your patience.

Erm, sorry, YES! Possibly, maybe. I'm getting to much webcam related bugs lately and thus not reading them well, did I already say sorry?

/me goes to plug a zc3xx based cam in my PC
/me next goes to test cheese

Works fine for me I'm afraid.

But given that it does not happen with all apps, there are 2 things you can do for me:
1) Test with the latest gspca as described before
2) Run cheese from a terminal like this:
"LIBV4L2_LOG_FILENAME=/tmp/log cheese"
And then attach /tmp/log here.

Thanks!
Comment 6 Hans de Goede 2008-11-24 08:11:25 EST
One last thing, which you could try in cheese, go to Edit->preferences in the menu and try to change the resolution, maybe your cam has trouble with a certain resolution and cheese uses a different one then xawtv?
Comment 7 Benjamín Valero Espinosa 2008-11-24 14:36:02 EST
Created attachment 324532 [details]
Running Cheese
Comment 8 Benjamín Valero Espinosa 2008-11-24 14:38:11 EST
I have followed your steps but I haven't make it work. I attach the log. In Cheese Preferences, I see "Camera (/dev/video0)", and I can't open the resolution list below.
Comment 9 Hans de Goede 2008-11-25 03:26:10 EST
Ok,

I think I know whats going on. I think the driver for your cam (which btw is vc032x not zc3xx, my bad) has a bug which makes things not work when using a resolution of 640x480. Cheese uses 640x480 during its initial cam test and that failing causes the resolutions box to be empty.

Can you please try with ucview (yum install ucview), select a video format of RGB3 and a resolution of 320x240, then press OK. That should work (just like xawtv). Then quit ucview and try again, again with a video format of RGB3 and now with a resolution of 640x480, if I'm right that will fail and this is a driver bug. In which case the best I can do is to advice you to contact "Jean-Francois Moine <moinejf@free.fr>". Either way let me know how it goes.
Comment 10 Benjamín Valero Espinosa 2008-11-26 09:18:35 EST
It has failed as you predicted. I have contacted with Jean-François explaining him the same.
Comment 11 Benjamín Valero Espinosa 2009-02-08 05:04:00 EST
Well, I have just updated my FC10 and seen a new update for libv4l. Then, just by chance, I have checked again the tests you gave me, and now it works, either with Ucview or Cheese. Thank you!

Note You need to log in before you can comment on or make changes to this bug.