Bug 473019 - HTML: Author_Group "<orgname>" merged between "<surname>" and "<surname>"
HTML: Author_Group "<orgname>" merged between "<surname>" and "<surname>"
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: docbook-style-xsl (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
: 474076 476101 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-25 23:17 EST by Murray McAllister
Modified: 2016-04-26 12:19 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-13 10:08:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
HTML output build on Fedora 10 (12.00 KB, image/png)
2008-11-25 23:17 EST, Murray McAllister
no flags Details

  None (edit)
Description Murray McAllister 2008-11-25 23:17:19 EST
Created attachment 324690 [details]
HTML output build on Fedora 10

Description of problem:
In HTML output, the "<orgname>" tag is merged between the "<surname>" and "<surname>" tags.

Version-Release number of selected component (if applicable):

Fedora release 10 (Cambridge):

* publican-0.38-0.fc10.noarch
* publican-fedora-0.15-0.fc10.noarch
* fop-0.95-0.2.beta1.noarch
* saxon-6.5.5-1.3.fc10.noarch

How reproducible:
Always.

Steps to Reproduce:
1. yum install publican publican-fedora (or build from svn)
2. svn co http://svn.fedorahosted.org/svn/selinuxguide
3. make html-en-US
  
Actual results:
See attached.


Additional info:
Same issue occurs when building from svn, and when using publican-redhat brand.
Comment 1 Jeff Fearn 2008-11-25 23:41:50 EST
This is probably a bug in the docbook-xsl shipped in F10.

Please post the output of `rpm -q docbook-style-xsl`
Comment 2 Murray McAllister 2008-11-26 02:08:37 EST
docbook-style-xsl-1.74.0-3.fc10.noarch
Comment 3 Jeff Fearn 2008-11-30 17:48:39 EST
This is a bug in the non-customised XSL and is therefore not a bug in Publican.

You should transfer this bug to the appropriate Fedora component or open a bug upstream.

Below is my discussion of the problem that has been introduced in to the common XSL, hopeful this will help the package maintainers resolve this issue for you.

This issue is caused by a change to /usr/share/sgml/docbook/xsl-stylesheets-1.74.0/common/common.xsl

Line 577 reads:

  <xsl:if test="$node//orgname">
    <xsl:if test="$node//honorific or $node//firstname
                  or ($node//othername and $author.othername.in.middle != 0)">
      <xsl:text> </xsl:text>
    </xsl:if>
    <xsl:apply-templates select="$node//orgname[1]"/>
  </xsl:if>

The solution, IMHO, is to get a variable, which defaults off, added to that if statement.

e.g.

in params.xsl:

<xsl:param name="weird.use.of.orgname" select="0"/>

in common.xsl:

<xsl:if test="$node//orgname and $weird.use.of.orgname != 0">
Comment 4 Murray McAllister 2008-12-01 17:14:32 EST
docbook-style-xsl-1.74.0-3.fc10.noarch

See comment #3 ...
Comment 5 Murray McAllister 2008-12-01 19:56:06 EST
*** Bug 474076 has been marked as a duplicate of this bug. ***
Comment 6 Jeff Fearn 2008-12-11 18:25:20 EST
*** Bug 476101 has been marked as a duplicate of this bug. ***
Comment 7 Ondrej Vasik 2008-12-12 04:36:05 EST
Thanks for info and suggestions, it is not only for html output, but general problem in docbook-style-xsl 1.74.0. It does the same error even with xsltproc/passivetex for e.g. example from docbook.org site http://www.docbook.org/tdg/en/html/bookinfo.html ... will try to find out why they did the change and possibly use the approach suggested by Jeff in comment #3 - to keep that weird behaviour available for possible use.
Comment 8 Ondrej Vasik 2008-12-12 04:40:32 EST
From 1.74.0 Changelog:
● Michael(tm) Smith: common.xsl

    Added support for orgname in authorgroup. Thanks to Camille
    Bégnis.

http://lists.oasis-open.org/archives/docbook-apps/200802/msg00089.html
Comment 9 Ondrej Vasik 2008-12-12 05:31:25 EST
Upstream bug report tracker: http://sourceforge.net/tracker/index.php?func=detail&aid=2000787&group_id=21935&atid=373747

Fixed rawhide - built as docbook-style-xsl-1.74.0-4.fc11
Comment 10 Fedora Update System 2008-12-12 05:40:17 EST
docbook-style-xsl-1.74.0-4.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/docbook-style-xsl-1.74.0-4.fc10
Comment 11 Fedora Update System 2008-12-13 10:08:55 EST
docbook-style-xsl-1.74.0-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Murray McAllister 2008-12-14 17:26:53 EST
Thank you so much for fixing this so quick!

Note You need to log in before you can comment on or make changes to this bug.