Bug 473352 - Anaconda crashes trying to upgrade from Fedora9 to Fedora10
Anaconda crashes trying to upgrade from Fedora9 to Fedora10
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
: 475194 476507 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-27 17:34 EST by Oleg Drokin
Modified: 2009-09-03 17:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-03 17:39:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
exception log (105.53 KB, text/plain)
2008-11-27 17:34 EST, Oleg Drokin
no flags Details

  None (edit)
Description Oleg Drokin 2008-11-27 17:34:48 EST
Created attachment 324922 [details]
exception log

Description of problem:
When doing upgrade from Fedora10 DVD, I gt a message that anaconda encountered an exception.

I am attaching the log generated.
Might have something to do with my encrypted device.
Comment 1 Oleg Drokin 2008-11-27 18:42:16 EST
I just commented out this line in /etc/fstab and the upgrade proceeded past the point of failure:
/dev/mapper/backup /backups ext3 defaults 0 0
Comment 2 Chris Lumens 2008-12-08 09:57:38 EST
*** Bug 475194 has been marked as a duplicate of this bug. ***
Comment 3 Chris Lumens 2008-12-15 10:02:32 EST
*** Bug 476507 has been marked as a duplicate of this bug. ***
Comment 4 A.Russo 2008-12-19 23:21:25 EST
I too experienced this bug. However, paring my fstab down to only the installed hard drives (3 of them, all SATA) did not make any difference. 

I was using preupgrade from F9 to F10 on x86_64.

I'd be willing to beta test any fixes if you can instruct me how to do it within the preupgrade framework.
Comment 5 David Lehman 2008-12-22 14:08:49 EST
The basic problem is that there is no easy way to know that the device referenced by the fstab is a mapped LUKS device. (If the troublesome device is not a mapped LUKS device, you are seeing a different problem.)

The simplest solution is to change the mapping so that the mapped device starts with 'luks-', eg: 'luks-backups' (using the example from the original reporter). To do this, edit /etc/crypttab to change the mapping name so it begins with 'luks-', then edit /etc/fstab to use the new device (eg: /dev/mapper/luks-backups). After that, which should take no more than a few minutes, your upgrade should work.
Comment 6 Sam W. 2009-01-13 01:50:53 EST
I think I've run into something similar with an f8 to f10 upgrade using the DVD.  I'm seeing: "Error mapping device mapper/foo as /home/foo; mount: special device /dev/mapper/foo does not exist".

The same error appears whether or not the passphrase is provided.

The solution suggested (prepending "luks-" to all of the labels) worked (so far), and it had to be added to both the regular partition and encrypted swap partition entries.

At the very least, I suggest this be added to the known bugs list.

Note You need to log in before you can comment on or make changes to this bug.