Bug 473555 - X freeze on Radeon X300SE (RV370) with KDE4
X freeze on Radeon X300SE (RV370) with KDE4
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks: 474072
  Show dependency treegraph
 
Reported: 2008-11-29 06:14 EST by Alexander Gavrilov
Modified: 2009-12-18 02:01 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 02:01:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (692 bytes, text/plain)
2008-11-29 06:14 EST, Alexander Gavrilov
no flags Details
Xorg.0.log (59.22 KB, text/plain)
2008-11-29 06:15 EST, Alexander Gavrilov
no flags Details
ioctl backtrace log.bz2 (250.26 KB, application/x-bzip2)
2008-11-29 06:19 EST, Alexander Gavrilov
no flags Details

  None (edit)
Description Alexander Gavrilov 2008-11-29 06:14:23 EST
Created attachment 325077 [details]
xorg.conf

Description of problem:

After using KDE4 with XRender desktop effects for several hours,
X rendering operations suddenly start slowing down, which quickly
proceeds to a complete X freeze. The rest of the system remains
operative, so it is possible to reboot it either remotely, or
through the ATX power button.

Version-Release number of selected component (if applicable):

Fedora 9 upgraded to Fedora 10 + latest updates.

Updating to kernel-2.6.27.5-123.fc10.i686
and xorg-x11-drv-ati-6.9.0-58.fc10.i386 did not have any effect.

How reproducible:

Once or twice a day.

Additional info:

Attaching a debugger shows that X actually continues working,
but some ioctls hang in drm_fence_object_wait for minutes.

I'll try running with nomodeset, and without xorg.conf next.
Comment 1 Alexander Gavrilov 2008-11-29 06:15:23 EST
Created attachment 325078 [details]
Xorg.0.log
Comment 2 Alexander Gavrilov 2008-11-29 06:19:13 EST
Created attachment 325079 [details]
ioctl backtrace log.bz2

A log of ioctl backtraces from the debugger.
Points of freeze are marked by "----------".
Comment 3 H. Peter Anvin 2008-11-30 15:57:28 EST
I am having the same problem with Fedora 9 + latest updates, no Fedora 10 involved.  In addition to the problems described above, I get stray lines all over the screen.
Comment 4 Alexander Gavrilov 2008-12-02 03:07:32 EST
In my case removing xorg.conf doesn't help; on the other hand, I worked 2 days without freezes when I specified nomodeset. Now I added nomodeset to my grub.conf.

Do you need any additional information on this problem?
Comment 5 Kostas Georgiou 2008-12-17 13:59:39 EST
I see the same as also with an X300SE no desktop effects are enabled though. After a few hours of uptime ioctl starts stalling and the machine needs a reboot to recover, restarting X doesn't help.
Comment 6 Tim Jackson 2009-02-01 13:15:49 EST
I'm seeing the same issue (works fine initially, grinds to a halt after a couple of hours, reboot required) with a clean (up to date, as of today) F-10 install and an "ATI Technologies Inc RV370 5B60 [Radeon X300 (PCIE)]" card. No desktop effects, just using the standard GNOME desktop. Never had any issue with the same hardware on FC-6, F-8, F-9.

Haven't tried any debugging or running with nomodeset; will try the nomodeset workaround.
Comment 7 Tim Jackson 2009-02-07 12:26:26 EST
I tried the latest driver from koji (xorg-x11-drv-ati-6.10.0-2.fc10.x86_64) and it didn't help. Seems to work OK with the "nomodeset" kernel option though.
Comment 8 Bug Zapper 2009-11-18 04:03:55 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Bug Zapper 2009-12-18 02:01:39 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.