Bug 474961 - [fix available] OpenOffice.org seems to bind C-s to underscore
[fix available] OpenOffice.org seems to bind C-s to underscore
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: David Tardon
Fedora Extras Quality Assurance
:
: 478701 502773 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 22:13 EST by Jonathan Blandford
Modified: 2013-04-02 00:22 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-29 18:10:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Relevant part of keyboard shortcuts list (85.31 KB, image/png)
2008-12-08 03:35 EST, David Tardon
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 97088 None None None Never

  None (edit)
Description Jonathan Blandford 2008-12-05 22:13:53 EST
I just realized why I lost my document this week...
C-s seems to be bound to underline in OO-impress, so when I thought I was saving a document I was underlining words.
Comment 1 Caolan McNamara 2008-12-06 06:40:13 EST
That wouldn't be my own experience, and I imagine the locale is en_US.UTF-8.

Is the shortcut of ctrl+s listed in the file menu beside "save" ?
And if it is, if you create a blank document and whack ctrl+s then the save as dialog should appear, or if already saved and changes have been made then the save icon should be enabled and whacking ctrl+s should make it disable again.

Trying to see if the binding has become attached to something else instead of save in some "formal" way, or if there is some weird cockup
Comment 2 Jonathan Blandford 2008-12-07 22:09:22 EST
My locale is en_US.UTF-8, and I can duplicate it with a blank document.  Save is listed in the file menu as Ctrl+s.  It only seems to be like this in ooimpress, and not oowriter or oocalc.
Comment 3 David Tardon 2008-12-08 03:35:09 EST
Created attachment 326094 [details]
Relevant part of keyboard shortcuts list

The Ctrl+S shortcut is really redefined in impress, It's certainly been done by mistake, because, as you can see, underlining is already bound to Ctrl+U.
Comment 4 Caolan McNamara 2008-12-08 06:26:59 EST
And I have "Save" there under ctrl+s. I blew away my ~/.openoffice.org* dirs and set to en_US.UTF-8 and started impress and its still ctrl+s for Save.

caolanm->dtardon; can you back up your own ~/.openoffice.org* dirs and do the same, to see if it always reappears as underline after that, of if this might be an issue with the automigration stuff from an older version of OOo ?
Comment 5 Jonathan Blandford 2008-12-08 11:45:31 EST
FWIW, I am getting this with a fresh account.
Comment 6 David Tardon 2008-12-10 03:45:51 EST
Immediate fix is possible by running
cp -f /usr/lib64/openoffice.org/share/config/soffice.cfg/modules/simpress/accelerator/default.xml ~/.openoffice.org/3/user/config/soffice.cfg/modules/simpress/accelerator/custom.xml .
It destroys all custom-defined keyboard shortcuts.

dtardon->caolanm: I can commit it to CVS right now, without any waiting for acks as in RHEL, right?
Comment 7 Caolan McNamara 2008-12-10 04:22:52 EST
Ah, wrong location for en_US translation for accelerators so ends up being the first one found in the dir which must be why it refused to happen for me. I see that the accelerator file *also* as the bindings duplicated as two xml nodes.

Yeah, you can just commit to the fedora one without the pesky rhel ack system. Though I've taken the liberty of committing this one to F-10 and devel. Will be in next F-10 update and in >= rawhide 3.0.1-13.2
Comment 8 Caolan McNamara 2009-01-03 18:16:27 EST
*** Bug 478701 has been marked as a duplicate of this bug. ***
Comment 9 Fedora Update System 2009-01-13 03:46:57 EST
openoffice.org-3.0.1-15.1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/openoffice.org-3.0.1-15.1.fc10
Comment 10 Fedora Update System 2009-01-14 21:53:53 EST
openoffice.org-3.0.1-15.1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0390
Comment 11 Fedora Update System 2009-01-29 18:09:48 EST
openoffice.org-3.0.1-15.2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 David Tardon 2009-05-27 03:59:20 EDT
*** Bug 502773 has been marked as a duplicate of this bug. ***
Comment 13 David Tardon 2009-05-27 04:07:41 EDT
Anyone still affected by this problem after update to newer version should remove ~/.openoffice.org/3/user/config/soffice.cfg/modules/simpress/accelerator/custom.xml . After next start of openoffice.org fixed accelerators' configuration file will be used.

Note You need to log in before you can comment on or make changes to this bug.