Bug 475232 - missing dependencies prevent updating PackageKit-associated packages
missing dependencies prevent updating PackageKit-associated packages
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 475364 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-08 11:25 EST by Andre Robatino
Modified: 2008-12-12 22:04 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 23:35:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2008-12-08 11:25:39 EST
Description of problem:
[root@localhost ~]# yum update
Loaded plugins: refresh-packagekit, security
skype                                                    |  951 B     00:00     
skype/primary                                            | 1.3 kB     00:00     
skype                                                                       1/1
livna                                                    | 2.1 kB     00:00     
livna/primary_db                                         | 4.3 kB     00:00     
fedora                                                   | 2.8 kB     00:00     
fedora/primary_db                                        | 8.1 MB     00:52     
rpmfusion-free-updates                                   | 2.7 kB     00:00     
rpmfusion-free-updates/primary_db                        | 1.1 kB     00:00     
rpmfusion-nonfree-updates                                | 2.7 kB     00:00     
rpmfusion-nonfree-updates/primary_db                     | 1.1 kB     00:00     
rpmfusion-free                                           | 2.7 kB     00:00     
rpmfusion-free/primary_db                                | 259 kB     00:04     
updates                                                  | 2.3 kB     00:00     
updates/primary_db                                       | 1.1 MB     00:07     
rpmfusion-nonfree                                        | 2.7 kB     00:00     
rpmfusion-nonfree/primary_db                             |  66 kB     00:00     
Skipping security plugin, no data
Setting up Update Process
Resolving Dependencies
Skipping security plugin, no data
--> Running transaction check
--> Processing Dependency: libpackagekit-glib.so.10()(64bit) for package: gnome-packagekit
---> Package PackageKit-qt.x86_64 0:0.3.11-4.fc10 set to be updated
---> Package PackageKit-yum-plugin.x86_64 0:0.3.11-4.fc10 set to be updated
---> Package PackageKit-udev-helper.x86_64 0:0.3.11-4.fc10 set to be updated
---> Package PackageKit-yum.x86_64 0:0.3.11-4.fc10 set to be updated
---> Package PackageKit.x86_64 0:0.3.11-4.fc10 set to be updated
---> Package PackageKit-gstreamer-plugin.x86_64 0:0.3.11-4.fc10 set to be updated
--> Processing Dependency: libpackagekit-qt.so.10()(64bit) for package: kpackagekit
---> Package PackageKit-glib.x86_64 0:0.3.11-4.fc10 set to be updated
--> Finished Dependency Resolution
kpackagekit-0.3.1-4.fc10.x86_64 from installed has depsolving problems
  --> Missing Dependency: libpackagekit-qt.so.10()(64bit) is needed by package kpackagekit-0.3.1-4.fc10.x86_64 (installed)
gnome-packagekit-0.3.9-8.fc10.x86_64 from installed has depsolving problems
  --> Missing Dependency: libpackagekit-glib.so.10()(64bit) is needed by package gnome-packagekit-0.3.9-8.fc10.x86_64 (installed)
Error: Missing Dependency: libpackagekit-glib.so.10()(64bit) is needed by package gnome-packagekit-0.3.9-8.fc10.x86_64 (installed)
Error: Missing Dependency: libpackagekit-qt.so.10()(64bit) is needed by package kpackagekit-0.3.1-4.fc10.x86_64 (installed)
[root@localhost ~]#

Version-Release number of selected component (if applicable):
PackageKit-0.3.9-4.fc10.x86_64
Comment 1 Andre Robatino 2008-12-08 13:45:30 EST
From this

http://www.redhat.com/archives/fedora-list/2008-December/msg01446.html

it looks like it's not limited to 64-bit.  Changing platform to "All".
Comment 2 Gwyn Ciesla 2008-12-08 13:50:06 EST
(In reply to comment #1)
> From this
> 
> http://www.redhat.com/archives/fedora-list/2008-December/msg01446.html
> 
> it looks like it's not limited to 64-bit.  Changing platform to "All".

I confirm this.
Comment 3 Todd R. 2008-12-08 15:00:25 EST
The packages kpackagekit-0.3.1-4.fc10 and gnome-packagekit-0.3.9-8.fc10 the libraries, libpackagekit-qt.so.10 and libpackagekit-glib.so.10 respectively.

Removing kpackagekit and gnome-packagekit allows the PackageKit files to be updated which then in turn install the 'so.11' versions of the library dependencies and thus prevent the re-installation of kpackagekit and gnome-packagekit.

This renders the 'Add/Remove' software menu item broken with an error in 'gpk-application' (for gnome anyway).

Looks like the two packages need to be updated to use the new 'so.11' libraries.
Comment 4 Fedora Update System 2008-12-09 03:04:14 EST
PackageKit-0.3.12-1.fc10,gnome-packagekit-0.3.12-1.fc10,kpackagekit-0.3.1-9.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/PackageKit-0.3.12-1.fc10,gnome-packagekit-0.3.12-1.fc10,kpackagekit-0.3.1-9.fc10
Comment 5 Michael Schwendt 2008-12-09 09:58:55 EST
*** Bug 475364 has been marked as a duplicate of this bug. ***
Comment 6 Nicola Soranzo 2008-12-09 14:49:00 EST
*** Bug 475317 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2008-12-09 23:34:57 EST
PackageKit-0.3.12-1.fc10, gnome-packagekit-0.3.12-1.fc10, kpackagekit-0.3.1-9.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 N. Meek 2008-12-10 18:10:23 EST
(In reply to comment #3)
> The packages kpackagekit-0.3.1-4.fc10 and gnome-packagekit-0.3.9-8.fc10 the
> libraries, libpackagekit-qt.so.10 and libpackagekit-glib.so.10 respectively.
> 
> Removing kpackagekit and gnome-packagekit allows the PackageKit files to be
> updated which then in turn install the 'so.11' versions of the library
> dependencies and thus prevent the re-installation of kpackagekit and
> gnome-packagekit.
> 
> This renders the 'Add/Remove' software menu item broken with an error in
> 'gpk-application' (for gnome anyway).
> 
> Looks like the two packages need to be updated to use the new 'so.11'
> libraries.

If I understand what you mean here, I think I may have done this. I tried to uninstall kpackagekit and gnome-packagekit to fix my problem and now I can't get any packagekit things to reinstall. It seems to be some sort of circular dependency problem. Is there some way I can install packagekit without packagekit? I get a similar problem when I try to just install PackageKit-0.3.11-4



Here's what I get:
# yum install PackageKit-0.3.12-1.fc10.i386.rpm
Loaded plugins: dellsysidplugin, refresh-packagekit                
Setting up Install Process                                         
Parsing package install arguments                                  
Examining PackageKit-0.3.12-1.fc10.i386.rpm: PackageKit-0.3.12-1.fc10.i386
Marking PackageKit-0.3.12-1.fc10.i386.rpm as an update to PackageKit-0.3.11-4.fc10.i386
Resolving Dependencies                                                                 
--> Running transaction check                                                          
---> Package PackageKit.i386 0:0.3.12-1.fc10 set to be updated                         
--> Processing Dependency: PackageKit-glib = 0.3.12-1.fc10 for package: PackageKit     
--> Processing Dependency: PackageKit-udev-helper = 0.3.12-1.fc10 for package: PackageKit
--> Processing Dependency: PackageKit-yum = 0.3.12-1.fc10 for package: PackageKit
--> Processing Dependency: PackageKit-yum-plugin = 0.3.12-1.fc10 for package: PackageKit
--> Processing Dependency: PackageKit = 0.3.11-4.fc10 for package: PackageKit-qt
--> Processing Dependency: PackageKit = 0.3.11-4.fc10 for package: PackageKit-yum
--> Processing Dependency: PackageKit = 0.3.11-4.fc10 for package: PackageKit-glib
--> Finished Dependency Resolution
PackageKit-glib-0.3.11-4.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: PackageKit = 0.3.11-4.fc10 is needed by package PackageKit-glib-0.3.11-4.fc10.i386 (installed)
PackageKit-0.3.12-1.fc10.i386 from PackageKit-0.3.12-1.fc10.i386.rpm has depsolving problems
  --> Missing Dependency: PackageKit-glib = 0.3.12-1.fc10 is needed by package PackageKit-0.3.12-1.fc10.i386 (PackageKit-0.3.12-1.fc10.i386.rpm)
PackageKit-qt-0.3.11-4.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: PackageKit = 0.3.11-4.fc10 is needed by package PackageKit-qt-0.3.11-4.fc10.i386 (installed)
PackageKit-0.3.12-1.fc10.i386 from PackageKit-0.3.12-1.fc10.i386.rpm has depsolving problems
  --> Missing Dependency: PackageKit-yum-plugin = 0.3.12-1.fc10 is needed by package PackageKit-0.3.12-1.fc10.i386 (PackageKit-0.3.12-1.fc10.i386.rpm)
PackageKit-0.3.12-1.fc10.i386 from PackageKit-0.3.12-1.fc10.i386.rpm has depsolving problems
  --> Missing Dependency: PackageKit-udev-helper = 0.3.12-1.fc10 is needed by package PackageKit-0.3.12-1.fc10.i386 (PackageKit-0.3.12-1.fc10.i386.rpm)
PackageKit-yum-0.3.11-4.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: PackageKit = 0.3.11-4.fc10 is needed by package PackageKit-yum-0.3.11-4.fc10.i386 (installed)
PackageKit-0.3.12-1.fc10.i386 from PackageKit-0.3.12-1.fc10.i386.rpm has depsolving problems
  --> Missing Dependency: PackageKit-yum = 0.3.12-1.fc10 is needed by package PackageKit-0.3.12-1.fc10.i386 (PackageKit-0.3.12-1.fc10.i386.rpm)
Error: Missing Dependency: PackageKit = 0.3.11-4.fc10 is needed by package PackageKit-qt-0.3.11-4.fc10.i386 (installed)
Error: Missing Dependency: PackageKit-udev-helper = 0.3.12-1.fc10 is needed by package PackageKit-0.3.12-1.fc10.i386 (PackageKit-0.3.12-1.fc10.i386.rpm)
Error: Missing Dependency: PackageKit-yum = 0.3.12-1.fc10 is needed by package PackageKit-0.3.12-1.fc10.i386 (PackageKit-0.3.12-1.fc10.i386.rpm)
Error: Missing Dependency: PackageKit-yum-plugin = 0.3.12-1.fc10 is needed by package PackageKit-0.3.12-1.fc10.i386 (PackageKit-0.3.12-1.fc10.i386.rpm)
Error: Missing Dependency: PackageKit = 0.3.11-4.fc10 is needed by package PackageKit-yum-0.3.11-4.fc10.i386 (installed)
Error: Missing Dependency: PackageKit = 0.3.11-4.fc10 is needed by package PackageKit-glib-0.3.11-4.fc10.i386 (installed)
Error: Missing Dependency: PackageKit-glib = 0.3.12-1.fc10 is needed by package PackageKit-0.3.12-1.fc10.i386 (PackageKit-0.3.12-1.fc10.i386.rpm)
Comment 9 Andre Robatino 2008-12-11 00:06:04 EST
It looks like it's yet another one of those times when the update emails went out, but the actual updates never got pushed.  Considering the importance of this latest batch (the missing packagekit-associated packages, and the glibc update to fix the DNS issue) I hope someone will expedite this.
Comment 10 Otto 2008-12-11 06:22:43 EST
The problem remains:

# yum update
Plugins carregados: refresh-packagekit
Configurando o Processo de Atualização
Resolvendo Dependências
--> Executando verificação da transação
---> Pacote PackageKit.i386 0:0.3.11-4.fc10 definido para ser atualizado
---> Pacote PackageKit-gstreamer-plugin.i386 0:0.3.11-4.fc10 definido para ser atualizado
---> Pacote PackageKit-yum-plugin.i386 0:0.3.11-4.fc10 definido para ser atualizado
--> Processando Dependência: libpackagekit-glib.so.10 para o pacote: gnome-packagekit
---> Pacote PackageKit-yum.i386 0:0.3.11-4.fc10 definido para ser atualizado
---> Pacote PackageKit-udev-helper.i386 0:0.3.11-4.fc10 definido para ser atualizado
---> Pacote PackageKit-glib.i386 0:0.3.11-4.fc10 definido para ser atualizado
--> Resolução de Dependências Finalizada
gnome-packagekit-0.3.9-8.fc10.i386 a partir de installed tem problemas de resolução de dependências
  --> Dependência Faltando: libpackagekit-glib.so.10 é requerido pelo pacote gnome-packagekit-0.3.9-8.fc10.i386 (installed)
Error: Dependência Faltando: libpackagekit-glib.so.10 é requerido pelo pacote gnome-packagekit-0.3.9-8.fc10.i386 (installed)
Comment 11 Andre Robatino 2008-12-11 12:27:01 EST
The PackageKit-related packages have finally shown up on the mirrors.
Comment 12 pryza 2008-12-11 15:35:17 EST
I'am a little confused, is there a fix for the Error: Missing Dependency: PackageKit-glib = 0.3.12-1.fc10 is needed by package
PackageKit-0.3.12-1.fc10.i386 (PackageKit-0.3.12-1.fc10.i386.rpm)????
Comment 13 Andre Robatino 2008-12-12 16:33:48 EST
The dependency problems should be gone by now.
Comment 14 Otto 2008-12-12 22:04:24 EST
Yes, it's OK for me.

Note You need to log in before you can comment on or make changes to this bug.