Bug 475343 - [LTC 5.5 FEAT] Provide CMS script for initial IPL under z/VM [201594]
[LTC 5.5 FEAT] Provide CMS script for initial IPL under z/VM [201594]
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.5
s390x All
high Severity high
: beta
: 5.5
Assigned To: David Cantrell
Alexander Todorov
: FutureFeature, OtherQA
: 511983 (view as bug list)
Depends On:
Blocks: 533941 557292 481160 531114
  Show dependency treegraph
 
Reported: 2008-12-08 17:10 EST by IBM Bug Proxy
Modified: 2010-03-30 04:00 EDT (History)
9 users (show)

See Also:
Fixed In Version: anaconda-11.1.2.200-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 04:00:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Proposed CMS script: RHEL.EXEC (219 bytes, text/plain)
2009-01-06 11:40 EST, Brad Hinson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 50341 None None None Never

  None (edit)
Description IBM Bug Proxy 2008-12-08 17:10:31 EST
=Comment: #0=================================================
Emily J. Ratliff <ratliff@austin.ibm.com> - 
1. Feature Overview:
Feature Id:	[201594]
a. Name of Feature:	Provide CMS script for initial IPL under z/VM
b. Feature Description
After having loaded the three necessary install files (kernel,
  parameter file, initrd) to a VM guest, e.g. via FTP, the user has to
  IPL the initial install process of zLinux. This requires the execution
  of CMS commands, which the user might not be familiar with. Although
  there are in the documentation predefined CMS scripts to setup the VM reader and finally IPL the
zLinux installation, the
  user would still have to bring such a script into his guest.
 
 A script should be provided per enterprise distribution,
  which uses the distro specific
 naming scheme for kernel, parameter file, and initrd. This script
 should be placed in the directory of the distro shipping media
 (DVD/CD/FTP server), where the other three files already reside. This
 way, the user gets relieved from e.g. entering such a script using
 xedit in the CMS environment and can simply download it using FTP
 along with the three other files and then execute it.
 
System z requests that Red Hat  take such a CMS EXEC from you current documentation and ship it with
5.4+.
 
The corresponding architecture specific installation documentation should be updated accordingly.

2. Feature Details:
Sponsor:	zSeries
Architectures:
s390x

Arch Specificity: Purely Arch Specific Code
Affects Installer: Yes
Delivery Mechanism: Request Red Hat development assistance
Category:	zSeries
Request Type:	Installer - Enhancement from Distributor
d. Upstream Acceptance:	No Code Required
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	no
g. Component Version Target:	n/a

3. Business Case
Avoid customer frustration during installation, by just needing to know how to FTP from z/VM
(instead of having to learn how to use z/VM editor).

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):

Gonzalo Muelas Serrano, gmuelas@de.ibm.com

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 1 John Jarvis 2008-12-22 12:19:03 EST
IBM is signed up to test and provide feedback.
Comment 2 Brad Hinson 2009-01-06 11:40:24 EST
Created attachment 328295 [details]
Proposed CMS script: RHEL.EXEC
Comment 3 Steffen Maier 2009-03-17 12:51:54 EDT
[I made the same comment on 2009-01-16 07:08:25 EST in the corresponding LTC bug but for some reason it didn't get mirrored which I only figured out now by accident.]

(In reply to comment #2)
> Created an attachment (id=328295) [details]
> Proposed CMS script: RHEL.EXEC  

Brad, thanks a lot for your proposed CMS script.

Please make sure the file names referenced in the script match those customers
are already used to from the existing install guide documentation. Let's not
forget to also update the install guide documentation so the customers know of
the new script and how to use it effectively. See comment 14 of LTC bug 48079
or
https://bugzilla.redhat.com/show_bug.cgi?id=462953#c10 respectively for more
details as we've discussed this for RHEL6 already and the same content applies
here for RHEL5.4.
Comment 4 RHEL Product and Program Management 2009-03-26 13:25:11 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 5 IBM Bug Proxy 2009-03-30 06:11:28 EDT
------- Comment From gmuelas@de.ibm.com 2009-03-30 06:01 EDT-------
Hello Red Hat Product Management,
what is the concrete reason to reject this feature for RHEL 5.4?
what would be Red Hat's impact of accepting this feature for RHEL 5.4?

Thank you!
Gonzalo Muelas Serrano.
Comment 7 IBM Bug Proxy 2009-04-21 23:20:55 EDT
------- Comment From tpnoonan@us.ibm.com 2009-04-21 23:17 EDT-------
Hi John, Would you please take a second look at the following three rejected System z features for RHEL5.4
based on the justifications provided. It looks like these are being rejected due to Red Hat resources???.
All three look to improve the IBM/Red Hat System z customer experience.
The justifications are also documented in the feature bugzillas.

Many thanks.

2.) Provide CMS script for initial IPL under z/VM
Red Hat Bugzilla  475343 LTC 50341 ??-?? [LTC 5.4 FEAT] Provide CMS script for initial IPL under z/VM [201594]

Status:
Red Hat developed and proposed CMS script

Red Hat reason for reject:
This component is not scheduled to be updated in
the current Red Hat Enterprise Linux release.

Business justification:
This feature will significantly simplify the installation under z/VM (most common installation) for new customers that do not have z/VM skills, and save some work for all the customers installing on a new z/VM guest, since the script needed to generate under z/VM to start the installation under z/VM, can simply be downloaded from the install DVD.
Without this feature, the customer will have to spend some time learning how to use XEDIT (z/VM editor) to create the script, type it and finally use it. This precious time/skill-gap can easily be avoid but delivering the script requested.
Comment 8 IBM Bug Proxy 2009-04-27 13:11:36 EDT
------- Comment From mgrf@de.ibm.com 2009-04-27 13:04 EDT-------
Hello Red Hat, Hi John,
What is the status regarding RHEL 5.4 acceptance for this feature?
Comment 9 John Jarvis 2009-04-27 14:34:40 EDT
This feature is denied for RHEL 5.4 due to a lack of resources.
Comment 10 IBM Bug Proxy 2009-04-28 08:31:48 EDT
------- Comment From gmuelas@de.ibm.com 2009-04-28 08:22 EDT-------
Hello Red Hat,

IBM is not quite sure if this request was properly understood:

The CMS script requested does already exist, so there is nothing new to develop. [1]
Also the script does NOT affect the installer in any way. It is a REXX script to be executed in the CMS operating system under z/VM in order to boot the installation. This has to be done by all users under z/VM anyway. Shipping the script on the DVD reliefs users from typing it manually themselves which is error prone and unnecessary.
Shipping the script on the DVD only requires the addition of a single line to scripts/mk-images.s390 [2]:
cp -v $BOOTDISKDIR/redhat.exec $TOPDESTPATH/images/redhat.exec

A suggestion for an update of the RHEL Install Guide already exists [1] and if you like, Steffen Maier (IBM) would even provide a patch to the DocBook sources, so you just had to apply it. Nothing more to do from your side.

An of course, IBM would test it.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=462953#c10
[2] http://git.fedorahosted.org/git/anaconda.git?p=anaconda.git;a=commitdiff;h=51a505e605018a9d97ffe1b2b54c9c005041119b;hp=0f7f33279b7131139ad45d7bcaed13ac7ded03e5

Is it still not possible to get it accepted for RHEL 5.4?

Thank you!
Gonzalo Muelas Serrano.
Comment 11 IBM Bug Proxy 2009-07-15 08:22:56 EDT
(In reply to comment #5)
> Created an attachment (id=42083) [details]


Please make sure the file names referenced in the script match those customers are already used to from the existing install guide documentation. Let's not forget to also update the install guide documentation so the customers know of the new script and how to use it effectively. See comment 14 of LTC bug 48079 or
https://bugzilla.redhat.com/show_bug.cgi?id=462953#c10 respectively for more details as we've discussed this for RHEL6 already and the same content applies here for RHEL5.4.














> Proposed CMS script: RHEL.EXEC

Brad, thanks a lot for your proposed CMS script.


------- Comment From mgrf@de.ibm.com 2009-07-15 08:12 EDT-------
This feature has been rejected by Red Hat due to lack of resources.
Despite a cms script is already proposed.
Deferring feature request to RHEL 5.5
Comment 12 IBM Bug Proxy 2009-07-16 08:11:11 EDT
------- Comment From mgrf@de.ibm.com 2009-07-16 08:01 EDT-------
This request got a new feature BZ for RHEL 5.5 that is

LTC 54795 - RHBZ 511983  [LTC 5.5 FEAT] Provide CMS script for initial IPL under z/VM [201594]

Therefore closing this for RHEL 5.4 with "willnotfix" based on Red Hat reject
Comment 13 IBM Bug Proxy 2009-08-03 07:50:58 EDT
------- Comment From mgrf@de.ibm.com 2009-08-03 07:49 EDT-------
*** Bug 54795 has been marked as a duplicate of this bug. ***
Comment 14 IBM Bug Proxy 2009-08-03 08:01:26 EDT
------- Comment From mgrf@de.ibm.com 2009-08-03 07:55 EDT-------
As agreed with John:

Re-open old RHEL 5.4 feature to request for inclusion into RHEL 5.5.
That is to have done discussions included in feature request

Note:
The new opened RHEL 5.5 feature BZ get closed
LTC 54795 - RHBZ 511983  [LTC 5.5 FEAT] Provide CMS script for initial IPL under z/VM [201594]
Comment 15 John Jarvis 2009-08-03 09:44:29 EDT
*** Bug 511983 has been marked as a duplicate of this bug. ***
Comment 16 IBM Bug Proxy 2009-09-04 03:50:41 EDT
------- Comment From mgrf@de.ibm.com 2009-09-04 03:48 EDT-------
Summary:
There is no IBM code to be delivered for this feature
A script is already prepared by Red Hat

Please ensure the review results get worked into the script

The review results from previous comment:
> Brad, thanks a lot for your proposed CMS script.

>Please make sure the file names referenced in the script match those
> customers are already used to from the existing install guide documentation.
> Let's not forget to also update the install guide documentation so the
> customers know of the new script and how to use it effectively.
> see comment # 10 of RHBZ 462953,
>  https://bugzilla.redhat.com/show_bug.cgi?id=462953#c10
> respectively for more details as we've discussed this for RHEL6 already and
> the same content applies here for RHEL5.4.
Comment 17 John Jarvis 2009-10-26 09:25:19 EDT
IBM is signed up to test and provide feedback.
Comment 18 Denise Dumas 2009-11-03 09:38:08 EST
Per our discussion last week, I will set up a technical meeting on this BZ and other IBM requests in early January to look at this for a future RHEL5 release.
Denise
Comment 19 IBM Bug Proxy 2009-11-03 10:02:18 EST
------- Comment From gmuelas@de.ibm.com 2009-11-03 09:56 EDT-------
Denise,
actually for this concrete feature, I thought that we agree that you would check with David since it was already upstream an it is only about delivering a text file (script to boot) so that the user can just download it and do not have to create it under z/VM... and update the documentation informing the user of the existence of this script.

Could you check with David?

Thank you!
Gonzalo.
Comment 20 David Cantrell 2009-11-03 14:26:40 EST
We can cherry-pick this from the master or rhel6-branch.
Comment 21 IBM Bug Proxy 2009-11-03 15:10:41 EST
------- Comment From MAIER@de.ibm.com 2009-11-03 15:00 EDT-------
(In reply to comment #25)
> We can cherry-pick this from the master or rhel6-branch.

David, when you do please make sure the file names referenced in the script match those customers
are already used to from the existing install guide documentation.
I.e. https://www.redhat.com/archives/anaconda-devel-list/2009-October/msg00280.html should only apply to RHEL6 as a new major release but for RHEL5 the old parm file name should be used in the rexx script.
Comment 22 David Cantrell 2009-12-20 20:18:55 EST
Since this is a REXX script change and it's done upstream, pulling this in to 5.5 is simple.  Giving it a devel-ack.
Comment 24 John Jarvis 2009-12-21 12:02:25 EST
This enhancement request was evaluated by the full Red Hat Enterprise Linux 
team for inclusion in a Red Hat Enterprise Linux minor release.   As a 
result of this evaluation, Red Hat has tentatively approved inclusion of 
this feature in the next Red Hat Enterprise Linux Update minor release.   
While it is a goal to include this enhancement in the next minor release 
of Red Hat Enterprise Linux, the enhancement is not yet committed for 
inclusion in the next minor release pending the next phase of actual 
code integration and successful Red Hat and partner testing.
Comment 25 David Cantrell 2009-12-22 14:50:31 EST
Fix add to anaconda git repository (commit 8088530d5b677d644113e8109558ef5c2ec6e7aa).  anaconda-11.1.2.200-1 will be the next release of anaconda in RHEL-5.5 that will include this fix.
Comment 27 Chris Ward 2010-02-11 05:33:26 EST
~~ Attention Customers and Partners - RHEL 5.5 Beta is now available on RHN ~~

RHEL 5.5 Beta has been released! There should be a fix present in this 
release that addresses your request. Please test and report back results 
here, by March 3rd 2010 (2010-03-03) or sooner.

Upon successful verification of this request, post your results and update 
the Verified field in Bugzilla with the appropriate value.

If you encounter any issues while testing, please describe them and set 
this bug into NEED_INFO. If you encounter new defects or have additional 
patch(es) to request for inclusion, please clone this bug per each request
and escalate through your support representative.
Comment 28 IBM Bug Proxy 2010-02-16 09:51:09 EST
------- Comment From mgrf@de.ibm.com 2010-02-16 09:43 EDT-------
This feature is verified with one bug reported:

LTC 59980 - RIT457983  [RHEL5.5 Alpha] Documentation updation regarding CMS exec (redhat.exec) shipped now along with ISO
Comment 29 Alexander Todorov 2010-02-18 11:20:04 EST
The redhat.exec script is shipped in the s390x tree. 
Moving to VERIFIED as per comment #28. Documentation is a separate issue.
Comment 31 errata-xmlrpc 2010-03-30 04:00:47 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0194.html

Note You need to log in before you can comment on or make changes to this bug.