Bug 475350 - [LTC 5.4 FEAT] Dialog defaults for Linux on System z specific Anaconda [201677]
[LTC 5.4 FEAT] Dialog defaults for Linux on System z specific Anaconda [201677]
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.4
s390x All
high Severity high
: alpha
: 5.4
Assigned To: David Cantrell
Release Test Team
: FutureFeature, OtherQA
: 460575 472936 475345 475346 (view as bug list)
Depends On:
Blocks: 445204 472936 483784
  Show dependency treegraph
 
Reported: 2008-12-08 17:30 EST by IBM Bug Proxy
Modified: 2011-01-24 18:36 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
The RHEL installation process now includes specific parameter recommendations and defaults when installing onto the System z platform. Anaconda now suggests sensible default answers based on internal heuristics that evaluate the device configuration in sys-fs.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:52:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
list sensible network device hardware setups for Linux on System z (11.91 KB, text/plain)
2009-01-15 15:38 EST, IBM Bug Proxy
no flags Details
extended initial installation dialog for RHEL on System z (103.33 KB, text/plain)
2009-01-15 15:38 EST, IBM Bug Proxy
no flags Details
list sensible network device hardware setups for Linux on System z (11.91 KB, text/plain)
2009-03-12 10:54 EDT, IBM Bug Proxy
no flags Details
extended initial installation dialog for RHEL on System z (104.13 KB, text/plain)
2009-03-12 10:54 EDT, IBM Bug Proxy
no flags Details
enable configuration of IPv6 for (real) HiperSockets in layer3 mode (3.79 KB, text/plain)
2009-07-21 07:01 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 50343 None None None Never

  None (edit)
Description IBM Bug Proxy 2008-12-08 17:30:28 EST
=Comment: #0=================================================
Emily J. Ratliff <ratliff@austin.ibm.com> - 
1. Feature Overview:
Feature Id:	[201677]
a. Name of Feature:	Dialog defaults for Linux on System z specific Anaconda
b. Feature Description
During the interactive entry of System z specific parameters at the beginning of the anaconda
install process, it is hard for unexperienced users to get all answers syntactically and
semantically right.

Therefore, anaconda should suggest sensible default answers or let the user choose from a list of
answers based on internal heuristics that evaluate the device configuration in sys-fs. This is
possible in VM guests which usually have relatively few devices attached. In order to keep this
approach also feasible in LPAR environments, the user should only get a choice of answers/devices,
if there are less than or equal to 10 devices per class (disk or network). Otherwise, the user
should have the choice whether he wants to see the entire possibly very long list of suggestions or
he wants to fall back to manually specifying the necessary information.
 
The corresponding architecture specific installation documentation should be updated accordingly.

2. Feature Details:
Sponsor:	zSeries
Architectures:
s390x

Arch Specificity: Both
Affects Installer: Yes
Delivery Mechanism: Backport
Category:	Installation
Request Type:	Installer - Enhancement from Distributor
d. Upstream Acceptance:	No Code Required
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	no
g. Component Version Target:	n/a

3. Business Case
Improve the customer satisfaction through a better experience when installing the product.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 2 IBM Bug Proxy 2009-01-15 15:38:03 EST
Created attachment 329136 [details]
list sensible network device hardware setups for Linux on System z
Comment 3 IBM Bug Proxy 2009-01-15 15:38:07 EST
Created attachment 329137 [details]
extended initial installation dialog for RHEL on System z
Comment 4 IBM Bug Proxy 2009-03-12 10:54:28 EDT
Created attachment 334938 [details]
 list sensible network device hardware setups for Linux on System z 


------- Comment (attachment) From hans@linux.vnet.ibm.com 2009-03-12 10:46 EDT-------


"Updated patches as discussed in RHEL 5.4 Installer eSDT to reflect correct
handling/user interaction of MAC address with Layer2 devices and text for
CTC for migration purposes, which remains deprecated".
Comment 5 IBM Bug Proxy 2009-03-12 10:54:32 EDT
Created attachment 334939 [details]
extended initial installation dialog for RHEL on System z 


------- Comment (attachment) From hans@linux.vnet.ibm.com 2009-03-12 10:47 EDT-------


"Updated patches as discussed in RHEL 5.4 Installer eSDT to reflect correct
handling/user interaction of MAC address with Layer2 devices and text for
CTC for migration purposes, which remains deprecated".
Comment 6 David Cantrell 2009-04-16 20:10:57 EDT
*** Bug 475345 has been marked as a duplicate of this bug. ***
Comment 7 David Cantrell 2009-04-16 20:11:43 EDT
*** Bug 475346 has been marked as a duplicate of this bug. ***
Comment 8 David Cantrell 2009-04-16 20:12:44 EDT
Can IBM agree to QA this change for RHEL 5.4?
Comment 9 David Cantrell 2009-04-16 20:20:47 EDT
*** Bug 472936 has been marked as a duplicate of this bug. ***
Comment 10 IBM Bug Proxy 2009-04-17 03:21:09 EDT
------- Comment From mgrf@de.ibm.com 2009-04-17 03:17 EDT-------
With taking this as the reference BZ and flagging the others DUP
the linuxrc.s390 enhancemetns are  acceptex for RHEL 5.4 as confirmed via mail in advance:
...
>Just so noone is surprised to see the bugzillas change - we are
>definitely taking the updated linuxrc.S390 into RHEL5.4 and RHEL6 (thank
>you Steffen!), but to simplify internal processing, David is going to
>open a single bugzilla per release to track the linuxrc change and close
>the other BZs with a pointer to the new BZ.
>
>Regards,
>Denise
Comment 12 IBM Bug Proxy 2009-04-17 12:13:45 EDT
------- Comment From gmuelas@de.ibm.com 2009-04-17 12:10 EDT-------
Hello Red Hat,
if QA is to do the testing and if any problem arise related to this provided code, to fix it, yes IBM will test this feature with RHEL 5.4 and RHEL 6 and fix any issues related with this provided code.

FYI - before providing the code, we have already tested based on RHEL 5.3 GA with positive results.

Thank you,
Gonzalo Muelas Serrano.
Comment 13 John Jarvis 2009-04-30 09:47:56 EDT
This enhancement request was evaluated by the full Red Hat Enterprise Linux 
team for inclusion in a Red Hat Enterprise Linux minor release.   As a 
result of this evaluation, Red Hat has tentatively approved inclusion of 
this feature in the next Red Hat Enterprise Linux Update minor release.   
While it is a goal to include this enhancement in the next minor release 
of Red Hat Enterprise Linux, the enhancement is not yet committed for 
inclusion in the next minor release pending the next phase of actual 
code integration and successful Red Hat and partner testing.
Comment 14 David Cantrell 2009-05-06 14:36:50 EDT
Patch merged in to anaconda git repository.  Will be in anaconda-11.1.2.174-1 and later builds.
Comment 15 David Cantrell 2009-05-11 16:03:13 EDT
*** Bug 460575 has been marked as a duplicate of this bug. ***
Comment 18 Issue Tracker 2009-05-15 11:44:59 EDT
------- Comment From MAIER@de.ibm.com 2009-05-14 07:19 EDT-------
(In reply to LTC comment #16 / RH comment #4)
> These changes made by dcantrell@redhat.com.
> Bugzilla comment added:
> IBM improvements to linuxrc.s390 provide ipv6 support, closing this bug
as a
> duplicate of bug #475350.

Hi David,

you are correct with regard to IPv6 support within linuxrc.s390 and as
such it is valid to make this a dup of LTC bug #50343 / RH bug #475350.

However, the transfer of IPv6 configuration from linuxrc.s390 into loader
(to get it finally to anaconda), is still incomplete. Am I correct to
assume, that network install over IPv6 works with platforms other than
s390? If so, we would like to see this working on s390 also. That is why
we already added IPv6 support to linuxrc.s390 which was certainly the
biggest step to get to a working network install over IPv6 on s390.
Unfortunately, I could not add a complete transfer of IPv6 configuration
to the loader, since I did not understand exactly how the IPv6
configuration is represented in the loader. We need your help there.

How are we going to get to a working install over IPv6 on s390, i.e. how
do we add the little missing piece for transferring the IPv6 configuration
to linuxrc.s390 and, if necessary, loader? In this bug by reopening or do
you want me to open another new bug for that?

Regards,
Steffen


This event sent from IssueTracker by jkachuck 
 issue 215634
Comment 19 Steffen Maier 2009-05-15 12:12:16 EDT
(In reply to comment #18)
> ------- Comment From MAIER@de.ibm.com 2009-05-14 07:19 EDT-------

Just for clarification: I'm sorry, the above cited comment was done and meant for RH Bug 460575 but appears here because that bug is a dup.

Steffen
Comment 20 Chris Ward 2009-06-14 19:17:25 EDT
~~ Attention Partners RHEL 5.4 Partner Alpha Released! ~~

RHEL 5.4 Partner Alpha has been released on partners.redhat.com. There should
be a fix present that addresses this particular request. Please test and report back your results here, at your earliest convenience. Our Public Beta release is just around the corner!

If you encounter any issues, please set the bug back to the ASSIGNED state and
describe the issues you encountered. If you have verified the request functions as expected, please set your Partner ID in the Partner field above to indicate successful test results. Do not flip the bug status to VERIFIED. Further questions can be directed to your Red Hat Partner Manager. Thanks!
Comment 21 John Jarvis 2009-06-16 13:50:58 EDT
*** Bug 460575 has been marked as a duplicate of this bug. ***
Comment 22 Chris Ward 2009-07-03 14:15:58 EDT
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.
Comment 23 IBM Bug Proxy 2009-07-03 16:11:10 EDT
------- Comment From MAIER@de.ibm.com 2009-07-03 16:03 EDT-------
Thanks a lot Red Hat for integrating this improvement of linuxrc.s390.

Unfortunately, the following bugs currently block further verification of this item with RHEL 5.4 beta1, since IPv6 addresses are always rejected due to a bug in /sbin/ipcalc inside initrd called to check IP address syntax:

LTC Bug 47464 / RIT 215634 / RH bug 460575 : s390 support for installation over IPv6
LTC Bug 47462 / RIT 215500 / RH bug 460579 : linuxrc.s390 needs a tool to validate text representations of IPv6 addresses

Additionally, install over network types ctc and netiucv is broken due to the untouched way loader configures devices in RHEL 5.4 beta1. This has nothing to do with the rewrite of linuxrc.s390.

So far, I could successfully verify manual installations over IPv4 with the following combinations of network types and install repositories/methods:
hsi layer2, nfs
hsi layer3, http
lcs, ftp
osa layer2, ftp
osa layer3, ftp
guestlan qdio layer2, nfs
guestlan qdio layer3, http
guestlan hipersocket, ftp.
Additionally, the following combinations were successfully tested in fully unattended mode with parm file and kickstart:
hsi layer2, nfs
osa layer2, ftp.
Comment 24 Chris Ward 2009-07-03 16:52:12 EDT
I've set bug 460579 as a TestBlocker. Thanks for posting your results. We'll work on getting these issues resolved as soon as possible.
Comment 25 Shawn Wells 2009-07-06 18:21:15 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
The RHEL installation process now includes specific parameter recommendations and defaults when installing onto the System z platform. Anaconda now suggests sensible default answers based on internal heuristics that evaluate the device configuration in
sys-fs.
Comment 26 Shawn Wells 2009-07-06 18:22:33 EDT
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1,2 +1 @@
-The RHEL installation process now includes specific parameter recommendations and defaults when installing onto the System z platform. Anaconda now suggests sensible default answers based on internal heuristics that evaluate the device configuration in
+The RHEL installation process now includes specific parameter recommendations and defaults when installing onto the System z platform. Anaconda now suggests sensible default answers based on internal heuristics that evaluate the device configuration in sys-fs.-sys-fs.
Comment 27 Chris Ward 2009-07-10 15:07:31 EDT
~~ Attention Partners - RHEL 5.4 Snapshot 1 Released! ~~

RHEL 5.4 Snapshot 1 has been released on partners.redhat.com. If you have already reported your test results, you can safely ignore this request. Otherwise, please notice that there should be a fix available now that addresses this particular request. Please test and report back your results here, at your earliest convenience. The RHEL 5.4 exception freeze is quickly approaching.

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Do not flip the bug status to VERIFIED. Instead, please set your Partner ID in the Verified field above if you have successfully verified the resolution of this issue. 

Further questions can be directed to your Red Hat Partner Manager or other appropriate customer representative.
Comment 29 IBM Bug Proxy 2009-07-20 09:41:17 EDT
------- Comment From mgrf@de.ibm.com 2009-07-20 09:38 EDT-------
This feature is verified on RHEL 5.4 using IPv4
As this feature is flagged DUP to 50343   - RHBZ 475350 on Red Hat site

Closing feature request.

The IPv6 testing will be tracked with feature verification for
50343   - RHBZ 475350 [LTC 5.4 FEAT] Dialog defaults for Linux on System z
specific Anaconda [201677]

The required fix for IPv6 is expected in Anaconda with rc1

Test results:

Unfortunately, the following bugs currently block further verification of this
item with RHEL 5.4 beta1, since IPv6 addresses are always rejected due to a bug
in /sbin/ipcalc inside initrd called to check IP address syntax:

LTC Bug 47464 / RIT 215634 / RH bug 460575 : s390 support for installation over
IPv6
LTC Bug 47462 / RIT 215500 / RH bug 460579 : linuxrc.s390 needs a tool to
validate text representations of IPv6 addresses

Additionally, install over network types ctc and netiucv is broken due to the
untouched way loader configures devices in RHEL 5.4 beta1. This has nothing to do with the rewrite of linuxrc.s390.

So far, I could successfully verify manual installations over IPv4 with the
following combinations of network types and install repositories/methods:
Additionally, the following combinations were successfully tested in fully
unattended mode with parm file and kickstart:
Comment 30 IBM Bug Proxy 2009-07-20 09:51:32 EDT
------- Comment From mgrf@de.ibm.com 2009-07-20 09:46 EDT-------







untouched way loader configures devices in RHEL 5.4 beta1. This has nothing to
do with the rewrite of linuxrc.s390.
Comment 31 IBM Bug Proxy 2009-07-21 06:51:10 EDT
------- Comment From MAIER@de.ibm.com 2009-07-21 06:45 EDT-------
FYI

(In reply to comment #29)
> This feature is verified on RHEL 5.4 using IPv4
> As this feature is flagged DUP to 50343   - RHBZ 475350 on Red Hat site
>
> Closing feature request.

The above cited comment belongs to
LTC Bug 50342 / RH Bug 475346: [LTC 5.4 FEAT] Improve checking mechanisms and workflow of Linux on System z Anaconda install process [201676]
and
LTC Bug 50344 / RH Bug 475345: [LTC 5.4 FEAT] Change list of Anaconda network alternatives to indicate supported devices on System z [201679]
It only appears here because of the duplicate dependencies.
Comment 32 IBM Bug Proxy 2009-07-21 07:01:18 EDT
Created attachment 354458 [details]
enable configuration of IPv6 for (real) HiperSockets in layer3 mode


------- Comment on attachment From MAIER@de.ibm.com 2009-07-21 06:58 EDT-------


The current version of linuxrc.s390 as shipped with this feature bug and as contained in RHEL 5.4 snap2 prevents users to configure IPv6 for (real) HiperSockets in layer3 mode.
Meanwhile I got to know that this constraint is no longer necessary, since RHEL 5.4 does contain another feature backport enabling IPv6 on (real) HiperSockets in layer3 mode:
LTC bug 50359 / RH bug 475572: [LTC 5.4 FEAT] HiperSockets Layer3 support for IPv6 [201751] 

This patch enables the configuration of IPv6 for (real) HiperSockets in layer3 mode. The patch has been sniff tested.

Red Hat please apply on top of the current code base.

I'm sorry for any inconvenience.
Comment 33 Chris Ward 2009-07-21 07:26:56 EDT
IBM, please clarify your request. We are at a blocker bug only stage in the release cycle, so unless it can be justified that the request you're making is urgent (comment #32), with a strong business case, the request will need to be filed as a new bug and requested for RHEL 5.5 inclusion. The urgency of sorting this out is high. There is only a few short window now to commit new changes for 5.4.
Comment 34 IBM Bug Proxy 2009-07-21 09:32:19 EDT
------- Comment From MAIER@de.ibm.com 2009-07-21 09:28 EDT-------
Red Hat,
you are right that it would be too risky to bring this in for 5.4, thanks for pointing this out.
Please ignore my previous attachment titled
"enable configuration of IPv6 for (real) HiperSockets in layer3 mode".
We plan to report it by means of a new bug against 5.4 GA so it can go into 5.5.
Comment 35 Chris Ward 2009-07-21 10:15:39 EDT
Thank you. If there is not already a bug filed for the IPv6 issue, now would be a good time to file it. I suggest cloning this bug and requesting that your Partner Manager flag it for RHEL 5.5.
Comment 36 IBM Bug Proxy 2009-07-23 21:51:15 EDT
------- Comment From markver@us.ibm.com 2009-07-23 21:49 EDT-------
As discussed with Steffen,  with respect to the IPv6 support status,  this is currently what we see in Poughkeepsie:

- Snapshot3 appears to resolve the issue of all ipv6 IP getting rejected for installation (bug 47462).

- http install source using IPv6 seems to be supported (specified install server as [feff::20])
... was able to perform install following IPv6 scenario with partial success:

- The issues seen with the http install revolve around the question of required configuration for proper routing to occur ...
*  Have tried "automatic neighbor discovery" but with this the qeth device did not pick up any site or wider area IP (maybe either because of compatibility issues or bad configuration from radvd server ...).
*  Tried manual IP but with this the system ignores the router advertisement packet from radvd server and never sets up a default route (using GATEWAY=<my-router-site-IP> did not work).  On systems where the interface is manually enabled with an IPv6 address, a route like the following pointing to router link address seems to automatically get set up:
default via fe80::5:ff:fe00:33 dev eth2  proto kernel  metric 1024  expires 1601sec mtu 1280 advmss 1220 hoplimit 64
* What works for me is manually tweaking the ifcfg file after installation so that it has both a manually configured IP and automatic neighbor discover set on, ex:
[root@m36distr02 ~]# cat /etc/sysconfig/network-scripts/ifcfg-hsi0
# IBM HiperSockets
DEVICE=hsi0
BOOTPROTO=static
IPV6ADDR=fefc::3/80
IPV6INIT=yes
IPV6_AUTOCONF=yes
MACADDR=02:05:03:00:00:ff
NETTYPE=qeth
ONBOOT=yes
OPTIONS="layer2=1"
SUBCHANNELS=0.0.e000,0.0.e001,0.0.e002
[root@m36distr02 ~]#

- Am still playing with FTP support on the installation (haven't even begun to look at nfs support for ipv6).
Comment 37 IBM Bug Proxy 2009-07-23 22:01:21 EDT
------- Comment From markver@us.ibm.com 2009-07-23 21:50 EDT-------
Sorry, link got sent before ready.

The IPv6 partial install attempt was:
hsi layer2,  http
Comment 38 IBM Bug Proxy 2009-08-10 07:51:47 EDT
------- Comment From MAIER@de.ibm.com 2009-08-10 07:40 EDT-------
2 related issues are still open and tracked in separate new bugs:
* LTC bug 54524 / RIT 314457-install of RHEL 5.4 beta1 on s390x over IPv6 still broken in loader and ipcalc
* LTC bug 54332 / RIT 322712 - install attempt hangs with "pumpSetupInterface failed: get link - 19: No such device"

Otherwise, this feature request has been successfully integrated in RHEL 5.4.
Therefore, I'm closing this bug here.
Comment 41 errata-xmlrpc 2009-09-02 05:52:54 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1306.html

Note You need to log in before you can comment on or make changes to this bug.