Bug 476105 - taglib doesn't grok ogg-vorbis .oga files
taglib doesn't grok ogg-vorbis .oga files
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: taglib (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
: 496384 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-11 18:38 EST by Flóki Pálsson
Modified: 2009-04-18 20:43 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-10 09:05:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
from terminal amarok 2>amarok20.txt (4.37 KB, text/plain)
2008-12-11 18:38 EST, Flóki Pálsson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 178602 None None None Never

  None (edit)
Description Flóki Pálsson 2008-12-11 18:38:54 EST
Created attachment 326689 [details]
from terminal amarok 2>amarok20.txt 

Description of problem:
Amarok 2.0 ( testing) can not scan folders. Only one folder comes to local collection. 

Version-Release number of selected component (if applicable):
amarok-2.0-2.fc10.x86_64

How reproducible:
always 

Steps to Reproduce:
1.  
2.
3.
  
Actual results:


Expected results:


Additional info:
see attachment when amarok is started from terminal.
I have seen high CPU usag off amarok in System monitor while scanning.
Gnome session. KDE not instaled.  
Same problem was in amarok 1.98
Comment 1 Rex Dieter 2008-12-12 00:00:44 EST
It's unclear to me how to try to reproduce this.  Am I to understand you have multiple folders, but only one works?

As an aside, the only item in the logfile out of the ordinary are the db-related stuff, like
081211 23:31:48  InnoDB: Database was not shut down normally!
Sounds like amarok, at one point or another either crashed or was killed.
Comment 2 Flóki Pálsson 2008-12-12 03:12:20 EST
In am not able to scan this folder 
/media/tonlist/MP3_lög/ᛏᛣᚱ/Ragnarok

Is it a problem with spechial  characters
Comment 3 Rex Dieter 2008-12-12 07:59:46 EST
Be aware too, fedora doesn't support MP3's (I assume due to the name of your folder).  For that, you need to flow "Enabling MP3 support" link on http://amarok.kde.org/wiki/Download:Fedora
Comment 4 Flóki Pálsson 2008-12-12 08:14:31 EST
I can play mp3 with amarok. 
I have benn able scan mp3 in too local files.
There is no mp3 file in  /media/tonlist/MP3_lög/ᛏᛣᚱ/Ragnarok
Rytmninbox has no problem with Ragnarok folder.
Comment 5 Rex Dieter 2008-12-12 08:31:04 EST
For giggles and to confirm your suspicion, mind renaming the folder to something simple like
/media/tonlist/MP3_log/foo/Ragnarok
can amarok parse it now?
Comment 6 Flóki Pálsson 2008-12-12 15:16:30 EST
amarok can not play files in  /media/tonlist/MP3_lög/ᛏᛣᚱ/Ragnarok.
and not /home/floki/Download/The Music Still Goes On which are off type 
for exapmle 03 - On and on and On.oga.  Rytminbox can play them. 

I wan able to scan to folders in  /home/floki/Music/.
But I had to kill amarok after 5 minutes and using  cpu  from 50 80.
Comment 7 Flóki Pálsson 2008-12-13 16:21:42 EST
Now I can scan folders. 
What changed I dot know.
What confused me is that amarok can not play oga files.
Comment 8 Rex Dieter 2008-12-13 17:45:34 EST
OK... now to the ogg issue.  ogg files should play fine (do for me).

Can you describe the symptoms?  Does amarok say playing, and nothing comes?  Does it skip over these items?

In the meantime,
rpm -q xine-lib-pulseaudio phonon-backend-xine phonon-backend-gstreamer

please.
Comment 9 Flóki Pálsson 2008-12-13 19:20:10 EST
floki@flokip ~]$ rpm -q xine-lib-pulseaudio phonon-backend-xine phonon-backend-gstreamer
package xine-lib-pulseaudio is not installed
phonon-backend-xine-4.1.3-1.fc10.x86_64
phonon-backend-gstreamer-4.2.0-7.fc10.x86_64
[floki@flokip ~]$ 

I can now play oga files. 
ogg was always ok. 
xine neads xine-lib-extras.x86_64 1.1.15-3.fc10     for oga I think
I used Sound Juicer 2.24.0 to extract, and by default it creates oga files for audio.
oga files are not scanned in to  collection.

and 
[floki@flokip ~]$ rpm -qa | grep xine
xine-lib-extras-1.1.15-3.fc10.x86_64
phonon-backend-xine-4.1.3-1.fc10.x86_64
xine-0.99.5-5.fc10.x86_64
xine-lib-1.1.15-3.fc10.x86_64
xine-lib-extras-freeworld-1.1.15-4.fc10.x86_64
[floki@flokip ~]$ 

Amarok relays on xine as sound engine ( as far I understand )
Comment 10 Rex Dieter 2008-12-13 19:36:47 EST
amarok relies on phonon, which uses xine by default.

xine-lib-extras shouldn't be required here.

What is at issue is the lack of xine-lib-pulseaudio, which would explain it not working (when PA is in use).
Comment 11 Flóki Pálsson 2008-12-13 21:16:34 EST
I have installed 
xine-lib-pulseaudio-1.1.15-3.fc10.x86_64
and not able to scan oga files but play.
Comment 12 Rex Dieter 2008-12-13 22:13:10 EST
Wierd, I can't reproduce that (a majority of my own amarok collection oare ogg's).  I wonder if .ogg vs .oga makes a difference?
Comment 13 Flóki Pálsson 2008-12-14 15:59:35 EST
Tray to extract with  Sound Juicer.  Default is to create *.oga.
Tray to scan *.oga from  Sound Juicer.
Comment 14 Rex Dieter 2008-12-23 10:31:29 EST
I still can't reproduce.

Mind sending me one of those problematic files privately?
Comment 15 Rex Dieter 2008-12-23 15:15:09 EST
OK, I was finally able to reproduce, with a sample (thanks).  Oddly, renaming said file to .ogg made it work.

I'll do some digging.
Comment 16 Rex Dieter 2008-12-23 15:27:40 EST
OK, problem here is that taglib, the library amarok uses for extracted metadata/tags, assumes that .oga represents an ogg-flac file, and the ones you're using are ogg-vorbis (which taglib assumes has an .ogg extension).

I'll keep looking into whether the .oga => ogg-flac assumption is legit or whether it warrants fixing.
Comment 17 Rex Dieter 2008-12-23 15:52:43 EST
Upstream bug filed, http://bugs.kde.org/178602

In the meantime, if you follow the current constraints of naming ogg-vorbis files .ogg and ogg-flac files .oga, things should work fine (or better anyway).
Comment 18 Matthias Saou 2009-01-07 07:19:57 EST
FYI, the new default of *.oga naming instead of *.ogg has created other problems. See bug #479120 for the audacious-libs issue. Problem can be two fold :
 * It has been assumed that ogg files always contained ogg/vorbis, so there are problems when it contains something else (like ogg/flac).
 * Is has been assumed that ogg files should be named *.ogg (or *.ogm too sometimes), so there are problems when they are named *.oga.

Obviously, the proper fix is to detect ogg based on the file's mime type and to then detect if it contains audio streams and what codec they use, but that probably means major code changes (it does in audacious-libs where I've had a quick look).
Comment 19 Steven M. Parrish 2009-01-10 09:05:32 EST
Since this has been reported upstream, going to close this report as such.  Will monitor upstream for resolution.
Comment 20 Rex Dieter 2009-04-18 20:43:09 EDT
*** Bug 496384 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.