Bug 479120 - Audacious doesn't load and play .oga files
Audacious doesn't load and play .oga files
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: audacious-plugins (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ralf Ertzinger
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-07 07:13 EST by Matthias Saou
Modified: 2009-06-26 22:47 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.5.1-6.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-26 22:45:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to have Audacious open .oga files (579 bytes, patch)
2009-01-07 07:13 EST, Matthias Saou
no flags Details | Diff

  None (edit)
Description Matthias Saou 2009-01-07 07:13:53 EST
Created attachment 328368 [details]
Patch to have Audacious open .oga files

The current Fedora 10 Sound Juicer defaults to ripping as ogg/vorbis and now creates the files with the .oga extension instead of .ogg. When dragging and dropping these *.oga files on Audacious, nothing happens. Renaming them as *.ogg and trying again works fine.

I've tested this trivial patch against audacious-libs and it works : The filename extension for vorbis files is hardcoded in the plugin, not detected by the mime type. Too bad.

If this "fix" could be sent upstream and included in the Fedora packages, it would be great!

Note that there is a more severe yet similar bug in taglib filed as bug #476105. The last few comments do indicate that we might have another problem here, if indeed some ogg/flac files are also named *.oga from now on.
Comment 1 Ralf Ertzinger 2009-01-07 07:21:29 EST
May I inquire as to who came up with the idea to name these files .oga instead of the well known .ogg?
Comment 2 Matthias Saou 2009-01-07 07:25:21 EST
Very good inquiry indeed :-)
Reading up on this page, it seems that it would be more of a Sound Juicer wrong choice to start naming ogg/vorbis files with the .oga extension!

http://wiki.xiph.org/index.php/MIME_Types_and_File_Extensions#.oga_-_audio.2Fogg
Comment 3 Matthias Saou 2009-01-07 07:34:13 EST
I was about to reassign against Sound Juicer, since I've just checked and indeed in Fedora 10 it defaults to naming ogg/vorbis files with the .oga extension and the flac files with .flac extension (which it doesn't seem to put into an ogg container, but I haven't dug any further).

But in the link from my last comment, it states : "Vorbis and Speex may use .oga, but it is not the prefered method of distributing these files because of backwards-compatibility issues."

So either we should include this patch to have audacious work with the Fedora Sound Juicer's new default, or have Sound Juicer change back to the .ogg extension for ogg/vorbis.
Comment 4 Matthias Saou 2009-04-12 12:57:13 EDT
Any further thoughts on this? I got a report myself against easytag about the exact same problem, but am still unsure about what to do (it's bug #483647).
Comment 5 Fedora Update System 2009-05-01 13:58:30 EDT
audacious-plugins-1.5.1-4.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/audacious-plugins-1.5.1-4.fc11
Comment 6 Fedora Update System 2009-05-09 00:16:28 EDT
audacious-plugins-1.5.1-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious-plugins'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-4556
Comment 7 Fedora Update System 2009-06-05 08:03:13 EDT
audacious-plugins-1.5.1-6.fc11,audacious-1.5.1-9.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/audacious-plugins-1.5.1-6.fc11,audacious-1.5.1-9.fc11
Comment 8 Fedora Update System 2009-06-05 08:10:52 EDT
audacious-plugins-1.5.1-6.fc10,audacious-1.5.1-9.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/audacious-plugins-1.5.1-6.fc10,audacious-1.5.1-9.fc10
Comment 9 Fedora Update System 2009-06-15 22:38:06 EDT
audacious-plugins-1.5.1-6.fc11, audacious-1.5.1-9.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious-plugins audacious'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6438
Comment 10 Fedora Update System 2009-06-15 22:45:37 EDT
audacious-plugins-1.5.1-6.fc10, audacious-1.5.1-9.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious-plugins audacious'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-6490
Comment 11 Fedora Update System 2009-06-26 22:44:45 EDT
audacious-plugins-1.5.1-6.fc11, audacious-1.5.1-9.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2009-06-26 22:46:58 EDT
audacious-plugins-1.5.1-6.fc10, audacious-1.5.1-9.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.