Bug 477562 - [PATCH] Preupgrade only updates from one repository
[PATCH] Preupgrade only updates from one repository
Status: CLOSED DUPLICATE of bug 473966
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-21 19:02 EST by Lubomir Rintel
Modified: 2014-01-21 18:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-15 09:37:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Support multiple repositories in preupgrade (16.82 KB, text/plain)
2008-12-21 19:02 EST, Lubomir Rintel
no flags Details

  None (edit)
Description Lubomir Rintel 2008-12-21 19:02:27 EST
Created attachment 327599 [details]
Support multiple repositories in preupgrade

Currently preupgrade cares very little about repositories other than GOLD's Everything. After preupgrade I ended up having to download ~300M of RPM Fusion packages and Fedora updates.

The attached patch adds support for multiple repositories, making it possible for RPM Fusion to supply its own set of repositories for new release to download the packages from. I'd be very thankful for the review of the patch, since I don't code in python much and am aware it may not be suitable for inclusion as-is from a quality standpoint.

A side effect of the patch is that it mitigates bug #477327 by moving the long string of repository URL to the kickstart file making it less likely to hit the 255 character command line boundary. Probably the URL of stage2 could be also moved into kickstart file (which would require trivial modification of anaconda's stage1 loader), since that tends to be the longest part of the command line in case install.img can't find on /boot and the mirror URLs can be arbitrarily long in theory.
Comment 1 Lubomir Rintel 2009-01-02 07:25:24 EST
It seems to me that it is really desirable to download updates during preupgrade, since package versions of packages in updates of older branches sometimes advance beyond the version in GA of newer branch.

A good example of this is kernel. Moreover. in f10 anaconda has a bug (fixed in git) that causes it to crash with an unexpected exception when kernel is not being updated, therefore preupgrade will be effectively useless for f10 once f9's kernel is updated to newer version.
Comment 2 Lubomir Rintel 2009-01-12 16:02:08 EST
ping
Comment 3 Will Woods 2009-05-15 09:37:04 EDT
This should be fixed with preupgrade-1.1.0.

*** This bug has been marked as a duplicate of bug 473966 ***

Note You need to log in before you can comment on or make changes to this bug.