This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 473966 - RfE: Preupgrade should downloading new distributation with updates
RfE: Preupgrade should downloading new distributation with updates
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
: Reopened
: 477558 477562 492403 500647 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-01 11:38 EST by Jochen Schmitt
Modified: 2014-01-21 18:07 EST (History)
7 users (show)

See Also:
Fixed In Version: 1.1.0-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-17 10:34:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jochen Schmitt 2008-12-01 11:38:06 EST
I have upgraded from F-9 to F-10 with preupgrade. 

After I have finished the upgrade and type in a 'yum update' over 150 packages was provided for updating.

I think is should be nice, if preupgrade could downloading availlable updates before starting the upgrade process, becouse it's annouying to have to downloading over 750 Meg of updates after the upgrade process.
Comment 1 seth vidal 2009-01-22 09:01:04 EST
*** Bug 477558 has been marked as a duplicate of this bug. ***
Comment 2 Michal Jaegermann 2009-01-22 12:18:21 EST
As it was said in bug 477558 a working option to enable additional repositories, not only those on a "built-in" list, would be a really helpful too.
Comment 3 Will Woods 2009-03-26 15:16:48 EDT
*** Bug 492403 has been marked as a duplicate of this bug. ***
Comment 4 Will Woods 2009-03-26 15:18:52 EDT
Current code in bzr (eventually to be released as 1.1.0) will search for updated versions of every repo you have enabled. This should enable updates, updates-testing (if you have that turned on), and even third-party repos.
Comment 5 Gerry Reno 2009-03-26 16:31:37 EDT
This bug has a subtle difference to my bug.  I was suggesting that it have an OPTION to turn on this 'latest update' behavior and therefore you could either have it work as it does today just downloading the distribution as bundled OR you could have it download the distribution but with the very latest packages from 'updates'.

  Is that what the new code will do?
Comment 6 Will Woods 2009-03-26 16:48:06 EDT
No on/off switch planned. I can't see a use case for *not* installing updates.
Comment 7 Gerry Reno 2009-03-26 17:30:59 EDT
Use case for having an option would be if some package is broken in updates then you can always fall back to the bundled distro and then exclude the broken package in a followup 'yum update'.  
OR 
If preupgrade would respect the yum excludes then we could just list it there and keep going.

Also, will the user be able to select a list of update repos to use from the repos that the user has enabled?
Comment 8 Fedora Update System 2009-04-28 18:07:38 EDT
preupgrade-1.1.0-0.pre2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/preupgrade-1.1.0-0.pre2.fc10
Comment 9 Fedora Update System 2009-05-02 12:42:00 EDT
preupgrade-1.1.0-0.pre2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-4211
Comment 10 Fedora Update System 2009-05-13 18:47:01 EDT
preupgrade-1.1.0-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/preupgrade-1.1.0-1.fc9
Comment 11 Fedora Update System 2009-05-13 18:47:55 EDT
preupgrade-1.1.0-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/preupgrade-1.1.0-1.fc11
Comment 12 Will Woods 2009-05-15 09:26:58 EDT
*** Bug 500647 has been marked as a duplicate of this bug. ***
Comment 13 Will Woods 2009-05-15 09:37:04 EDT
*** Bug 477562 has been marked as a duplicate of this bug. ***
Comment 14 Fedora Update System 2009-05-15 19:34:00 EDT
preupgrade-1.1.0-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-4211
Comment 15 Fedora Update System 2009-05-28 03:58:14 EDT
preupgrade-1.1.0-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2009-05-28 04:10:58 EDT
preupgrade-1.1.0-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2009-05-28 04:12:57 EDT
preupgrade-1.1.0-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Christopher Beland 2009-07-17 01:36:43 EDT
I used preupgrade-1.1.0-1.fc9.noarch (the GUI method) to upgrade from F9 to F11 today.  Even though the correct repositories were enabled after the installer ran, when I ran "yum update" immediately after the upgrade, I had several hundred updates waiting for download.  (I assume they were all the updates for F11 that have been posted since the final release.)  I think the expectation of the original reporter (and my own hope) was that preupgrade would have downloaded these updates instead of the originally-released versions of these RPMs.

In response to comment #7, I had also considered that reason not to just always download updates, but on reflection, the solution would be to simply issue another update that *does* work.  (Assuming the person who encounters it has another computer they can use to report the bug, or a LiveCD, or something.)
Comment 19 seth vidal 2009-07-17 10:34:17 EDT
I'm suspecting you got a mirror change of state, especially if you did it in the last couple of days as we've been having issues with our mirroring and things have just started to get back into sync.

Note You need to log in before you can comment on or make changes to this bug.