Bug 478958 - Sometimes, Firefox's URL window only lets you type one character
Sometimes, Firefox's URL window only lets you type one character
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
: Triaged
: 516371 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-06 03:47 EST by Andre Robatino
Modified: 2010-12-05 02:03 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-05 02:03:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
requested backtrace (20.67 KB, text/plain)
2009-01-06 05:46 EST, Andre Robatino
no flags Details

  None (edit)
Description Andre Robatino 2009-01-06 03:47:39 EST
Description of problem:
Sometimes, I'll notice that when I type an URL, the text goes in backwards, for example if I type abcde, it appears edcba, with each new character added at the beginning instead of the end.  On the other hand, if I paste an entire text string at once, it goes in correctly.  When I see this behavior, top shows that firefox is using near 100% CPU.  I try to exit firefox, and the window closes, but top shows the process is still running near 100% CPU.  So I kill it with an ordinary kill signal, and when I restart firefox, it's behaving normally again.

Version-Release number of selected component (if applicable):
firefox-3.0.5-1.fc10.x86_64

How reproducible:
don't know

Additional info:
Fully updated, cleanly installed x86_64 F10.
Comment 1 Martin Stransky 2009-01-06 04:03:53 EST
It would be great to have backtrace from firefox process when it's running near 100% CPU...please try to attach gdb to the firefox by:

$gdb --pid=xxx where xxx is PID of firefox-bin. Then please run "bt" gdb command and attach output here...
Comment 2 Martin Stransky 2009-01-06 04:05:03 EST
note - you need to install debuginfo packages (xulrunner-debuginfo and firefox-debuginfo)
Comment 3 Andre Robatino 2009-01-06 04:28:36 EST
I have the two packages installed from the updates-debuginfo repo.  When I run Firefox, the only process is "firefox", so I'm assuming you mean that, not firefox-bin ("locate firefox-bin" turns up nothing).
Comment 4 Martin Stransky 2009-01-06 05:23:27 EST
ahh, okay, please try firefox then...
Comment 5 Andre Robatino 2009-01-06 05:46:47 EST
Created attachment 328262 [details]
requested backtrace
Comment 6 Andre Robatino 2009-01-06 05:49:58 EST
I found out how to reproduce the bug: go to

http://www.jigzone.com/puzzles/daily-jigsaw

and "Change Cut" to "247 Piece Triangles".  At this point, there's a good chance you'll see the behavior I've described if you try opening an URL in a new tab.
Comment 7 Andre Robatino 2009-01-06 05:50:56 EST
Should have mentioned that I'm using F10's built-in Java plugin.
Comment 8 Matěj Cepl 2009-01-06 11:04:54 EST
(In reply to comment #6)
> I found out how to reproduce the bug: go to
> 
> http://www.jigzone.com/puzzles/daily-jigsaw
> 
> and "Change Cut" to "247 Piece Triangles".  At this point, there's a good
> chance you'll see the behavior I've described if you try opening an URL in a
> new tab.

Sorry, I don't get where I am supposed to type. Moreover, I get the similar behavior in Ekiga (or at least used to while it still worked for me), so I suspect that this might be more Gtk+ issue. However, I would still need a better description of how to reproduce this bug.
Comment 9 Andre Robatino 2009-01-06 17:01:00 EST
1. Go to http://www.jigzone.com/puzzles/daily-jigsaw
2. Wait for the puzzle to load.
3. Change Cut to 247 Piece Triangles.
4. Wait for the new puzzle to load.
5. Type Ctrl-t to open new tab.
5. Type some text for the URL, hopefully see it go in backwards.
Comment 10 Andre Robatino 2009-01-07 17:36:08 EST
I was able to reproduce this on my 32-bit machine, on the first attempt.
Comment 11 Matěj Cepl 2009-01-27 18:40:47 EST
t): emit yreve tsomla ,yaw siht skrow i ,sey yllautcA
Comment 12 Matěj Cepl 2009-01-27 18:46:31 EST
Meaning, yes I was able to reproduce it with

xulrunner-1.9.0.5-1.fc10.x86_64
firefox-3.0.5-1.fc10.x86_64
java-1.6.0-openjdk-plugin-1.6.0.0-7.b12.fc10.x86_64

[root@viklef ~]# LANG=C update-alternatives --display libjavaplugin.so.x86_64
libjavaplugin.so.x86_64 - status is auto.
 link currently points to /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/IcedTeaPlugin.so
/usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/IcedTeaPlugin.so - priority 16000
Current `best' version is /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/IcedTeaPlugin.so.
[root@viklef ~]#
Comment 13 Andre Robatino 2009-01-27 19:13:43 EST
I can partly reproduce this on 64-bit Rawhide running as guest in VirtualBox 2.1.2.  The 100% CPU usage by Firefox is the same.  When I type text into the new tab, only the first character displays, then it won't let me enter any more.  So I can't tell if it would be backwards or not.

xulrunner-1.9.1-0.6.beta2.fc11.x86_64
firefox-3.1-0.4.beta2.fc11.x86_64
java-1.6.0-openjdk-plugin-1.6.0.0-8.b14.fc11.x86_64
Comment 14 Matěj Cepl 2009-01-27 20:05:00 EST
the same on i386 client
Comment 15 Matěj Cepl 2009-01-27 20:15:00 EST
Yes, can reproduce even with the upstream firefox binary. So, the only suspicion on the Fedora side could be openjdk webplugin.

Reassigning to its maintainers.
Comment 16 Andre Robatino 2009-02-02 01:01:41 EST
After letting the original puzzle load, the same thing happens if any of the other links "Shuffle Pieces", "Auto Solve", or "Start Over" is chosen instead of "Change Cut".
Comment 17 Andre Robatino 2009-02-07 01:57:30 EST
Unchanged with latest updates:

firefox-3.0.6-1.fc10.x86_64
java-1.6.0-openjdk-1.6.0.0-9.b14.fc10.x86_64

Same with latest Rawhide.  The fastest way to reproduce this is to use the "Start Over" button.
Comment 18 Omair Majid 2009-02-20 16:50:38 EST
I can reproduce the issue with firefox even if Java is disabled. Here are the instructions (taken from http://www.bobafred.com/index.php/archive/firefox-and-google-maps-backwards-typing/):

1. Disable Java 
  - Edit -> Preferences -> Content -> uncheck "Enable Java"
  - double check that it is off through "about:plugins". There should be no entry for "IcedTea Java Web Browser Plugin"
2. Go to maps.google.ca
3. Click the 'Print' link. Wait for a new browser window and a print dialog to pop up (I didnt click anything in this window) 
4. Go back to the original firefox window. Try typing text in the address bar.

Given the above, I dont think this bug is caused by the IcedTea Plugin itself. Reassigning to firefox.

Reproduced with:
firefox-3.0.6-1.fc10.i386
Comment 19 Andre Robatino 2009-02-20 17:05:11 EST
I see the same with firefox-3.0.6-1.fc10.x86_64.  The behavior is the same with maps.google.com.  Unlike the other way, this does not trigger 100% CPU usage (whether Java is enabled or not), and if the 2 new windows are closed, the original window goes back to normal behavior without having to restart Firefox.
Comment 20 Andre Robatino 2009-02-20 17:24:21 EST
The behavior in Rawhide with firefox-3.1-0.6.beta2.fc11.x86_64 is similar to what it was on Jigzone - it only allows me to type one character, so I can't tell if it would be backwards or not.  As above, there is no 100% CPU usage, and if I close the extra windows, the original window goes back to normal without restarting Firefox.  So Firefox 3.1 is still buggy but in a slightly different way.
Comment 21 Christopher Aillon 2009-02-23 10:50:28 EST
Martin, any idea here?
Comment 22 Andre Robatino 2009-03-10 14:23:04 EDT
Behavior in F10 same with firefox-3.0.7-1.fc10.x86_64.
Comment 23 Andre Robatino 2009-03-15 01:50:01 EDT
Bug #490257 also involves characters being inserted backwards in a text field (in xfig-plain).  Any connection?
Comment 24 Martin Stransky 2009-04-01 07:33:33 EDT
Bug 490257 doesn't seem to be related to this issue...firefox uses GTK widgets there.
Comment 25 Andre Robatino 2009-04-30 07:38:47 EDT
Behavior unchanged with firefox-3.0.10-1.fc10.x86_64 in F10, or firefox-3.5-0.20.beta4.fc11.x86_64 in rawhide.
Comment 26 Andre Robatino 2009-08-08 19:45:40 EDT
In F11 with firefox-3.5.2-2.fc11.x86_64, it does the same thing it did in F11 Rawhide - it lets you type only one character.  The first time I tried it, this didn't happen, so I thought it was fixed, but trying it again I now see the bug consistently.  This is by going to maps.google.com and clicking the Print link.
Comment 27 Andre Robatino 2009-08-08 20:26:40 EDT
The same bug also exists in F12 Rawhide with firefox-3.5.2-3.fc12.x86_64.  I reported it as bug #516371 against Rawhide.
Comment 28 Matěj Cepl 2009-08-09 11:11:34 EDT
*** Bug 516371 has been marked as a duplicate of this bug. ***
Comment 29 Bug Zapper 2009-11-16 04:45:37 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 30 Andre Robatino 2009-11-20 13:06:17 EST
Seems fixed in Rawhide.  Can anyone verify?

firefox-3.6.1-0.2.b3.fc13.x86_64
xulrunner-1.9.2.1-0.3.b3.fc13.x86_64
Comment 31 Andre Robatino 2010-06-06 06:56:21 EDT
I am not seeing this any more in cleanly installed and updated x86_64 F13.  Can anyone still reproduce it in F12?
Comment 32 Bug Zapper 2010-11-04 07:34:23 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 33 Bug Zapper 2010-12-05 02:03:13 EST
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.