Bug 490257 - Text size field inserts characters on left instead of right
Text size field inserts characters on left instead of right
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xfig (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Stepan Kasal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-14 06:53 EDT by Ian Dall
Modified: 2009-04-02 13:12 EDT (History)
4 users (show)

See Also:
Fixed In Version: 3.2.5-17.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 165895
Environment:
Last Closed: 2009-04-02 13:12:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Dall 2009-03-14 06:53:50 EDT
+++ This bug was initially created as a clone of Bug #165895 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc3 Firefox/1.0.6

Description of problem:
When using the "edit" popup panel to modify the size of text, the "size" spec inserts on the left rather than the right.   For example, if you want to get font size "24" and type "2" then "4", you get "42".


Version-Release number of selected component (if applicable):
xfig-3.2.5-11

How reproducible:
Always

Steps to Reproduce:
1.  Run xfig-plain
2.  Insert a text string into the figure.
3.  Select "edit" from the left panel
4.  Click over the existing text to edit that text (and its properties)
5.  Delete the contents of the "size" field
6.  Type in "24".  Notice that you got "42" instead.
  

Actual Results:  Text (font) size is "42"

Expected Results:  Text size should be "24".

Additional info:
This bug does not occur with xfig-Xaw3d (but running xfig-Xaw3d is not a suitable alternative because of other problems).

This bug is not restricted to font size. For example line thickness and depth dialog boxes also have this behaviour, but the arrow size panel does not!
Comment 1 Andre Robatino 2009-03-15 01:48:25 EDT
I can reproduce this on x86_64, so the Platform should be changed to "All Linux".  You might have a look at bug #478958 which also involves characters being inserted backwards in a text field (in Firefox).
Comment 2 Hans de Goede 2009-03-16 06:17:58 EDT
Thanks for reporting this, an update fixing this is on its way to updates-testing,
please give it a good testing and give it positive karma in bodhi if all is well.
Comment 3 Fedora Update System 2009-03-16 06:19:33 EDT
xfig-3.2.5-17.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/xfig-3.2.5-17.fc10
Comment 4 Fedora Update System 2009-03-16 15:47:59 EDT
xfig-3.2.5-17.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xfig'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2748
Comment 5 Fedora Update System 2009-04-02 13:11:54 EDT
xfig-3.2.5-17.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.