Bug 478983 - "Advance Search" engine does not filter "Category" exactly in catalog
"Advance Search" engine does not filter "Category" exactly in catalog
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Hardware Catalog (Show other bugs)
5.3
All Linux
low Severity medium
: ---
: ---
Assigned To: sfu@redhat.com
http://hardware.redhat.com
:
: 234376 (view as bug list)
Depends On:
Blocks: 446164
  Show dependency treegraph
 
Reported: 2009-01-06 06:37 EST by sfu@redhat.com
Modified: 2009-04-07 23:10 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.3 (hwcert-3.2rh-20090129.0)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-03 23:47:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch fix: (1.78 KB, patch)
2009-01-06 06:57 EST, sfu@redhat.com
no flags Details | Diff

  None (edit)
Description sfu@redhat.com 2009-01-06 06:37:44 EST
Description of problem:

Search engine does not work exactly in catalog.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Login to the cataglog and click the "Advanced Search" link in the index
2.Then jump to the page: http://hardware.redhat.com/query.cgi.
3.Select "Dell" in Vendor list and select "Server" in Category list.  
4.Then click the "Search" button.

Actual results:
It will not only show the "Server" type certs but also show "Desktop/Workstation" type certs

Expected results:
It will only show the "Server" type certs.

Additional info:
Comment 1 sfu@redhat.com 2009-01-06 06:57:38 EST
Created attachment 328273 [details]
patch fix:

Modify the codes in the list.cgi to match the Bugzilla/Search.pm to make the search work well.

Test Link http://bugdev.devel.redhat.com/hwcert-xisun2/

please review.


The bug block #446164 to use the list.cgi to filter the "cf_internal_whiteboard".... so mark it as blocker.
Comment 2 Rob Landry 2009-01-06 14:23:01 EST
Before we change the list.cgi code as in the patch we should verify in the upstream to see what changes exist there.
Comment 4 XINSUN 2009-04-07 23:10:45 EDT
*** Bug 234376 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.