Bug 479725 - New refresh button for components/versions/milestones on query.cgi should be more intuitive
New refresh button for components/versions/milestones on query.cgi should be ...
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
3.2
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
:
: 480346 480427 485959 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-12 13:14 EST by David Lawrence
Modified: 2013-06-24 00:09 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 457843
Environment:
Last Closed: 2009-08-10 11:07:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot showing components/versions/milestones under product select (165.44 KB, image/jpeg)
2009-01-13 17:49 EST, David Lawrence
no flags Details
Screen shot showing new refresh button with comp/vers/mile lists enabled (initial page load) (210.33 KB, image/png)
2009-01-14 14:29 EST, David Lawrence
no flags Details
Screen shot showing new refresh button with comp/vers/mile lists disabled after selecting diff product (211.20 KB, image/png)
2009-01-14 14:30 EST, David Lawrence
no flags Details
Patch that adds js to disable the comp/ver/mile lists when a new product is selected (v1) (5.21 KB, patch)
2009-01-14 14:36 EST, David Lawrence
nelhawar: review+
Details | Diff
Screenshot showing bold alert that displays when a new product is selected (203.22 KB, image/png)
2009-02-25 15:16 EST, David Lawrence
no flags Details
Patch that shows a bold alert that displays when a new product is selected (v1) (4.41 KB, patch)
2009-02-25 15:18 EST, David Lawrence
nelhawar: review+
Details | Diff

  None (edit)
Description David Lawrence 2009-01-12 13:14:04 EST
+++ This bug was initially created as a clone of Bug #457843 +++

--- Additional comment from covex@lowlevel.cz on 2009-01-12 03:29:33 EDT ---

Oh yes, pressing this button is necessary, this should be more obvious. How about to move the Components, Version and Target below this button?

--- Additional comment from dkl@redhat.com on 2009-01-12 13:12:12 EDT ---

(In reply to comment #15)
> Oh yes, pressing this button is necessary, this should be more obvious. How
> about to move the Components, Version and Target below this button?

I will create a new bug for this and see if we can make this more intuitive. My first goal was to get the query.cgi to at least be usable to most people. The ajaxification of the products/components/versions/milestones made the page hang for long periods since the component lists for Fedora for example is over 7000 long now. The query.cgi page was never originally coded to handle that many components in a single product.

Dave
Comment 1 Kevin Baker 2009-01-12 14:41:13 EST
cc'd Mo Duffy. She might have some helpful input.
Comment 2 David Lawrence 2009-01-13 17:49:26 EST
Created attachment 328930 [details]
Screenshot showing components/versions/milestones under product select

Attaching a screenshot showing the components/versions/milestones underneath the new refresh button. Does this make it more obvious that they button needs to be clicked to refresh the lists?

Dave
Comment 3 Máirín Duffy 2009-01-13 23:18:57 EST
Hi Dave!

I think the primary issue with the component & version lists, which I am not sure the button solves, is that no matter what you select in the product select box, there is a whole set of text in the component & version lists. If the component & version lists are full of items, it gives the at-a-glance false impression that those items are valid for the selected item in the product select box.

I think if folks need to click this refresh button to refresh the components/versions list, they need a more intuitive impetus to actually press it. One idea:

- Blank out the component / version / milestones boxes by default, so when you first hit the page, they are completely empty.

- Use the original layout of product select box next to the component / version / milestones select boxes rather than the one that places them in different rows in attachment id=328930 from comment 2.

- Place the refresh button in between the product and component select boxes, and instead of labeling it "Refresh component / version / milestones" just label it with a "=>" or make it a button rather than an input and use a right arrow icon on it. 

- Once the button is pressed, populate the component/version/milestone fields appropriately for the selected product.

- When a different product is selected in the product select box, clear the component/version/milestone fields again. They should be blank. Populate them again when the => button is pressed.

Another idea:

- Use the new layout proposed in attachment id=328930 from comment 2.

- Don't show the component / version / milestones select boxes at all (you could put them in a div and hide them completely with JS/CSS by default) until the refresh button is pressed. (maybe s/refresh/load in the label)

- Every time a different product is selected, the component / version / milestones select boxes are hidden, until the refresh/load button is again pressed.

Two slightly different ways of implementing the same idea I think - making it very clear that the needed information still needs to be loaded rather than giving users a false sense that the components listed are actually correct for the currently-selected product.

Does that make sense? I could throw together a mockup if this explanation is too confusing. Is this do-able technically?
Comment 4 Adam Pribyl 2009-01-14 03:13:50 EST
I think this is good proposal.
Comment 5 David Lawrence 2009-01-14 11:26:46 EST
(In reply to comment #4)
> I think this is good proposal.

Adam, Which one is the one you liked in the post by Mairin? There were two suggestions. Or are you referring to my attached screenshot?

Mairin, they are both doable technically. I can work up two different versions with both of your stated suggestions.

Dave
Comment 6 David Lawrence 2009-01-14 14:29:41 EST
Created attachment 329040 [details]
Screen shot showing new refresh button with comp/vers/mile lists enabled (initial page load)
Comment 7 David Lawrence 2009-01-14 14:30:26 EST
Created attachment 329041 [details]
Screen shot showing new refresh button with comp/vers/mile lists disabled after selecting diff product
Comment 8 David Lawrence 2009-01-14 14:36:25 EST
Created attachment 329042 [details]
Patch that adds js to disable the comp/ver/mile lists when a new product is selected (v1)

Patch that adds the functionality to disable the components/versions/milestones lists when a different product set is chosen. Then the user can hit refresh which will update the lists and re-enable them.

One addition is that if a person goes back to the original list of products selected that they had when the page first loaded, it will re-enable the other lists since they still have the proper values.

Please let me know what you think. I can also easily work up another version with the components/versions/milestones list below the products list.

For internal redhatters, you can play with this at https://bz-web2-test.devel.redhat.com/query.cgi

Dave
Comment 9 Máirín Duffy 2009-01-14 14:44:44 EST
Dave, I like the screenshots, I think that might work a little better. I tried out the bz-web2-test.devel version, and noticed that the first product I click on still gets the list of RHEL components (eg I clicked on FreeIPA and was able to select 4Suite as a component o_O). It seems that the component list stays active and populated with old product items forever until the first time you hit the button. I think the grey out behavior should happen before the first time you hit the button, since the default selected product may not be the product you want.
Comment 10 Noura El hawary 2009-01-15 08:48:06 EST
Comment on attachment 329042 [details]
Patch that adds js to disable the comp/ver/mile lists when a new product is selected (v1)

Hey Dave, Patch looks good to me, and I really like how it looks now with the Refresh button :).

Noura
Comment 11 David Lawrence 2009-01-15 17:41:12 EST
(In reply to comment #10)
> (From update of attachment 329042 [details])
> Hey Dave, Patch looks good to me, and I really like how it looks now with the
> Refresh button :).
> 
> Noura

Thanks Noura. I will not commit this change until all parties are satisfied with this from a UI perspective.

Dave
Comment 12 David Lawrence 2009-01-16 11:01:43 EST
*** Bug 480346 has been marked as a duplicate of this bug. ***
Comment 13 David Lawrence 2009-01-17 18:09:39 EST
*** Bug 480427 has been marked as a duplicate of this bug. ***
Comment 14 Adam Pribyl 2009-01-18 11:05:18 EST
(In reply to comment #5)
> (In reply to comment #4)
> > I think this is good proposal.
> 
> Adam, Which one is the one you liked in the post by Mairin? There were two
> suggestions. Or are you referring to my attached screenshot?
> 
> Mairin, they are both doable technically. I can work up two different versions
> with both of your stated suggestions.
> 
> Dave

Sorry I meant what Mairin proposed. From screenshots I see you implemented that, therefore it is fine with me. I however can not test the internatl site to check the functionality is OK.
Comment 15 David Lawrence 2009-01-22 16:32:39 EST
(In reply to comment #9)
> Dave, I like the screenshots, I think that might work a little better. I tried
> out the bz-web2-test.devel version, and noticed that the first product I click
> on still gets the list of RHEL components (eg I clicked on FreeIPA and was able
> to select 4Suite as a component o_O). It seems that the component list stays
> active and populated with old product items forever until the first time you
> hit the button. I think the grey out behavior should happen before the first
> time you hit the button, since the default selected product may not be the
> product you want.


Sorry for the delay replying. I am not able to replicate the exact behaviour you are describing. When I first load the page my default query is loaded and the component/version/milestone lists are not disabled. If I select some other product other than the one currently highlighted, the lists turn grey. Then I can hit the refresh button and the page reloads with the new component/version/milestone list based on the product I selected. The the process starts again
if I change product.

But I have found some other corner cases that need to be addressed before I can consider this ready for release.

1. If I select multiple products, hit refresh, then the correct lists are generated but when I unselect one of the multiple components the lists are disabled which is incorrect.
2. Changing the classification generates a new product list automatically which should also disable the component/version/milestone lists if the previously selected product(s) are not in the new product list.

Will work on this some more and generate new prototype or people to look at.

Dave
Comment 16 David Lawrence 2009-02-17 12:45:22 EST
*** Bug 485959 has been marked as a duplicate of this bug. ***
Comment 17 Warren Togami 2009-02-24 18:49:34 EST
This is still broken, making it very difficult to use Bugzilla for Fedora.
Comment 18 David Lawrence 2009-02-25 15:16:35 EST
Created attachment 333217 [details]
Screenshot showing bold alert that displays when a new product is selected

Another screenshot showing a different way of alerting the user that they need to do something.

The <span> containing the alert is hidden when query.cgi is initially loaded. If a product change is made in the drop down, then the bold alert displayed to the right of the button that needs to be pressed. 

This is a less invasive change than some of the others that have been proposed by myself. Is this something that would be suitable to alert users when they need to reload the page do update the lists?

Dave
Comment 19 David Lawrence 2009-02-25 15:18:16 EST
Created attachment 333218 [details]
Patch that shows a bold alert that displays when a new product is selected (v1)
Comment 20 Noura El hawary 2009-02-26 06:42:26 EST
Comment on attachment 333218 [details]
Patch that shows a bold alert that displays when a new product is selected (v1)

Hey Dave,

patch looks good to me, I guess there is no way to miss the refresh button now with that dynamic bold text, also I noticed you made the selection lists longer containing 10 elements instead of 5 i guess that also is a good idea to reduce the scrolling for users. 

Noura
Comment 21 David Lawrence 2009-02-26 16:00:33 EST
(In reply to comment #20)
> (From update of attachment 333218 [details])
> Hey Dave,
> 
> patch looks good to me, I guess there is no way to miss the refresh button now
> with that dynamic bold text, also I noticed you made the selection lists longer
> containing 10 elements instead of 5 i guess that also is a good idea to reduce
> the scrolling for users. 
> 
> Noura

This patch has been pushed live today. Will wait and see what people think about this more simple approach.

Dave
Comment 22 Warren Togami 2009-03-04 18:57:28 EST
Hi Dave, will this fix my original problem in Bug #480427?
Comment 23 David Lawrence 2009-03-04 21:17:18 EST
(In reply to comment #22)
> Hi Dave, will this fix my original problem in Bug #480427?

No you still need to press the "Refresh components/versions/milestones" button as before. The recent change was to make it more obvious to the user that they need to do so.

Dave
Comment 24 Chris Ward 2009-04-02 02:04:21 EDT
I see this as fixed already. I would call it VERIFIED, myself.
Comment 25 Matt McCutchen 2010-05-02 22:50:45 EDT
(In reply to comment #23)
> (In reply to comment #22)
> > Hi Dave, will this fix my original problem in Bug #480427?
> 
> No you still need to press the "Refresh components/versions/milestones" button
> as before.

Then bug 480427 should not be marked as a duplicate of this one.

Note You need to log in before you can comment on or make changes to this bug.