Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 479919 - hts-5.3-12 VIDEO test FAIL on mga driver
hts-5.3-12 VIDEO test FAIL on mga driver
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-mga (Show other bugs)
5.4
All Linux
low Severity high
: ---
: 5.4
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: OtherQA, Reopened
: 490659 496115 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-13 21:12 EST by Ken Chan
Modified: 2010-10-23 03:00 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:55:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
8MB 16-bit locked xlog (55.85 KB, text/x-log)
2009-02-04 11:16 EST, Rob Landry
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1390 normal SHIPPED_LIVE xorg-x11-drv-mga bug fix update 2009-09-01 07:58:35 EDT

  None (edit)
Description Ken Chan 2009-01-13 21:12:28 EST
Description of problem:

mga driver that we ship in RHEL 5.3 do not support higher color depth other than 16 so VIDEO will always FAIL since the minimum requirement is > 16. Since most of the server in the market using mga so please advice
Comment 3 Greg Nichols 2009-01-14 20:36:44 EST
It seems that the mga driver does support 24/32 bit color depths.  Some hardware may fail to support this due to inadequate RAM.   Closing this as NOTABUG, since HTS should fail these systems.
Comment 4 Rob Landry 2009-02-04 11:16:27 EST
Created attachment 330879 [details]
8MB 16-bit locked xlog
Comment 5 Rob Landry 2009-02-04 11:20:03 EST
Log highlights...

(EE) MGA(0): Forcing 16bpp on G200SE due to low memory.
(EE) MGA(0): Using settings from depth 24 section
(**) MGA(0): Depth 16, (--) framebuffer bpp 16
(==) MGA(0): RGB weight 565
(II) MGA(0): Disabling MTRR support.
(==) MGA(0): Using AGP 1x mode
(--) MGA(0): Linear framebuffer at 0xF9000000
(--) MGA(0): MMIO registers at 0xFB6FC000
(--) MGA(0): Pseudo-DMA transfer window at 0xFA800000
(--) MGA(0): BIOS at 0xFB6E0000
(II) Attempted to read BIOS 64KB from /sys/bus/pci/devices/0000:03:00.0/rom: got 32KB
(--) MGA(0): Video BIOS info block at offset 0x07AE0
(**) MGA(0): Option "mtrr" "False"
(--) MGA(0): VideoRAM: 8128 kByte


...probably a RHEL/X driver bug or still a hardware issue but re-opening for now under hts.
Comment 14 RHEL Product and Program Management 2009-03-11 11:58:54 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 17 Jeremy West 2009-03-17 15:48:11 EDT
*** Bug 490659 has been marked as a duplicate of this bug. ***
Comment 24 Adam Jackson 2009-05-20 17:10:34 EDT
Closing as per comment #23.
Comment 31 Larry Troan 2009-05-25 09:25:52 EDT
Reopening this bugzilla based on comment #28..

Multiple partners reporting... 
> a lot of shipped servers with G200SE, and they need 24bpp support on both 
> RHEL4.8 and RHEL5.4.
>    It's reason why this ticket open.
>    .. Not fixed as indicated.

Red Hat has hardware as do our on-site partners.
Comment 32 Larry Troan 2009-05-25 09:39:37 EDT
And per comment #2 regarding certification, Rob L spoke with Kevin M.  
> The outcome of this conversation was that the mga driver does support 24/32bit 
> color depths fine however there is a limitation the g200se(ev,wb,se-a) where
> some version only have 1.5MB of vram which means there is not enough RAM on 
> hose cards to do 1024@24bit color.  I've talked with RH Support and upon 
> verifying that 
> (a) this is one of those cards,
> (b) it only has 1.5MB of vram, 
> (c) the test passes 1024x768 @ 16bpp testing (note the video test may return
>     a failure anyway) and 
> (d) system-config-lvm functions properly (which has been reported to fail to
>     run @ palletized color depths); 
> with all of that in place we can grant an exception for systems based
> on this hardware which will also include associating a kbase which will outline
> the the impacts of this limited amount of RAM which include the degredation
> functionality (eg. the video and 3D extentions will fail as there simply isn't
> enough ram to have have the off screen RAM available).  

So if the problem is indeed a RAM limitation on the video card, I agree this should be closed as CURRENT RELEASE. If not a hardware limitation, then we need to consider modifying the driver to support 24 bpp.
Comment 39 Issue Tracker 2009-05-29 04:29:47 EDT
info:
  Trying to fix this problem on RHEL5.4 with great effort.
  Keep you posted.


This event sent from IssueTracker by mfuruta@redhat.com 
 issue 276017
Comment 40 Adam Jackson 2009-06-02 13:01:13 EDT
Built xorg-x11-drv-mga 1.4.10-1.el5

MODIFIED
Comment 43 Alan Matsuoka 2009-06-03 10:15:31 EDT
*** Bug 496115 has been marked as a duplicate of this bug. ***
Comment 44 Chris Ward 2009-06-03 21:49:15 EDT
with pleasure! 

http://people.redhat.com/cward/5.4.0/xorg-x11-drv-mga/
Comment 50 Adam Jackson 2009-06-15 13:25:39 EDT
Build ID: xorg-x11-server 1.1.1-48.52.el5 

This is too old to run this version of the mga driver.  At least -48.64 is required.
Comment 51 Adam Jackson 2009-06-15 14:15:40 EDT
New package built that Requires: the correct X server version.

MODIFIED
Comment 56 Chris Ward 2009-07-03 14:20:29 EDT
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.
Comment 58 Alan Brown 2009-08-27 11:02:15 EDT
(In reply to comment #40)
> Built xorg-x11-drv-mga 1.4.10-1.el5
> 
> MODIFIED
Comment 59 errata-xmlrpc 2009-09-02 07:55:16 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1390.html

Note You need to log in before you can comment on or make changes to this bug.