Bug 496115 - RHEL5.2: Update of mga driver for ServerEngines Pilot 2 support
RHEL5.2: Update of mga driver for ServerEngines Pilot 2 support
Status: CLOSED DUPLICATE of bug 479919
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-mga (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Regression
Depends On:
Blocks: 499522
  Show dependency treegraph
 
Reported: 2009-04-16 13:55 EDT by Alan Matsuoka
Modified: 2009-06-03 10:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-03 10:15:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kronos2-el53ga-090417-2.tgz (63.23 KB, application/x-compressed-tar)
2009-04-17 09:57 EDT, Alan Matsuoka
no flags Details
sosreport-090416tx120s2el53ga-447746-0efc5a.tar.bz2 (524.06 KB, application/x-bzip2)
2009-04-17 09:58 EDT, Alan Matsuoka
no flags Details

  None (edit)
Description Alan Matsuoka 2009-04-16 13:55:55 EDT
I, for one, welcome our new SEG OverLords,

Yup, I know this one's been making the rounds, and it's been up the
RFE path before, and the corresponding BZ is closed as fixed in
RHEL5.2.  However, it's still broken as it's still forcing 16bpp. So,
here comes the escalation template. Not sure if this should be marked
"Regression" or not, but whatever you want to call it, "only
partially working" is appropriate.

General Escalation Information
===========================================================================
State the problem:

  1. Provide time and date of the problem

  Not applicable, happens every time on RHEL5.3 you start X and have
  a mga200e card with 8MB vram.

  2. Indicate the platform(s) (architectures) the problem is being
    reported against.

  x86 / x86_64 (but probably not limited to)

  3. Provide clear and concise problem description as it is
     understood at the time of escalation
     * Observed behavior

  (--) MGA(0): Chipset: "mgag200 SE A PCI"
  (EE) MGA(0): Forcing 16bpp on G200SE due to low memory.
  (--) MGA(0): VideoRAM: 8128 kByte

     * Desired behavior

  Allow 8, 15, 16 and 24 bpp without real restrictions. Might be a
  case, as on the RHEL4 issue, to lock to 16bpp if a Kronos1 (1.7MB
  vram), but with 8MB, we can allow 24bpp I think...

  4. State specific action requested of SEG

  Run this up to Engineering, f.a.o. Ajax. I think Chris Ward has
  been working on this as well for the RHEL4 issue (126881).

  5. State whether or not a defect in the product is suspected

  Yes, defect suspected.

     * Provide Bugzilla if one already exists

  None found (so far).

  6. If there is a proposed patch, make sure it is in unified diff
     format (diff -pruN)

  No patch.

  8. This is especially important for severity one and two
     issues. What is the impact to the customer when they experience
     this problem?

  Hard one to state, but probably akin to your car having four gears,
  and you are only allowed to use one of them, the third one,
  regardless of how many passangers you have.

  We are arbitrarily overriding the requested depth from xorg.conf in
  this driver, even when no real reason to do so.

Provide supporting info

  1. State other actions already taken in working the problem:

    * tech-list, google searches, fulltext, consulting with another
      engineer

  Having worked on the problem since July 2007....

    * Provide any relevant data found

  It's aaaaall in the issue. :) And in IT#282593. And for RHEL4 in
  IT#126881 (and probably more to boot)

  2. Attach sosreport

  If this really is required, I'll get you one from the RX200S5 in
  the Lab. The xorg.conf snippet in
  https://enterprise.redhat.com/issue-tracker/?module=issues&action=view&tid=282593&gid=1011&view_type=lifoall#eid_2890306
  might give enough.

  3. Attach other supporting data

  ...

  4. Provide issue repro information:
     * List steps or...

  1. Obtain a system that use the mga graphics driver
  2. create a plain xorg.conf that requests 24bpp Depth
  3. startx
  4. peer in to /var/log/Xorg.0.log and notice that the driver
     have blatantly ignored your request for 24bpp, instead
     giving you 16bpp.

     * ...reference the specific ticket update which contains the
       steps.

     * Provide location and access information for repro machine, if
       available

  5. List any known hot-fix packages on the system

  Not applicable. Happens on a clean RHEL5.3 x86_64 install.

  6. List any customer applied changes from the last 30 days

  Other than clean install and running s-c-d? None.

===========================================================================

This appears to be a regression
Comment 2 Alan Matsuoka 2009-04-17 09:57:00 EDT
Hi Anders,

I retested this by changing the resolution upwards order (low resolution
to high resolution), since downwards order is not available due to IT#193072.

1) TX120S2(kronos2) + RHEL5.3 GA (xorg-x11-drv-mga-1.4.2-10.el5)

            16bpp  24bpp
640x480 .....  OK    NG
800x600 .....  OK    NG
1024x768 ....  OK    NG
1280x1024 ...  OK    --

Kronos2-el53ga-090417-2.tgz contains a complete set of Xorg.0.log files.

Takeshi Suzuki
Comment 3 Alan Matsuoka 2009-04-17 09:57:30 EDT
Created attachment 340013 [details]
Kronos2-el53ga-090417-2.tgz
Comment 4 Alan Matsuoka 2009-04-17 09:58:29 EDT
Created attachment 340014 [details]
sosreport-090416tx120s2el53ga-447746-0efc5a.tar.bz2
Comment 7 Larry Troan 2009-06-02 19:06:01 EDT
Believe this is a DUP of... 
 Bug 479919 -  hts-5.3-12 VIDEO test FAIL on mga driver 
 Built xorg-x11-drv-mga 1.4.10-1.el5
 Approved exception for Internal Beta Compose 2. (RHEL5.4 beta)
Comment 8 Alan Matsuoka 2009-06-03 10:15:31 EDT
Identical issue as 479919.

*** This bug has been marked as a duplicate of bug 479919 ***

Note You need to log in before you can comment on or make changes to this bug.