Bug 490659 - [RHEL5.3G] mga driver can not provide 24bpp on X
[RHEL5.3G] mga driver can not provide 24bpp on X
Status: CLOSED DUPLICATE of bug 479919
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-mga (Show other bugs)
5.3
All Linux
urgent Severity high
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-17 10:48 EDT by Alan Matsuoka
Modified: 2010-09-24 10:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-17 15:48:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
MGAoutput.zip - sosreport appears to be in the zip file (578.26 KB, application/x-zip-compressed)
2009-03-17 10:48 EDT, Alan Matsuoka
no flags Details

  None (edit)
Description Alan Matsuoka 2009-03-17 10:48:33 EDT
Created attachment 335531 [details]
MGAoutput.zip - sosreport appears to be in the zip file

State the problem

  1. Provide time and date of the problem
N/A

  2. Indicate the platform(s) (architectures) the problem is being
     reported against.
RHEL5.3GA, i686, x86_64, xorg-x11-drv-mga-1.4.2-10.el5

  3. Provide clear and concise problem description as it is
     understood at the time of escalation
         * Observed behavior

The issue is re-create from IT#268374 on NEC-Certification and this NEC's blocker for RHEL5.4.

This is problem about xorg-x11-drv-mga-1.4.2-10.el5 on RHEL5.3 and
this prevent 24bit color on many NEC servers using "MGA G200e [Pilot] ServerEngines (SEP1) (rev 02)".

Since this driver is hard coded for using 16bpp with X, though video card have efficien memory (8MB) for 24bpp.
This cause limitation issue for NEC customers. 

         * Desired behavior
Mga driver can privide 24bpp on X.

  4. State specific action requested of SEG
----
NEC tell me that this is must be fixed on RHEL5.4.
In the case I need exception for RHEL5.4.
----

  5. State whether or not a defect in the product is suspected
         * Provide Bugzilla if one already exists
BZ#479919

  6. If there is a proposed patch, make sure it is in unified diff
     format (diff -pruN)
N/A

  7. Refrain from using the word "hang", as it can mean different
     things to different people in different contexts. Use a better
     and more specific description of your problem.
----
Hardware Certification Test failed with "Warning ! Current color depth: 16 does not meet the minimum requirements !" for G200SE with mga driver. Video.py failed on normal kernel, Xen kernel, GuestOS

There is excerpt of error from video.py:

====================================
(EE) MGA(0): Forcing 16bpp on G200SE due to low memory.
(EE) MGA(0): Using settings from depth 24 section
(WW) MGA(0): xf86UnMapVidMem: cannot find region for [0x2b59d563e000,0x7f0000]
FreeFontPath: FPE "unix/:7100" refcount is 2, should be 1; fixing.
x11perf returned 0

Screen resolution: 1280x768
     Color depth: 16

Warning ! Current color depth: 16 does not meet the minimum requirements !

Video test on device video-card FAILED
...finished running ./video.py, exit code=1
====================================
----

  8. This is especially important for severity one and two
     issues. What is the impact to the customer when they experience
     this problem?
         * For example: "This system houses our accounts payable
           database. When the system crashes we are unable to process
           payroll, and other payable functions. This is especially
           critical as we approach end of our quarter."
----
Many NEC server used MGA G200, "MGA G200e [Pilot] ServerEngines (SEP1) (rev 02)".
where RHEL Certification requires 24bpp on X, but xorg-x11-drv-mga-1.4.2-10.el5 can not provide 24bpp.
They need mga driver for supporting customers, so this is big impact for NEC's server business.
----

**** Provide supporting info ****

  1. State other actions already taken in working the problem:
         * tech-list, google searches, fulltext, consulting with
           another engineer
         * Provide any relevant data found
----
I talked this with Rob Landry-san about BZ#479919, and very much, great helpful for current RHEL5.3 Hardware Certification.
But NEC strongly need to be fixed on *RHEL5.4* for this problem.
----

  2. Attach sosreport
Attached MGAoutput.zip, this include sosreport and result of video.py in hts.  

# unzip -l MGAoutput.zip
Archive:  MGAoutput.zip
 Length     Date   Time    Name
--------    ----   ----    ----
   95554  02-18-09 13:37   MGAoutput.log
  104019  02-18-09 13:37   VESAoutput.log
  566241  02-18-09 13:37   T120aMel5x64.2009021792353.tar.bz2
--------                   -------
  765814                   3 files

  3. Attach other supporting data
N/A

  4. Provide issue repro information:
         * List steps or...
         * ...reference the specific ticket update which contains the
           steps.
         * Provide location and access information for repro machine,
           if available
Always on X.

  5. List any known hot-fix packages on the system
N/A

  6. List any customer applied changes from the last 30 days
N/A


NOTES:


The error pops out for mga driver claiming the card is G200SE chip,
which hardcoats and caps the bpp at the max to 16. I'm guessing there
are variants of cards with the same chip but different ram, as lspci
indicates the card ready with 8MB, which would allow more bpp than
it is limited at the moment (if it's designed that way).

The ultimate of the vendor's wish is certifying the box, so we have
two things on our mind: 1. lift off 24bpp hurdle on 5.3 hts certification
and allow 16bpp as it was in 5.2 cert, or 2. Lift off 16bpp limit
or do anything to let the specific card get its way around it.

We are not sure if 2. is feasible for any card that returns reply
claiming G200SE, so if this is the path we are to take, then we
need to ask someone that's good with mga driver/products. Note
we are still not sure if this is actually functional with lifted-off
driver though.
Comment 2 Jeremy West 2009-03-17 15:48:11 EDT

*** This bug has been marked as a duplicate of bug 479919 ***

Note You need to log in before you can comment on or make changes to this bug.