Bug 480839 - Please enable all CONFIG_ISDN_DIVAS* options in kernel (2 are missing)
Please enable all CONFIG_ISDN_DIVAS* options in kernel (2 are missing)
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
All Linux
low Severity medium
: ---
: ---
Assigned To: Jarod Wilson
Red Hat Kernel QE team
:
Depends On: 480840
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-20 15:27 EST by Robert Scheck
Modified: 2010-11-09 08:18 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-03 10:28:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2009-01-20 15:27:52 EST
Description of problem:
There are only less active ISDN card controllers supported fine with Linux
and even less supported with HylaFax which is CAPI incompatible. Yes, there
is capi4hylafax, but that software is unmaintained for years now as well.

So in the past there was the active AVM B1 ISDN card which has worked very 
well. Unluckily this card is 5V only and can't be used in modern or at least
recent server hardware, which usually only has PCI-X (3.3V only) or PCIe
(3.3V or 12V).

Please enable all CONFIG_ISDN_DIVAS* options in the Red Hat Enterprise Linux
kernel, currently only the following are enabled.

CONFIG_ISDN_DIVAS=m
CONFIG_ISDN_DIVAS_BRIPCI=y
CONFIG_ISDN_DIVAS_PRIPCI=y
CONFIG_ISDN_DIVAS_DIVACAPI=m
CONFIG_ISDN_DIVAS_USERIDI=m
CONFIG_ISDN_DIVAS_MAINT=m

As of my knowledge, there are CONFIG_ISDN_DIVAS_HSI, CONFIG_ISDN_DIVAS_ANALOG
as well which are currently not enabled. Please enable them for at least ix86
and x86_64 - thank you.

Version-Release number of selected component (if applicable):
kernel-2.6.18-92.1.22.el5

Expected results:
All CONFIG_ISDN_DIVAS* options in kernel enabled (ix86 and x86_64).

Additional info:
Bug #480837 is the corresponding bug report for Fedora.
Comment 1 Jarod Wilson 2010-09-03 10:28:41 EDT
This just got assigned over to me, since its just a config option change request, so taking a look...

$ git grep ISDN_DIVAS
drivers/isdn/hardware/eicon/Kconfig:config ISDN_DIVAS
drivers/isdn/hardware/eicon/Kconfig:config ISDN_DIVAS_BRIPCI
drivers/isdn/hardware/eicon/Kconfig:    depends on ISDN_DIVAS
drivers/isdn/hardware/eicon/Kconfig:config ISDN_DIVAS_PRIPCI
drivers/isdn/hardware/eicon/Kconfig:    depends on ISDN_DIVAS
drivers/isdn/hardware/eicon/Kconfig:config ISDN_DIVAS_DIVACAPI
drivers/isdn/hardware/eicon/Kconfig:    depends on ISDN_DIVAS && ISDN_CAPI
drivers/isdn/hardware/eicon/Kconfig:config ISDN_DIVAS_USERIDI
drivers/isdn/hardware/eicon/Kconfig:    depends on ISDN_DIVAS
drivers/isdn/hardware/eicon/Kconfig:config ISDN_DIVAS_MAINT
drivers/isdn/hardware/eicon/Kconfig:    depends on ISDN_DIVAS && m
drivers/isdn/hardware/eicon/Makefile:obj-$(CONFIG_ISDN_DIVAS)           += divadidd.o divas.o
drivers/isdn/hardware/eicon/Makefile:obj-$(CONFIG_ISDN_DIVAS_MAINT)             += diva_mnt.o
drivers/isdn/hardware/eicon/Makefile:obj-$(CONFIG_ISDN_DIVAS_USERIDI)   += diva_idi.o
drivers/isdn/hardware/eicon/Makefile:obj-$(CONFIG_ISDN_DIVAS_DIVACAPI)  += divacapi.o
drivers/isdn/hardware/eicon/Makefile:divas-$(CONFIG_ISDN_DIVAS_BRIPCI)  += os_bri.o  s_bri.o os_4bri.o s_4bri.o
drivers/isdn/hardware/eicon/Makefile:divas-$(CONFIG_ISDN_DIVAS_PRIPCI)  += os_pri.o  s_pri.o
drivers/isdn/hardware/eicon/diva.c:#ifdef CONFIG_ISDN_DIVAS_PRIPCI
drivers/isdn/hardware/eicon/diva.c:#ifdef CONFIG_ISDN_DIVAS_BRIPCI
drivers/isdn/hardware/eicon/diva.c:#ifdef CONFIG_ISDN_DIVAS_PRIPCI
drivers/isdn/hardware/eicon/diva.c:#ifdef CONFIG_ISDN_DIVAS_BRIPCI
drivers/isdn/hardware/eicon/divasmain.c:#ifdef CONFIG_ISDN_DIVAS_BRIPCI
drivers/isdn/hardware/eicon/divasmain.c:#ifdef CONFIG_ISDN_DIVAS_PRIPCI

Not seeing _HSI or _ANALOG variants, likely meaning the Red Hat Enterprise Linux 5 code predates those variants. We'd probably need a driver backport here to even have those flags to enable. Please open a new bug if you'd like to request that, but for not, closing this as NOTABUG, since all available CONFIG_ISDN_DIVAS* options are already enabled.

Note You need to log in before you can comment on or make changes to this bug.