Bug 480840 - Please enable CONFIG_CAPI_EICON for x86_64 (already enabled for ix86)
Please enable CONFIG_CAPI_EICON for x86_64 (already enabled for ix86)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
All Linux
low Severity medium
: ---
: ---
Assigned To: Phillip Lougher
Red Hat Kernel QE team
:
Depends On:
Blocks: 480839
  Show dependency treegraph
 
Reported: 2009-01-20 15:28 EST by Robert Scheck
Modified: 2014-07-06 13:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:22:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2009-01-20 15:28:56 EST
Description of problem:
There are only less active ISDN card controllers supported fine with Linux
and even less supported with HylaFax which is CAPI incompatible. Yes, there
is capi4hylafax, but that software is unmaintained for years now as well.

So in the past there was the active AVM B1 ISDN card which has worked very 
well. Unluckily this card is 5V only and can't be used in modern or at least
recent server hardware, which usually only has PCI-X (3.3V only) or PCIe
(3.3V or 12V).

The only reasonable alternative seems to be Dialogic Diva (former Eicon);
so please enable for x86_64 the CONFIG_CAPI_EICON - on ix86 this is already
case. As far as I got Chuck Ebbert, this seems to be an accident in Fedora
which slipped into Red Hat Enterprise Linux as well. So CONFIG_CAPI_EICON
is enabled on ix86, but not on x86_64.

The Dialogic Diva (former Eicon) cards are known to work on ix86 and x86_64;
for ppc and so on I can't tell you that for sure. These cards are available
as PCI-X and as well as PCIe - very future oriented, AVM sales itself was stating on the phone to me, that they will not provide something else except 
AVM B1 and if we don't like it, we simply shall look for another product...

Version-Release number of selected component (if applicable):
kernel-2.6.18-92.1.22.el5

Expected results:
Enabled CONFIG_CAPI_EICON on x86_64 same as on ix86.

Additional info:
Please also have a look to bug #480839 in order to enable the missing CONFIG_ISDN_DIVAS* options in the kernel (ix86 and x86_64). Bug #480837 is
the corresponding bug report for Fedora.
Comment 1 RHEL Product and Program Management 2014-03-07 08:54:59 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 2 RHEL Product and Program Management 2014-06-02 09:22:45 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.