Bug 48103 - unable to install on laptop with external monitor attached
unable to install on laptop with external monitor attached
Status: CLOSED DUPLICATE of bug 45544
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-09 15:18 EDT by Chris Runge
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-10 01:16:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Runge 2001-07-09 15:18:39 EDT
Description of Problem:

Fairfax (beta 1)
Tried to install using CD-ROMs on a Dell Latitude CPx notebook PC docked in
a docking station with an external monitor. Choosing the graphical install
option (ENTER at boot:) results in the following error:

Running anaconda - please wait...
Probing for video card: ATI Rage Mobility
Probing for monitor type: Dell M791
Probing for mouse type: Generic - 3 Button Mouse (USB)
Waiting for X server to start...log located in /tmp/X.log
... X server started successfully.
Traceback (innermost last):
  File "/usr/bin/anaconda", line 421, in ?
    from splashscreenimport SplashScreenShow
  File "/usr/lib/anaconda/splashscreen.py", line 20, in ?
     from gtk import *
  File "/usr/lib/python1.5/site-packages/gtk.py", line 29, in ?
     _gtk/gtk_init()
RuntimError: cannot open display
install exied abnormally
sending termination signals...done
.
.
.

How Reproducible:


Steps to Reproduce:
1. dock Latitude CPx
2. attach external monitor
3. begin graphical install

Actual Results:

(see above)

Expected Results:

normal install

Additional Information:
	
FWIW, there are no problems when the machine is undocked and no external
monitor is attached. I'm guessing this is perhaps related to the
LCD/ext.monitor issue with the ATI driver on 7.1. It would be nice if some
intelligence could be built-in to know whether the LCD or external monitor
is active and act appropriately. Or will 4.1.0 fix this issue?
Comment 1 Brent Nordquist 2001-07-09 23:16:29 EDT
Looks like a duplicate of bug 47530?
Comment 2 Brent Fox 2001-07-10 01:16:03 EDT

*** This bug has been marked as a duplicate of 45544 ***

Note You need to log in before you can comment on or make changes to this bug.