Bug 481450 - Impossible to access install DVD as package source.
Impossible to access install DVD as package source.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 487987 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-24 19:34 EST by feddy
Modified: 2009-09-09 10:15 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-07 21:48:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description feddy 2009-01-24 19:34:24 EST
Description of problem:

Once installation is done there is now way to add any packages available on the DVD. (Contrary to what is suggested during install)

Version-Release number of selected component (if applicable):

Fed 10 installation DVD (64 bit)


How reproducible:


Steps to Reproduce:
1.install from Fed 10 DVD
2.complete first time reboot
3.attempt to add pkg with gui pkg manager
  
Actual results:
pkg manager refuses to do anything without going on line to check the std repos. No way to add the DVD as pkg source. No way to add or remove software.

Expected results:
Either that the DVD is available as a pkg source or there is a way to add it.

Additional info:

It seems crazy that I can not acces the full set of packages that were available 2 minutes earlier during install. The installer even tells me I can select individual packages during install or add them later. It does not say this REQUIRES an internet connection. A natural assumption is that I can use the same DVD source.

While a typical move would be to check the online repos I see no reason why this should be obligatory. There may be number of scenarios where it may be preferable or necessary to use the new system before going online.

The installation process should produce a fully functional system. currently it can not even display a list of the installed packages without going online and it is impossible to remove an unwanted pkg.
Comment 1 Panu Matilainen 2009-01-26 05:00:44 EST
Bug 248930 seems to say a DVD-repository should be automatically set up on install but what whether that's true for F10 and what the interaction with yum vs PackageKit etc is supposed to be I've no idea. Reassigning to PackageKit (as per "gui package manager"), rpm is not involved here at all as it doesn't know anything at all about repositories.
Comment 2 feddy 2009-01-26 06:19:52 EST
Sorry for incorrectly labelling this to rpm. Bugzilla insists on defining a category and says to guess if you dont know. So I did.


Bug 248930 does relate to this issue. Unfortunately it was close with CLOSED CURRENTRELEASE without having been addressed in the slightest.

If there is some linux guru's hack in /etc/yum.d that _may_ enable adding a DVD (remains to be tested in Fed 10) this is far from accessible and is no more than a workaround.

The issue here is that a) it should already be available as a repo after installing from the DVD without any user interaction and b) whether or not installed from DVD there should be an accessible means to add a repo.
Comment 3 Richard Hughes 2009-02-16 11:13:53 EST
There's some people wanting to work on this in PackageKit upstream, I would suggest you post there for what you would expect to happen.
Comment 4 Richard Hughes 2009-06-03 05:02:15 EDT
*** Bug 487987 has been marked as a duplicate of this bug. ***
Comment 5 Steven M. Parrish 2009-09-07 21:48:21 EDT
This is really not a bug, but a RFE.  I would suggest either talking with upstream via packagekit.org or IRC at freenode.org #packagekit.

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 feddy 2009-09-09 09:50:02 EDT
I reiterate from the original report:
>>
Once installation is done there is no way to add any packages available on the
DVD. (Contrary to what is suggested during install)
>>

From comment #2
>>
The issue here is that a) it should already be available as a repo after
installing from the DVD without any user interaction
>>

The fact that the DVD is not listed as a repo source is not the fault of packagekit. So unless you indicate that this was done *intentionally* such that Fedora remains blocked as an unmodifiable system , then it is a bug.

What sources are initially available is clearly under the control of the distro when the DVD is compiled.

I see no justification for pushing the blame elsewhere. 

Please see how this can be rectified.
Comment 7 feddy 2009-09-09 09:58:33 EDT
This would appear to result from an erroneous assumption that a network connection will always be present. 

I see no reason why the DVD should not allow package modifications after the initial installation process in a context where the hardware or other circumstances mean an external connection is not available.

If there is a reason for this , let's hear it. If not let's fix it.
Comment 8 Richard Hughes 2009-09-09 10:15:14 EDT
(In reply to comment #7)
>  If not let's fix it.  

New volunteers always welcome. I'm totally busy right now, and I admit installing from physical media isn't that important to me personally.

Note You need to log in before you can comment on or make changes to this bug.