Bug 485373 - backtrace from %preun error when removing package
backtrace from %preun error when removing package
Status: CLOSED DUPLICATE of bug 484729
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 486582 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-12 23:25 EST by Jens Petersen
Modified: 2014-01-21 18:08 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-20 08:53:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2009-02-12 23:25:54 EST
Description of problem:
When I try to remove a package with yum with a broken install script
I am getting a python backtrace from yum.

Version-Release number of selected component (if applicable):
yum-3.2.21-9.fc11

How reproducible:
every time

Steps to Reproduce:
1. yum install ghc-HTTP
2. yum remove ghc
  
Actual results:
2.
=============================================================================================================================================================
 Package                             Arch                            Version                                      Repository                            Size
=============================================================================================================================================================
Removing:
 ghc                                 i386                            6.10.1-8.fc11                                installed                            178 M
Removing for dependencies:
 ghc-HTTP                            i386                            3001.1.5-1.fc11                              installed                            1.4 M

Transaction Summary
=============================================================================================================================================================
Install      0 Package(s)         
Update       0 Package(s)         
Remove       2 Package(s)         

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Erasing        : ghc                                                                                                                                   1/2 
/usr/lib/ghc-6.10.1/HTTP-3001.1.5/unregister.sh: line 3: /usr/bin/ghc-pkg: そのようなファイルやディレクトリはありません
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/yum/rpmtrans.py", line 389, in callback
    self._scriptError(bytes, total, h)
  File "/usr/lib/python2.6/site-packages/yum/rpmtrans.py", line 509, in _scriptError
    (hdr, rpmloc) = h
ValueError: too many values to unpack
error: python callback <bound method RPMTransaction.callback of <yum.rpmtrans.RPMTransaction instance at 0x96f0d8c>> failed, aborting!


Expected results:
ghc-HTTP to be removed first and then ghc; no backtrace ;)

Additional info:
The removal order issue part looks very similar to bug 479257.
Comment 1 Jens Petersen 2009-02-12 23:28:23 EST
BTW I have added protection to some of the scripts in question in rawhide, so the script errors may stop "magically", but that still leaves the order issue at least and the backtrace will surely affect other package removals.
Comment 2 seth vidal 2009-02-13 09:48:16 EST
the traceback looks similar to:
484729 which, we thought, was ppc only.
Comment 3 seth vidal 2009-02-20 08:52:40 EST
*** Bug 486582 has been marked as a duplicate of this bug. ***
Comment 4 seth vidal 2009-02-20 08:53:27 EST

*** This bug has been marked as a duplicate of bug 484729 ***

Note You need to log in before you can comment on or make changes to this bug.