Bug 485789 - Add Provides: to slim package
Add Provides: to slim package
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: slim (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anders F Björklund
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 478821 527520
  Show dependency treegraph
 
Reported: 2009-02-16 14:40 EST by Christoph Wickert
Modified: 2009-10-20 09:36 EDT (History)
4 users (show)

See Also:
Fixed In Version: 1.3.1-5.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-11 20:26:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch yuminstall.py to set runlevel 5 if slim was installed (718 bytes, patch)
2009-02-16 14:40 EST, Christoph Wickert
no flags Details | Diff

  None (edit)
Description Christoph Wickert 2009-02-16 14:40:27 EST
Created attachment 332088 [details]
Patch yuminstall.py to set runlevel 5 if slim was installed

Description of problem:
If a user installs slim instead of gdm/kdm the system will not boot into runlevel 5 by default.

Version-Release number of selected component (if applicable):
11.5.0.19
Comment 1 Chris Lumens 2009-02-16 15:05:10 EST
It would be really great if all the packages that have a login manager could Provide: something so that we could just query on that, rather than having to maintain an ever-out-of-date list.
Comment 2 Chris Lumens 2009-02-20 14:08:24 EST
Please add Provides: service(graphical-login) to the slim package and rebuild.  After some discussion on fedora-devel-list, it looks like we have some consensus around this proposal.  Having done that, anaconda can then just query for that without needing to know anything about the exact package name.  Thanks.

I will file similar bugs against gdm and kdebase-workspace.
Comment 3 Christoph Wickert 2009-03-11 19:35:40 EDT
(In reply to comment #2)
 
> I will file similar bugs against gdm and kdebase-workspace.  

Chris, have you don that yet?


Anders, can this bug be closed now?
Comment 4 Christoph Wickert 2009-03-11 20:26:17 EDT
Ok, I could have answered that myself.

Removing the dependency on bug 485751 so this one can be closed now.

Note You need to log in before you can comment on or make changes to this bug.