Bug 485979 - unwanted muting with pulseaudio 0.9.15
unwanted muting with pulseaudio 0.9.15
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
: 489142 (view as bug list)
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-02-17 14:03 EST by Matthias Clasen
Modified: 2009-03-11 22:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-11 22:03:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2009-02-17 14:03:02 EST
I assume this is a side-effect of the flat volumes that recently landed in rawhide.

I am playing music in rhythmbox, open the popup in the gvc-applet, adjust the volume, click on desktop background to dismiss the popup. Afer a very short moment, the icon changes to muted, and opening the popup again and changing it does not bring any sound back.

Opening the sound capplet shows all output volumes (ie the master slider, the event sound slider and the rhythmbox volume) at 0.
Comment 1 Bastien Nocera 2009-02-17 14:05:17 EST
Does this happen with anything but rhythmbox? My guess is a dupe of bug 485547
Comment 2 Matthias Clasen 2009-02-18 02:58:20 EST
Also happens with flash
Comment 3 Matthias Clasen 2009-03-01 22:27:16 EST
Still happening here.
Comment 4 Matthias Clasen 2009-03-08 12:30:13 EDT
*** Bug 489142 has been marked as a duplicate of this bug. ***
Comment 5 John Ellson 2009-03-08 13:54:00 EDT
Same thing happens with audacious, although the audicious volume control isn't moved by either the gnome applet or pavucontrol.  Sound still gets muted after sliding the gnome-applet then touching anywhere else on the desktop.
Comment 6 Matthias Clasen 2009-03-10 00:59:48 EDT
Bastien, 

commenting out the following lines in 
gvc-channel-bar.c:on_scale_button_release_event
seems to fix this for me. Can you explain those lines ? 
For me, they seem to have the effect of always injecting a value of zero
into adjustment at the end of a drag...

        value = gtk_adjustment_get_value (bar->priv->zero_adjustment);
        gtk_adjustment_set_value (bar->priv->adjustment, value);
Comment 7 Bastien Nocera 2009-03-11 07:27:59 EDT
Probably because I didn't understand what the zero_adjustment was for, and I just copied the code out of on_zero_adjustment_value_changed().

See the patch as reviewed in:
http://bugzilla.gnome.org/show_bug.cgi?id=564313

I guess the zero_adjustment was supposed to be to cache the volume before we were muted. I'll try and fix that.
Comment 8 Matthias Clasen 2009-03-11 22:03:41 EDT
Fixed in gnome-media-2.25.92-3.fc11

Note You need to log in before you can comment on or make changes to this bug.