Bug 486346 - dma_debug: 8139cp 0000:00:03.0: DMA-API: device driver frees DMA memory with different size
dma_debug: 8139cp 0000:00:03.0: DMA-API: device driver frees DMA memory with ...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 506015 (view as bug list)
Depends On:
Blocks: 487882
  Show dependency treegraph
 
Reported: 2009-02-19 08:35 EST by Adam Tkac
Modified: 2013-04-30 19:42 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-12 03:40:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
KDE LiveCD fc-12alpha - dmesg (24.35 KB, application/octet-stream)
2009-08-24 10:11 EDT, Martin Kho
no flags Details

  None (edit)
Description Adam Tkac 2009-02-19 08:35:44 EST
Version-Release number of selected component (if applicable):
# uname -r
2.6.29-0.124.rc5.fc11.x86_64

How reproducible:
always

Steps to Reproduce:
1. use 8139cp network driver (for example install rawhide system as qemu guest)

Additional info:
Feb 19 14:24:58 rawhide kernel: ------------[ cut here ]------------
Feb 19 14:24:58 rawhide kernel: WARNING: at lib/dma-debug.c:439 check_unmap+0x16a/0x3dd() (Not tainted)
Feb 19 14:24:58 rawhide kernel: Hardware name:
Feb 19 14:24:58 rawhide kernel: 8139cp 0000:00:03.0: DMA-API: device driver frees DMA memory with different size [device address=0x000000000f74e1c2] [map size=1536 bytes] [unmap size=1538 bytes]
Feb 19 14:24:58 rawhide kernel: Modules linked in: sunrpc ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 dm_multipath virtio_balloon pcspkr virtio_pci 8139too virtio_ring 8139cp i2c_piix4 virtio mii i2c_core [last unloaded: freq_table]
Feb 19 14:24:58 rawhide kernel: Pid: 0, comm: swapper Not tainted 2.6.29-0.124.rc5.fc11.x86_64 #1
Feb 19 14:24:58 rawhide kernel: Call Trace:
Feb 19 14:24:58 rawhide kernel: <IRQ>  [<ffffffff810488f6>] warn_slowpath+0xb7/0xe7
Feb 19 14:24:58 rawhide kernel: [<ffffffff8106934c>] ? graph_unlock+0x6b/0x77
Feb 19 14:24:58 rawhide kernel: [<ffffffff8106c9d5>] ? __lock_acquire+0xb67/0xc0d
Feb 19 14:24:58 rawhide kernel: [<ffffffff81029c00>] ? pvclock_tsc_khz+0x8/0x2d
Feb 19 14:24:58 rawhide kernel: [<ffffffff8137bd9f>] ? _spin_lock_irqsave+0x78/0x86
Feb 19 14:24:58 rawhide kernel: [<ffffffff811985eb>] ? get_hash_bucket+0x28/0x34
Feb 19 14:24:58 rawhide kernel: [<ffffffff8106b139>] ? mark_lock+0x28/0x37f
Feb 19 14:24:58 rawhide kernel: [<ffffffff81198ae5>] check_unmap+0x16a/0x3dd
Feb 19 14:24:58 rawhide kernel: [<ffffffff8106b6d3>] ? trace_hardirqs_on_caller+0x118/0x153
Feb 19 14:24:58 rawhide kernel: [<ffffffff81198ea5>] debug_dma_unmap_page+0x50/0x52
Feb 19 14:24:58 rawhide kernel: [<ffffffffa001c19a>] dma_unmap_single+0x67/0x70 [8139cp]
Feb 19 14:24:58 rawhide kernel: [<ffffffffa001d587>] cp_rx_poll+0x16c/0x329 [8139cp]
Feb 19 14:24:58 rawhide kernel: [<ffffffff812e1631>] net_rx_action+0xb1/0x1e9
Feb 19 14:24:58 rawhide kernel: [<ffffffff812e1720>] ? net_rx_action+0x1a0/0x1e9
Feb 19 14:24:58 rawhide kernel: [<ffffffff8104de7c>] __do_softirq+0x8f/0x173
Feb 19 14:24:58 rawhide kernel: [<ffffffff810126ac>] call_softirq+0x1c/0x30
Feb 19 14:24:58 rawhide kernel: [<ffffffff81013799>] do_softirq+0x4d/0xb4
Feb 19 14:24:58 rawhide kernel: [<ffffffff8104dac7>] irq_exit+0x4e/0x8b
Feb 19 14:24:58 rawhide kernel: [<ffffffff81013aa8>] do_IRQ+0x127/0x14b
Feb 19 14:24:58 rawhide kernel: [<ffffffff81011d93>] ret_from_intr+0x0/0x2e
Feb 19 14:24:58 rawhide kernel: <EOI>  [<ffffffff8102927a>] ? native_safe_halt+0x6/0x8
Feb 19 14:24:58 rawhide kernel: [<ffffffff8106b71b>] ? trace_hardirqs_on+0xd/0xf
Feb 19 14:24:58 rawhide kernel: [<ffffffff81017a5f>] ? default_idle+0x4c/0x77
Feb 19 14:24:58 rawhide kernel: [<ffffffff8137ee0c>] ? atomic_notifier_call_chain+0xf/0x11
Feb 19 14:24:58 rawhide kernel: [<ffffffff810101db>] ? enter_idle+0x22/0x24
Feb 19 14:24:58 rawhide kernel: [<ffffffff81010240>] ? cpu_idle+0x63/0xae
Feb 19 14:24:58 rawhide kernel: [<ffffffff8136719d>] ? rest_init+0x61/0x63
Feb 19 14:24:58 rawhide kernel: ---[ end trace 6089c83d46ba2fbd ]---
Comment 1 Adam Tkac 2009-02-19 08:39:06 EST
It seems this is similar issue as bug #484494, bug #485994, bug #485778, bug #485648 and bug #485172
Comment 2 Bernie Innocenti 2009-03-31 22:00:45 EDT
Still happens with kernel-2.6.29-16.fc11.x86_64
Comment 3 Richard W.M. Jones 2009-04-28 16:57:20 EDT
I see this with 2.6.30-0.72.rc3.git3.fc12.x86_64 from Rawhide.  See the
very bottom of this build log for the full stack trace:

http://koji.fedoraproject.org/koji/getfile?taskID=1327043&name=build.log
Comment 4 Bug Zapper 2009-06-09 07:30:47 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Chuck Ebbert 2009-06-16 09:54:44 EDT
*** Bug 506015 has been marked as a duplicate of this bug. ***
Comment 6 Martin Kho 2009-08-24 10:09:52 EDT
FYI:
It still happens in the current rawhide and qemu-kvm (x86_64).

Host kernel: 2.6.31-0.167.rc6.git6.fc12.x86_64 (Rawhide)
Guest kernel: 2.6.31-0.125.4.2.rc5.git2.fc12.x86_64 (KDE LiveCD,
F12-KDE-036-x86_64.iso)

dmesg in next comment (#7)

Martin Kho
Comment 7 Martin Kho 2009-08-24 10:11:02 EDT
Created attachment 358461 [details]
KDE LiveCD fc-12alpha - dmesg
Comment 8 Chuck Ebbert 2009-10-12 03:40:41 EDT
fixed in 2.6.31
Comment 9 Martin Kho 2009-10-12 06:29:19 EDT
Tried it with kernel 2.6.31.1-23.fc12.x86_64 (F12-snap3). Yes, the problem no longer exists. Thanks for the good work!

Martin Kho

Note You need to log in before you can comment on or make changes to this bug.