Bug 486368 - ATI radeon very slow - almost unusable
ATI radeon very slow - almost unusable
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-02-19 09:40 EST by Mads Kiilerich
Modified: 2009-03-08 06:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-06 09:07:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/Xorg.0.log (66.63 KB, text/plain)
2009-02-19 09:42 EST, Mads Kiilerich
no flags Details
/var/log/dmesg (38.44 KB, text/plain)
2009-02-19 09:43 EST, Mads Kiilerich
no flags Details

  None (edit)
Description Mads Kiilerich 2009-02-19 09:40:42 EST
Description of problem:

F11 / rawhide on my system is so slow that it is almost unusable and I must consider giving up trying to test it. To me that is a serious regression in a serious component and I have set severity/priority to indicate that.

I dont' know where the slowness comes from, but it is visible that for example redrawing after switching windows is slow, so I assume it is related to the X driver.

I have seen other reports which might be similar to this one, but I haven't found anything conclusive, so I create this issue to track my issue and my uploads without confusing by mixing them with what other see and report.


Version-Release number of selected component (if applicable):

kernel-PAE-2.6.29-0.124.rc5.fc11.i686 no KMS as mentioned on bug 486327
xorg-x11-drv-ati-6.10.0-3.fc11.i586 no xorg.conf

01:00.0 VGA compatible controller: ATI Technologies Inc RV516 [Radeon X1300/X1550 Series]

.xsession-errors has a lot of other noise, but the only X related is:
Xlib:  extension "XFree86-Misc" missing on display ":0.0".
Comment 1 Mads Kiilerich 2009-02-19 09:42:12 EST
Created attachment 332562 [details]
/var/log/Xorg.0.log
Comment 2 Mads Kiilerich 2009-02-19 09:43:07 EST
Created attachment 332563 [details]
/var/log/dmesg
Comment 3 François Cami 2009-02-22 09:59:22 EST
Similar to bug 486049 .
Keeping both because of different hardware (RV516 vs R420).
Comment 4 James 2009-02-22 18:24:24 EST
My notebook with a Mobility Radeon 9200 M9+ (R280) certainly feels a lot more sluggish under F11 than it did under F8 or F9 with 2D and no desktop effects (glxgears gets around 1200 fps), this is using kernel-2.6.29-0.137.rc5.git4.fc11.i586 and xorg-x11-drv-ati-6.10.0-3.fc11.i586, with no xorg.conf. Should I report a separate bug for this?
Comment 5 Arkadi Shishlov 2009-02-24 14:55:35 EST
I think you could wait for 6.11.0 and check again. It feels a lot faster on RV350.
Comment 6 James 2009-02-27 19:53:01 EST
I see no improvement with the 6.11.0 driver.
Comment 7 Milos Jakubicek 2009-02-28 18:17:03 EST
This seems to be indeed a widespread regression. Just to recapitulate from:

https://www.redhat.com/archives/fedora-devel-list/2009-February/msg02329.html

related bugs might be:

bug 485651
bug 469577
bug 485275
bug 486049
maybe also in some way bug 242386

There are lot of affected users, adding as F11Blocker.
Comment 8 James 2009-03-01 05:36:28 EST
(In reply to comment #7)
> This seems to be indeed a widespread regression. Just to recapitulate from:
> 
> https://www.redhat.com/archives/fedora-devel-list/2009-February/msg02329.html

I tried dropping the patches from the SRPM as suggested, but saw no significant performance increase on my Mobility Radeon 9200. Hmm. There are an awful lot of things like 

Xorg:2269 freeing invalid memtype ea102000-ea112000

in the syslog after quitting X.
Comment 9 Mads Kiilerich 2009-03-06 09:07:07 EST
It works fine for me now, both with and without KMS, thanks!

xorg-x11-drv-ati-6.11.0-3.fc11.i586
kernel-PAE-2.6.29-0.203.rc7.fc11.i686

Closing
Comment 10 James 2009-03-08 06:33:19 EDT
Hmm... the 2D side of X is still sluggish on my M9+ system. At the login screen, for instance, the background doesn't fade in smoothly at all (~1 fps). This is with kernel-2.6.29-0.207.rc7.fc11.i586, xorg-x11-drv-ati-6.11.0-5.fc11.i586 and mesa-dri-drivers-7.3-10.fc11.i586.

Note You need to log in before you can comment on or make changes to this bug.