Bug 487816 - volume.fstype - ntfs or ntfs-3g?
volume.fstype - ntfs or ntfs-3g?
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-27 19:50 EST by Bradley
Modified: 2009-09-09 09:41 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-09 09:25:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bradley 2009-02-27 19:50:48 EST
Description of problem:

ntfs-3g has an FDI rule that matches volume.fstype=="ntfs" and replaces it with "ntfs-3g". This appears to have been done deliberately in Oct last year (2:1.5012-2) "to enable hal automounting".

That change broke some of hal's rules that detects (and avoids auto-mounting) recovery partitions, and was reverted (bug 469283)

Now its been added back (bug 484779), because its needed for NTFS automounting in F11 - apparently (https://bugs.launchpad.net/ubuntu/+source/ntfs-3g/+bug/300443) "HAL will no longer mount a volume with a filesystem driver that is different to what is specified in "volume.fstype", unless it is explicitly defined in "volume.fstype.alternatives"".

This broke the hal rule in 20-storage-methods.fdi (search for recovery in that file) again so now my recovery partition is automounted.

Naively 'ntfs' seems right, because that *is* the fstype and the fact that the program that can mount that filetype is called ntfs-3g is an implementation detail.

The hal spec says that fstype is "The specific type of ... the file system". 'volume.fstype.alternatives' isn't documented in the hal spec (http://people.freedesktop.org/~david/hal-spec/hal-spec.html or the later version in the hal-docs pacakge) so I don't know what that key is meant to represent.

Regardless, either gnome-mount/nautilus is wrong, the hal ignore rule is, or ntfs-3g should add itself to the 'alternatives' key instead. It'd be nice if all the distributions had the same hal values, too...

Version-Release number of selected component (if applicable):

hal-0.5.12-14.20081027git.fc10.x86_64
ntfs-3g-2009.2.1-2.fc10.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Have an NTFS recovery partition
2. lshal
  
Actual results:

volume.fstype is 'ntfs-3g'
volume.ignore is false

Expected results:

volume.ignore is true
volume.fstype is <something that makes this all work>
NTFS automounting works on F11?
ntfs-3g's fdi file has a comment in it explaining what its trying to do and how.
Comment 1 Tom "spot" Callaway 2009-02-28 09:48:54 EST
I have no earthly idea how hal works, how fdi files work, or what gnome-mount/nautilus are trying to do. I'm poking blindly in the dark here. So, unless someone is able to point me to documentation that is in English, or suggest an .fdi file that works properly, I'm not sure if/when this bug will be resolved.
Comment 2 Scott Glaser 2009-09-09 09:14:28 EDT
Have you tried with the latest hal package in Fedora 10, Fedora 11 or tried Rawhide? In either case, can you let us know whether the issue is still happening, and give the current version of the HAL packages you're using?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Bradley 2009-09-09 09:25:34 EDT
Seems to work in F11 now
Comment 4 Scott Glaser 2009-09-09 09:41:47 EDT
Bradley,

Based on comment 3 I will be closing this bug. Should you again encounter this bug, please file a new bug against the applicable component.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.