Bug 488307 - libgxim 0.3.2-3.fc10 breaks keyboard input
libgxim 0.3.2-3.fc10 breaks keyboard input
Status: CLOSED DUPLICATE of bug 488223
Product: Fedora
Classification: Fedora
Component: libgxim (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
: 488295 488434 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-03 12:51 EST by Henrique Martins
Modified: 2009-03-04 06:33 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-03 18:27:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henrique Martins 2009-03-03 12:51:17 EST
Description of problem:
libgxim-0.3.2-3.fc10.i386 release today breaks keyboard input

Version-Release number of selected component (if applicable):
libgxim-0.3.2-3.fc10.i386

How reproducible:
Some windows lose keyboard input, mouse past seems to work.
See https://bugzilla.redhat.com/show_bug.cgi?id=488295
See http://forums.fedoraforum.org/showthread.php?t=215535

Steps to Reproduce:
I use fvwm, windows started by the orignal script work fine
All new xterms don't have keyboard input

Actual results:
No keyboard

Expected results:
keyboard input

Additional info:
reverting to libgxim-0.3.1-1.fc10.i386 fixes the problem
Comment 1 Jindrich Novy 2009-03-03 13:11:35 EST
*** Bug 488295 has been marked as a duplicate of this bug. ***
Comment 2 Jindrich Novy 2009-03-03 13:13:24 EST
Please fix ASAP, it is very annoying.

Especially as xterm is affected as well.
Comment 3 Henrique Martins 2009-03-03 13:19:42 EST
I don't have any SCIM rpms on my system, but on fedoraforum people are also claiming that today's scim-anthy may have the same problem.
Comment 4 Jindrich Novy 2009-03-03 13:26:21 EST
Feel free to reassign to a proper component. Actually I'm not completely certain the bug is in libgxim. But I'm pretty sure it is not in nedit :)
Comment 5 Dan Beard 2009-03-03 13:35:24 EST
I suspect you're right.   :/
Comment 6 Henrique Martins 2009-03-03 13:38:27 EST
As I said, I don't have any scim-xxx rpms on my system.  I reverted libgxim, and only libgxim on my system and it's been working ever since.  

It could be that the bug is somewhere else, e.g. in the several X components updated in the last couple of weeks, but libgxim tickles it.
Comment 7 Henrique Martins 2009-03-03 13:54:17 EST
Just checked my home system, which I've updated right before leaving home but didn't notice anything wrong in the 2 minutes I was on after rebooting for today's kernel and getting my xemacs going.

Don't even have libgxim on my home, and only scim-devel and scim-libs.  Connected to my home system via vino-server and all input seems fine, but I'm not sure if going through vino-server is a good test of the input methods.
Comment 8 Dan Beard 2009-03-03 17:33:19 EST
Looks like this isn't limited to F10.

See this thread.   http://forums.fedoraforum.org/showthread.php?p=1177047
Comment 9 Emmanuel Thomé 2009-03-03 17:42:44 EST
(In reply to comment #6)
> As I said, I don't have any scim-xxx rpms on my system.  I reverted libgxim,
> and only libgxim on my system and it's been working ever since.  

Same here. My window manager is fvwm, xterm refuses input most of the time when the system has the new libgxim installed. With libgxim reverted, it works.

I've noticed several bizarre behaviours:

- ssh -X localhost , and then xterm from within the ssh tunnel sometimes does accept input
- start urxvt. Suffers from the same disease as xterm, but much more rarely. After four or five trials, I have a fresh urxvt uncapable of catching input. At this moment, all of a sudden, all xterms resume working as normal.

Needless to say, I've reverted libgxim to stay away from this mess.

Kinda annoying, since a keyboard is useful as long as I don't have neuronal implants working ;-).

E.
Comment 10 Henrique Martins 2009-03-03 18:27:06 EST

*** This bug has been marked as a duplicate of bug 488223 ***
Comment 11 Miroslav Lichvar 2009-03-04 06:33:30 EST
*** Bug 488434 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.