Bug 488768 - complains about the shipped-with-m-i-t configuration
complains about the shipped-with-m-i-t configuration
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: module-init-tools (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jon Masters
Fedora Extras Quality Assurance
: Reopened
: 492732 494429 (view as bug list)
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-03-05 12:23 EST by Bill Nottingham
Modified: 2014-03-16 23:17 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-26 17:24:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2009-03-05 12:23:19 EST
Description of problem:

WARNING: All config files need .conf: /etc/depmod.d/depmod.conf.dist, it will be ignored in a future release.

Version-Release number of selected component (if applicable):

module-init-tools-3.7-4.fc11.x86_64
Comment 1 Michal Jaegermann 2009-03-06 12:24:02 EST
In case of /etc/depmod.d/depmod.conf.dist module-init-tools warns against itself so this should be easy to resolve even in that "future release".  The more trouble is that other packages drop files in /etc/depmod.d/.  In my sample they belong also to hwdata, udev and pilot-link.  What about those?
Comment 2 Valdis Kletnieks 2009-03-10 12:00:10 EDT
It pretty much has to be solved in the RPM that owns the file - if udev drops a file in /etc/depmod.d that doesn't have a .conf ending, that's udev's problem.  But you'd expect that m-i-t would at least be self-consistent.

The way it has a '.conf.dist' ending makes it seem almost like a packaging whoops (hasn't *everybody* saved a backup copy of foo.c, done a patch, then checked foo.c.dist into the revision system by accident at least once? :)
Comment 3 Valdis Kletnieks 2009-03-10 12:04:54 EDT
Not a packaging whoops.

/etc/modprobe.d/modprobe.conf.dist has the exact same issue.
Comment 4 Mark McLoughlin 2009-03-23 10:09:29 EDT
Just did a rawhide install and seeing these warnings repeated 5 times during boot:

  WARNING: All config files need .conf: /etc/modprobe.d/floppy-pnp, it will be ignored in a future release.
  WARNING: All config files need .conf: /etc/modprobe.d/modprobe.conf.dist, it will be ignored in a future release.
  WARNING: All config files need .conf: /etc/modprobe.d/blacklist, it will be ignored in a future release.

It would seem silly to ship the beta with this. If it can't be quickly fixed, just disable the warning for the release? Adding to F11Beta
Comment 5 Jesse Keating 2009-03-23 11:17:40 EDT
this isn't a critical issue to the beta, and other changes are already happening in this package upstream that I would not like to introduce at this stage of the freeze.  It'll get fixed with updates shortly after the beta goes out.  Beta doesn't have to be perfect, far from it.
Comment 6 Jon Masters 2009-03-23 11:28:02 EDT
Actually, these remaining warnings come from hwdata owned files. That package was rebuilt on Friday so I would have thought it was already in the wild but apparently not. It *should* be fixed, but I will keep an eye on it.
Comment 7 Jesse Keating 2009-03-23 11:46:47 EDT
We're in a freeze, built packages don't show up in rawhide unless a freeze override is requested of releng, or we unfreeze after the release.

Are there any other changes in hwdata?
Comment 8 Allen Kistler 2009-03-26 21:45:57 EDT
I'm not certain another $0.02 is needed, but here's what's in /etc/modprobe.d and not covered by module-init-tools or hwdata on my system.

anaconda
  created by anaconda, though I didn't check any anaconda version newer than
   the install media

floppy-pnp
  owned by udev (and I didn't see a version newer in koji than in rawhide)
Comment 9 James Laska 2009-04-01 09:16:50 EDT
*** Bug 492732 has been marked as a duplicate of this bug. ***
Comment 10 Harald Hoyer 2009-04-01 09:31:59 EDT
floppy-pnp fixed in udev-139-3.fc11

http://koji.fedoraproject.org/koji/taskinfo?taskID=1270161
Comment 11 Martin Ebourne 2009-04-05 20:19:24 EDT
I'm also getting these:

WARNING: Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.
Owned by module-init-tools

WARNING: All config files need .conf: /etc/modprobe.d/blacklist-visor, it will be ignored in a future release.
Owned by pilot-link
Comment 12 Bill Nottingham 2009-04-06 16:35:38 EDT
*** Bug 494429 has been marked as a duplicate of this bug. ***
Comment 13 Tom "spot" Callaway 2009-04-15 15:18:11 EDT
blacklist fixed in hwdata-0.225-1.fc11
modprobe.conf.dist fixed in mpdule-init-tools-3.7-7.fc11
floppy-pnp fixed in udev-139-3.fc11
blacklist-visor fixed in pilot-link-0.12.3-20.fc11 (see 494765)
anaconda fixed in anaconda-11.5.0.39-1.fc11

I'm closing this one out. Please reopen if I missed any.
Comment 14 Michael Monreal 2009-04-16 03:16:16 EDT
I can confirm all of those messages are gone EXCEPT the anaconda one. I'm using anaconda-11.5.0.44-1
Comment 15 Tom "spot" Callaway 2009-04-16 10:38:07 EDT
Well, anaconda doesn't own that file. It writes it out during install, and when it writes it out, it now does so as anaconda.conf.
Comment 16 Michael Monreal 2009-04-17 04:39:45 EDT
Hmm... so any F10->F11 upgrader will still have the old anaconda file which will produce this warning message?
Comment 17 Tom "spot" Callaway 2009-04-17 09:49:35 EDT
Well, the problem is this:

That file gets written out during installation. What package should clean it up? And when?
Comment 18 Andre Robatino 2009-04-21 17:54:13 EDT
I'm still getting the warning about /etc/modprobe.conf, with rawhide fully updated as of April 21.  This can't be fixed by renaming since m-i-t owns it.  Since nothing owns /etc/modprobe.d/anaconda, I could fix the warning for it by renaming it as /etc/modprobe.d/anaconda.conf.
Comment 19 Allen Kistler 2009-04-21 19:58:31 EDT
Hmm...

# touch /etc/modprobe.conf
# rpm -qf /etc/modprobe.conf
module-init-tools-3.7-7.fc11.i586

Since modprobe.conf isn't supposed to be there anymore, maybe m-i-t shouldn't own it anymore.  I'd call *that* a bug.

For upgraders, it's not necessary to change its name.  Just move it into /etc/modprobe.d.  Though to be clear, I'm not expressing a position on whether anaconda should do it automatically or the upgrader should do to it manually.
Comment 20 Andre Robatino 2009-04-21 21:48:45 EDT
Looks to me like this bug (owning /etc/modprobe.conf) should be reopened, since this is a bug in m-i-t, and the Summary still describes the problem accurately, so it was never fully fixed.
Comment 21 Andre Robatino 2009-04-22 01:10:14 EDT
According to

rpm -ql module-init-tools

and

rpm -V module-init-tools

this package does in fact own a 0-byte /etc/modprobe.conf, which is what I have.  So anyone who isn't currently seeing this warning message has a broken m-i-t (until m-i-t is fixed to remove this file from it).
Comment 22 Andre Robatino 2009-05-01 02:13:22 EDT
Is the only necessary change here to remove the 0-byte file /etc/modprobe.conf from the package?  It's pretty trivial.  I know it's not exactly a F11 blocker, but would prevent a lot of duplicate bug reports if it was fixed before F11 comes out.
Comment 23 Jon Masters 2009-05-11 12:43:48 EDT
Ah, I'd not been watching this one since I thought module-init-tools was sorted out, missed the last comments about /etc/modprobe.conf. So the plan is to remove that from the next build of module-init-tools and add a %pre that moves the legacy modprobe.conf to /etc/modprobe.d/anaconda.conf iff it doesn't exist. Does that sound like a reasonable plan?
Comment 24 Jon Masters 2009-05-11 13:36:50 EDT
We think /etc/modprobe.d/local.conf is (in general) a good idea. So we'll make this file and shove in local-specific stuff in there. I'll have the scripts rename modprobe.conf to local.conf and put it into /etc/modprobe.d.
Comment 25 Jon Masters 2009-05-11 16:09:51 EDT
This is fixed now in module-init-tools-3.7-8.fc11
Comment 26 Jeremy Katz 2009-05-18 10:43:44 EDT
Jon -- to get this into F11, you'll need to file a request for it to be tagged at https://fedorahosted.org/rel-eng/

Although bug 496261 is also on the blocker list, with patch and still needs to be applied/built
Comment 27 Jesse Keating 2009-05-18 14:16:43 EDT
I do believe we're waiting on a newer build that migrates the anaconda generated file as well.  Jon?
Comment 28 Andre Robatino 2009-05-21 17:44:12 EDT
After today's update to module-init-tools-3.7-9.fc11, the warning about /etc/modprobe.conf is gone, the file itself is gone, m-i-t no longer owns it, and there is a file /etc/modprobe.d/local.conf which m-i-t owns.  Fixed for me.
Comment 29 Andre Robatino 2009-07-08 17:54:11 EDT
This is still not fixed in F11 final, despite the fact that the version is module-init-tools-3.7-9.fc11.  I still have a 0-byte /etc/modprobe.conf file owned by module-init-tools, with the corresponding warning in the bootup messages (assuming one has disabled graphical boot).
Comment 30 Andre Robatino 2009-07-08 17:55:51 EDT
Never mind, /etc/modprobe.conf is NOT owned by any package, so I can remove it.  Nevertheless, I did a clean install, so that file shouldn't be there.

Note You need to log in before you can comment on or make changes to this bug.