Bug 489427 - can't find partition in device tree
can't find partition in device tree
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
: 490042 490299 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-09 19:44 EDT by Peter Robinson
Modified: 2009-06-25 11:31 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-25 11:31:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda crash output (22.66 KB, text/plain)
2009-03-13 06:50 EDT, Peter Robinson
no flags Details

  None (edit)
Description Peter Robinson 2009-03-09 19:44:45 EDT
Getting a OLPC rawhide image from http://dev.laptop.org/~cjb/rawhide-xo/20090306/ I connect the .iso as a cdrom to a kvm virtual machine configured with a 2Gb virtual disk configred. I then do a "yum install anaconda libselinux-python" to install anaconda and run the liveinst command to install the livecd to disk.

When going through the install it crashes at the disk configuration option. It does so no matter what options I chose. I've tried first manually creating a FS on the virtual disk and it all works OK. 

I've tried using to option within anaconda to submit a bug or save the details but all the options fail (tried bugzilla, both disk options and scp) so the only output I get is what is written to the terminal I ran the liveinst command from.

The output is:

[root@localhost ~]# liveinst 
  0 logical volume(s) in volume group "vg_olpcrawhide" now active
23:00:20 Starting graphical installation...
Running... ['udevadm', 'settle', '--timeout=2']
Running... ['udevadm', 'settle', '--timeout=2']
Running... ['udevadm', 'settle', '--timeout=2']
Running... ['udevadm', 'settle', '--timeout=2']
Loading /lib/kbd/keymaps/i386/qwerty/uk.map.gz
Running... ['udevadm', 'trigger', '--subsystem-match=block']
Running... ['udevadm', 'settle', '--timeout=2']
Running... ['udevadm', 'settle', '--timeout=2']
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/sbin/anaconda", line 1009, in <lambda>
    sys.excepthook = lambda type, value, tb, anaconda=anaconda: handleException(anaconda, (type, value, tb))
  File "/usr/lib/anaconda/exception.py", line 644, in handleException
    runSaveDialog(anaconda, exn)
  File "/usr/lib/anaconda/exception.py", line 489, in runSaveDialog
    saveWin = anaconda.intf.saveExceptionWindow(anaconda, exn.tbFile)
  File "/usr/lib/anaconda/gui.py", line 1209, in saveExceptionWindow
    win = SaveExceptionWindow (anaconda, longTextFile)
  File "/usr/lib/anaconda/gui.py", line 744, in __init__
    dests = anaconda.id.storage.exceptionDisks()
  File "/usr/lib/anaconda/storage/__init__.py", line 391, in exceptionDisks
    disk = parted.Disk(device=dev)
  File "/usr/lib/python2.6/site-packages/parted/disk.py", line 49, in __init__
    self.__disk = _ped.Disk(device.getPedDevice())
_ped.DiskLabelException: /dev/sr0: unrecognised disk label

Original exception was:
Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 1318, in nextClicked
    self.setScreen ()
  File "/usr/lib/anaconda/gui.py", line 1401, in setScreen
    new_screen = self.currentWindow.getScreen(anaconda)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1331, in getScreen
    self.populate(initial = 1)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 815, in populate
    " tree" % partName)
RuntimeError: can't find partition dm-01 in device tree
Comment 1 Peter Robinson 2009-03-09 19:47:04 EDT
BTW version of anaconda is 11.5.0.25-1
Comment 2 David Lehman 2009-03-12 14:14:07 EDT
I'm not totally sure about the original exception, but the failure trying to save the exception was resolved in anaconda-11.5.0.26-1.
Comment 3 David Lehman 2009-03-12 14:16:31 EDT
dmraid support did not exist in 11.5.0.25 (it appeared in 11.5.0.26-1), so that also should be resolved in newer versions of anaconda.
Comment 4 Peter Robinson 2009-03-12 18:12:53 EDT
I wasn't trying to use dmraid. It was on a KVM VM with a single virtual disk. I was wanting to do an install all into a single partition. I couldn't even get that far. I have no idea where it was getting the dm options from.
Comment 5 Peter Robinson 2009-03-13 06:49:42 EDT
This still isn't working so reopening. The remote save worked as mentioned so I have the full debug. This debug is from using a VM with a single 2Gb virtual disk configured. I specified the option to use a customer layout hit next and then this happened.
Comment 6 Peter Robinson 2009-03-13 06:50:19 EDT
Created attachment 335069 [details]
anaconda crash output
Comment 7 Peter Robinson 2009-03-13 06:51:05 EDT
Anaconda version is 11.5.0.27-1
Comment 8 Chris Lumens 2009-03-13 09:57:51 EDT
*** Bug 490042 has been marked as a duplicate of this bug. ***
Comment 9 David Lehman 2009-03-13 11:14:17 EDT
Live installs are not working right now because they do not contain the udev rules needed for anaconda to properly identify the storage devices in the system. Sorry for the initial confusion.
Comment 10 Chris Lumens 2009-03-16 10:34:07 EDT
*** Bug 490299 has been marked as a duplicate of this bug. ***
Comment 11 Chris Lumens 2009-03-16 13:47:18 EDT
This should be fixed in the next build of anaconda.  Thanks for the bug report.
Comment 12 Bug Zapper 2009-06-09 08:03:46 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.