Bug 489433 - Blue screen on W2K8/64 while running WHQL "common scenario stress with IO" test on RHELSCSI
Blue screen on W2K8/64 while running WHQL "common scenario stress with IO" te...
Status: CLOSED DUPLICATE of bug 526398
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xenpv-win (Show other bugs)
5.3
x86_64 Linux
high Severity medium
: rc
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
: 526400 526404 (view as bug list)
Depends On: 526393
Blocks: 518435 566786
  Show dependency treegraph
 
Reported: 2009-03-09 21:20 EDT by koka xiong
Modified: 2010-11-09 07:41 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 566786 (view as bug list)
Environment:
Last Closed: 2010-03-16 09:32:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the testing log (751.22 KB, text/plain)
2009-03-16 04:15 EDT, koka xiong
no flags Details
the mindump file one (66.46 KB, application/octet-stream)
2009-04-21 04:17 EDT, koka xiong
no flags Details
minidump file two (66.46 KB, application/octet-stream)
2009-04-21 04:17 EDT, koka xiong
no flags Details
the common scenario xp/32 hang cmd dialogue (225.78 KB, image/png)
2009-04-21 22:06 EDT, koka xiong
no flags Details

  None (edit)
Description koka xiong 2009-03-09 21:20:40 EDT
Description of problem:
Install windows 2003 guest with xen-pv win dirver and do Common Scenario Stress with IO,the windows will have no response.

Version-Release number of selected component (if applicable):
xenpv-win-32-bit-1.0.0-1.el5.noarch.rpm

How reproducible:
always

Steps to Reproduce:
1.Install the xenpv-win-32-bit according to the install manual
2.Do the stress testing according to http://msdn.microsoft.com/en-us/library/dd450391.aspx

  
Actual results:
The windows has no response after suspend/hibernate/wake many times testing RedHat PV NIC Driver

The windows has no response after suspend/hibernate/wake many times testing RHEL SCSI Bus Miniport .

Expected results:
The RedHat PV NIC Driver and RHEL SCSI Bus Miniport should can pass Common Scenario Stress with IO

Additional info:
I'll submit the log later.
Comment 2 koka xiong 2009-03-16 04:15:55 EDT
Created attachment 335315 [details]
the testing log
Comment 3 koka xiong 2009-04-17 06:24:42 EDT
This one is failed one to get WHQL unclassified certificate.
I will supply as much information as possible.
Comment 4 Lawrence Lim 2009-04-17 06:28:36 EDT
Proposed this to blocker. If this bug is resolved, we should be able to obtain WHQL (unclassified).
Comment 5 koka xiong 2009-04-21 02:53:00 EDT
when doing PC NIC common scenario stress with I/O it can pass.
The scsi miniport bus will test pv nic driver and rhel scsi disk driver,it will fail and go to blue screen.
I will attach the minidump file after go to blue screen from win 2003/32bit.
Comment 6 ashok 2009-04-21 03:35:41 EDT
does this happen with XP(32-bit)?
Comment 7 koka xiong 2009-04-21 04:17:04 EDT
Created attachment 340483 [details]
the mindump file one
Comment 8 koka xiong 2009-04-21 04:17:52 EDT
Created attachment 340484 [details]
minidump file two
Comment 9 koka xiong 2009-04-21 22:02:47 EDT
I have tested with winxp/32 bit, when do the common scenario testing,it will disable the device,then the whole screen hang.the xp system has no response.
I will attach the screen shot.
Comment 10 koka xiong 2009-04-21 22:06:45 EDT
Created attachment 340663 [details]
the common scenario xp/32 hang cmd dialogue
Comment 12 Paolo Bonzini 2009-09-30 03:21:05 EDT
*** Bug 526400 has been marked as a duplicate of this bug. ***
Comment 13 Paolo Bonzini 2009-09-30 03:24:15 EDT
*** Bug 526404 has been marked as a duplicate of this bug. ***
Comment 14 Paolo Bonzini 2009-09-30 05:49:22 EDT
This is failing for both the RHELSCSI and RHELNET drivers; however, the latter's failure is probably just a consequence of RHELSCSI's.
Comment 16 Paolo Bonzini 2009-11-05 09:18:15 EST
The screenshot is yet another occurrence of bug 526393.  We have to rerun everything after 526393 is fixed, as it look like it is a showstopper for any kind of stress testing.
Comment 17 Paolo Bonzini 2010-02-19 12:49:25 EST
I still get a PAGEFAULT_IN_NONPAGED_AREA after fixing bug 526393 while testing RHELNET common scenario stess with IO.
Comment 18 Paolo Bonzini 2010-03-16 09:32:36 EDT
After the latest changes, RHELSCSI testing should be done with EnumeratingDevices = 3.  In this case, "Common Scenario Stress With IO" fails without hanging the machine.

As this test is basically "Sleep Stress With IO" (which passes) + "Disable Enable With IO", and it fails in the Disable() step, I'm closing this as duplicate.

*** This bug has been marked as a duplicate of bug 526398 ***

Note You need to log in before you can comment on or make changes to this bug.