Bug 526393 - netfront should stay in Initialising after RHELNET is disabled
Summary: netfront should stay in Initialising after RHELNET is disabled
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xenpv-win
Version: 5.4.z
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Paolo Bonzini
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 497793 526410 532876 533103 533802 (view as bug list)
Depends On: 591548
Blocks: 489433 518435 526398 526407 526440 532840 533103 566786 595780
TreeView+ depends on / blocked
 
Reported: 2009-09-30 05:03 UTC by koka xiong
Modified: 2010-11-22 23:27 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Repeatedly disabling and enabling network cards caused the guest system to become unresponsive.
Clone Of:
Environment:
Last Closed: 2010-07-08 09:22:57 UTC


Attachments (Terms of Use)
disable/enable with IO the failing step (118.65 KB, image/png)
2009-09-30 05:04 UTC, koka xiong
no flags Details
patch that should fix the bug (8.89 KB, patch)
2009-12-15 18:32 UTC, Paolo Bonzini
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0514 normal SHIPPED_LIVE xenpv-win bug fix update 2010-07-08 09:22:29 UTC

Description koka xiong 2009-09-30 05:03:20 UTC
Description of problem:
The xen pv NIC failed 2008 R2 Disable/Enable with IO

Version-Release number of selected component (if applicable):
xenpv-win-64-bit-1.0.90-2.el5.noarch.rpm

How reproducible:
always

Steps to Reproduce:
1.Configure WHQL testing env
2.Run Disable/Enable with IO,the windows will go to no response,the run can't be finished
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 koka xiong 2009-09-30 05:04:57 UTC
Created attachment 363116 [details]
disable/enable with IO the failing step

Comment 2 Paolo Bonzini 2009-11-04 10:33:27 UTC
*** Bug 532876 has been marked as a duplicate of this bug. ***

Comment 3 Paolo Bonzini 2009-11-04 10:41:33 UTC
*** Bug 532866 has been marked as a duplicate of this bug. ***

Comment 4 Paolo Bonzini 2009-11-05 12:52:24 UTC
I can reproduce this just by disabling/enabling a NIC device ~5 times.  It fails under either 2003 or 2008.

Comment 5 Paolo Bonzini 2009-11-10 13:48:45 UTC
*** Bug 497793 has been marked as a duplicate of this bug. ***

Comment 6 Paolo Bonzini 2009-12-15 18:32:40 UTC
Created attachment 378575 [details]
patch that should fix the bug

Comment 9 Paolo Bonzini 2010-04-21 13:08:24 UTC
*** Bug 533103 has been marked as a duplicate of this bug. ***

Comment 10 Paolo Bonzini 2010-05-13 12:08:48 UTC
The patch is now in master.  It fixes RHELNET "Disable/Enable with IO", "Common Scenario Stress with IO", "Plug and Play" tests.

Comment 11 Paolo Bonzini 2010-05-13 12:09:19 UTC
*** Bug 526410 has been marked as a duplicate of this bug. ***

Comment 12 Paolo Bonzini 2010-06-02 13:14:54 UTC
*** Bug 533802 has been marked as a duplicate of this bug. ***

Comment 15 Xiaoli Tian 2010-06-25 00:53:26 UTC
It pass for windows 2008 R2 with  xenpv-win-1.2.0-1 ,xen-3.0.3-105
and kernel 2.6.18-194.7.1.

Comment 16 Yewei Shao 2010-06-25 10:08:18 UTC
Verified the bug based on the comment #15.

Comment 17 Jaromir Hradilek 2010-06-25 11:39:11 UTC
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
Repeatedly disabling and enabling network cards caused the guest system to become unresponsive.

Comment 19 errata-xmlrpc 2010-07-08 09:22:57 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0514.html


Note You need to log in before you can comment on or make changes to this bug.