Bug 526398 - The SCSI failed 2008R2 disable/enable with IO
Summary: The SCSI failed 2008R2 disable/enable with IO
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xenpv-win
Version: 5.4
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Paolo Bonzini
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 489433 532893 (view as bug list)
Depends On: 526393
Blocks: 518435
TreeView+ depends on / blocked
 
Reported: 2009-09-30 05:18 UTC by koka xiong
Modified: 2011-02-01 09:00 UTC (History)
4 users (show)

Fixed In Version: 1.3.0-1
Doc Type: Bug Fix
Doc Text:
Previously, disabling and re-enabling the SCSI device caused the windows guest to crash. With this update, the RHELSCSI driver behaves properly when disabling and re-enabling the SCSI controller device.
Clone Of:
Environment:
Last Closed: 2011-02-01 09:00:26 UTC


Attachments (Terms of Use)
disable/enable with IO the failing step_SCSI (115.23 KB, image/png)
2009-09-30 05:18 UTC, koka xiong
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0187 normal SHIPPED_LIVE xenpv-win bug fix update 2011-02-01 08:59:58 UTC

Description koka xiong 2009-09-30 05:18:23 UTC
Created attachment 363119 [details]
disable/enable with IO the failing step_SCSI

Description of problem:
The SCSI failed 2008R2 disable/enable with IO 

Version-Release number of selected component (if applicable):
xenpv-win-64-bit-1.0.90-2.el5.noarch.rpm

How reproducible:
always

Steps to Reproduce:
1.Configure the WHQL and run SCSI 2008 R2 testing
2.The test can't end,the windows has no response
3.
  
Actual results:


Expected results:


Additional info:
Please see the attachment to see the specific step that cause no response.

Comment 1 Paolo Bonzini 2009-11-04 10:34:02 UTC
*** Bug 532893 has been marked as a duplicate of this bug. ***

Comment 2 Paolo Bonzini 2009-11-04 10:34:40 UTC
From the duplicate bug 532893:

> Sometimes it will get the blue window and after I try to reboot it manually,
> the windows can not start up again. So can not get any minidump.
> Sometimes the windows will no more response during the testing.

Comment 3 Paolo Bonzini 2009-11-05 13:01:48 UTC
The SCSI device cannot be disabled unless you are not enumerating devices.

Can you try this test with no NICs installed?  If it passes, please close it as a dup of 526393.

Comment 4 Paolo Bonzini 2010-03-16 13:31:43 UTC
After the latest changes, RHELSCSI testing should be done with EnumeratingDevices = 3.  In this case, "Disable Enable With IO" fails without hanging the machine.

"Reinstall with IO" and "Plug and Play test" fail in the same way, and I'm opening separate bugs for them.

"Common Scenario Stress With IO" fails in the same way, but as it is basically "Sleep Stress With IO" + "Disable Enable With IO", and it fails in the Disable() step, I'm not opening a separate bug.

Comment 5 Paolo Bonzini 2010-03-16 13:32:36 UTC
*** Bug 489433 has been marked as a duplicate of this bug. ***

Comment 8 RHEL Product and Program Management 2010-08-09 19:01:14 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 9 Paolo Bonzini 2010-09-30 11:49:29 UTC
The fix is now in the master branch of the xenpv-win repo.

Comment 13 Florian Nadge 2010-10-18 16:26:20 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, disabling and re-enabling the SCSI device caused the windows guest to crash. With this update, the RHELSCSI driver behaves properly when disabling and re-enabling the SCSI controller device.

Comment 14 cshao 2010-10-19 02:30:23 UTC
After test in xenpv-win-1.3.0-1.el5,  the job "disable/enable with IO" can pass in win2008R2 guest.
So change bug status to verified.

Comment 15 errata-xmlrpc 2011-02-01 09:00:26 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0187.html


Note You need to log in before you can comment on or make changes to this bug.