Bug 490232 - RFE: s-c-date doesn't centre map when a GMT[+/-x] zone is selected
RFE: s-c-date doesn't centre map when a GMT[+/-x] zone is selected
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-date (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-13 18:48 EDT by David Timms
Modified: 2016-08-10 10:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 427177
Environment:
Last Closed: 2016-08-10 10:37:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
assign the GMT[x] entries to have latitutude and longitude (915 bytes, patch)
2009-03-14 09:03 EDT, David Timms
no flags Details | Diff
trick the sort routine into leaving the GMT zone item order as created (929 bytes, patch)
2009-03-14 09:09 EDT, David Timms
no flags Details | Diff

  None (edit)
Description David Timms 2009-03-13 18:48:24 EDT
+++ This bug was initially created as a clone of Bug #427177 +++

+++ This bug was initially created as a clone of Bug #293241 +++

Description of problem:
s-c-date allows selection of GMT timezones. It would be nice to rotate the map to centre the timezone location. A further enhancement could highlight the 1/24 of the map that corresponds to the selected GMT timezone.

Version-Release number of selected component (if applicable):
system-config-date-1.9.36-1.fc11.noarch

Steps to Reproduce:
1. start system-config-date from gnome-terminal
2. Time Zone tab
3. scroll to bottom of selected city pane
4. expand non-geographic-timezones
5. choose any of the GMT options.
  
Actual results:
1. Nothing seems to happen in the map

Info:
I propose a simple way around this might be to assign a lat/long to each of the
GMT zones of 15x{GMT zone}degE:0degN.
Additionally place those positions around the equator on the map.
If you think this would be suitable, let me know and I'll take a deeper look.

If you think that it would be better to highlight N-S bands around the map, and
you think that is possible with the current widgets etc, I wouldn't mind taking
a look.
Comment 1 David Timms 2009-03-14 09:03:21 EDT
Created attachment 335203 [details]
assign the GMT[x] entries to have latitutude and longitude

This patch takes the simpler approach of placing each of the GMT zone times as yellow dots round the equator. Both list selection or scrolling, as well as map point selection changes track the relevant item.
A non-integer long/lat is created so that code in timezone_map_gui.py does not assume that either value is zero should alter the operation to not map the point.

Also, wraps overly negative timezones into the positive longitudes.
Comment 2 David Timms 2009-03-14 09:09:36 EDT
Created attachment 335204 [details]
trick the sort routine into leaving the GMT zone item order as created

Additional patch so that the GMT list is no longer sorted alphanumerically. This leaves the GMT zones in -14,-13,-12,...,11,12 order.

To achieve this, the initial sort field is created to be ascending based on original item position, and starting at 10 so that 10<11 etc, rather than 1<10<11<2

A possibly better implementation would be to initially exclude the GMT group from the copied (sort) list, sort the first part, then append the GMT part in the original order, at the end.
Comment 3 David Timms 2009-04-15 09:09:26 EDT
Is there any interest in this expansion of the time zone markings on the map ?
Comment 4 Nils Philippsen 2009-04-16 06:09:27 EDT
I don't think having map markers for GMT+/-... timezones is a good idea (they're non-geographic timezones ;-). I'll see whether I can make the markers invisible for them so selecting one from the list would pan the map accordingly (if zoomed in).

Thanks for the sorting patch, I've applied it to git (though I'll probably rework the sorting anyway to make it more robust).
Comment 5 Nils Philippsen 2016-08-10 10:37:57 EDT
Thanks for taking the time to submit this request for enhancement.
Unfortunately, I haven't gotten around to implement this feature, sorry for
that.

Because I don't actively develop system-config-date anymore, I won't likely find
the time to work on this ticket, so I'll close this bug now.

Note You need to log in before you can comment on or make changes to this bug.