Bug 49143 - .abw, .rtf, .doc files not associated
.abw, .rtf, .doc files not associated
Status: CLOSED DUPLICATE of bug 50924
Product: Red Hat Raw Hide
Classification: Retired
Component: gnome-vfs (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-15 12:53 EDT by Ed McKenzie
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-28 09:54:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Correct app name in shortlist; diff from installed .keys (2.61 KB, patch)
2001-08-28 03:37 EDT, Toralf
no flags Details | Diff

  None (edit)
Description Ed McKenzie 2001-07-15 12:53:59 EDT
Red Hat's GNOME desktop has never shipped with associations for word
processing documents.  I think this is a bug, since the shipped KDE
packages install KWord (which IMO is much less mature than AbiWord.)  I
don't know where mime-type info is stored in GNOME these days, but
gnome-vfs sounds like as good a guess as any.

Including AbiWord in the default install was filed as bug 49142.
Comment 1 Toralf 2001-08-28 03:35:29 EDT
I think the problem is that /usr/share/mime-info/gnome-vfs.keys lists "abiword"
in shortlist for application/x-abiword, application/msword, while Red Hat
abiword package installs binary as "AbiWord" - gnome-vfs doesn't seem to
understand that these are the same app. (I think it should still pick up
"open=AbiWord" from abiword.keys, but it seems like it doesn't.)

To fix, [see attached patch], or install application as "abiword", or fix
gnome-vfs...
Comment 2 Toralf 2001-08-28 03:37:53 EDT
Created attachment 29834 [details]
Correct app name in shortlist; diff from installed .keys
Comment 3 Toralf 2001-08-28 04:14:50 EDT
I think what it all boils down to is that you should sync your spec file with
src/pkg/linux/rpm/abisuite.spec-template from AbiWord source tree.
Comment 4 Toralf 2001-08-28 07:50:14 EDT
Another problem here is that the mime-info files are inconsistent; abiword.keys
contains just

application/x-abiword
	ext: abw

but abiword.keys sets up handlers for text/abiword, not application/x-abiword.

Also, http://bugzilla.gnome.org/show_bug.cgi?id=59670, is clearly related to this.

Comment 5 Alexander Larsson 2001-08-28 11:07:54 EDT

*** This bug has been marked as a duplicate of 50924 ***

Note You need to log in before you can comment on or make changes to this bug.