Bug 491691 - [RHEL4.8 Beta] Bottom part of display is garbled in X-windows on MGA G200e with 1.7MB memory
[RHEL4.8 Beta] Bottom part of display is garbled in X-windows on MGA G200e wi...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
4.8
All Linux
urgent Severity high
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-23 12:37 EDT by Alan Matsuoka
Modified: 2010-10-23 04:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 09:44:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen-noise-investigation_file.tar.bz2 (910.44 KB, application/x-bzip2)
2009-03-23 12:37 EDT, Alan Matsuoka
no flags Details

  None (edit)
Description Alan Matsuoka 2009-03-23 12:37:24 EDT
Created attachment 336322 [details]
screen-noise-investigation_file.tar.bz2

This is *Regression* issue related to Xorg mga driver.
I belive combination of G200e and mga driver on xorg is very problematic.

**** General Escalation Information ****

State the problem

 1. Provide time and date of the problem
N/A

 2. Indicate the platform(s) (architectures) the problem is being
    reported against.
RHEL4.8 *Beta*, x86_64, xorg-x11-6.8.2-1.EL.62

 3. Provide clear and concise problem description as it is
    understood at the time of escalation
        * Observed behavior
Bottom part of the screen is garbled

        * Desired behavior
The screen is displayed without the noise.

 4. State specific action requested of SEG
----
I belive there is several combination of issues/bugs on X with G200e @ 24bpp.
IMO, this is problem how to detect/treat G200e series (Chipset:
"mgag200 SE A PCI") on Xorg.

For RHEL5.4/4.8 and RFEs (Backgrounds, I believe)

Basically, Xorg mga driver had no capability for 24bpp on X with MGA
G200e, if video memory would be recognized properly, because of hard
coding 16bpp on X (please see BZ#479919 for RHEL5.3).

So there's already RFE request for RHEL4.8 (by Fujitsu-Siemens) and
RHEL5.4 (by NEC).  Besides, it seemed there's much complicated that
MGA200e has 2 versions (Kronos-1 has 1.7MB Video Ram, Kronos-2 has
8MB) and MGA200 has 2 version (Pilot 1 and Pilot 2). About this,
please see BZ#469651.

For this issue

NEC have Great concern about that many server already shipped use
MGA200e (Pilot1, Kronos-1, pci-id 102b:0522) affected by this
problem and they think this as very important (prioritized) one.

In this time, they reported display corruption problem on RHEL4.8
Beta on this ticket, and memory detection problem on other ticket
(IT#278328).
I believe that both of issues should be fixed on
RHEL4.8, (and/or on z-stream?) through BZ#469651, on which
Fujitsu-Siemens also repoted similar problem.
----

 5. State whether or not a defect in the product is suspected
        * Provide Bugzilla if one already exists
RHEL4 for BZ#469651, RHEL5 for BZ#479919 (maybe related).

 6. If there is a proposed patch, make sure it is in unified diff
    format (diff -pruN)

 7. Refrain from using the word "hang", as it can mean different
    things to different people in different contexts. Use a better
    and more specific description of your problem.
----
Bottom part of display is garbled in X-windows on servers using MGA G200e.

This problem occurred on Pilot small VideoRAM if 24bpp is specified in RHEL4.8 Beta x86_64.
This problem did not occur on Pilot large VideoRAM (Pilot 2nd gen) even if 24bpp is specified in RHEL4.8 Beta x86_64.

  VideoRAM size
    Pilot small VideoRAM : 1696 kByte
    Pilot 2nd gen        : 8128 kByte

- This problem does not occur on RHEL4.8 Beta X86_64(select 16bpp).
- This problem does not occur on RHEL4.8 Beta i386.
  + RHEL4.8 Beta i386 cannot select 800x600 24bpp with the GUI tool.

[detail]
+----------------------+--------------+---------+
| config               | RHEL4.7      | RHEL4.8 |
| arch(Modes Depth)    | GA           | Beta    |
+----------------------+--------------+---------+
|x86_64(800x600 24bpp) | OK           | NG      |
|x86_64(800x600 16bpp) | OK           | OK      |
|i386(800x600 24bpp)   | Can't select | NG(*1)  |
|i386(800x600 16bpp)   | OK           | OK      |
+----------------------+--------------+---------+
*1 Adding 800x600 to the line of Modes of xorg.conf
----

 8. This is especially important for severity one and two
    issues. What is the impact to the customer when they experience
    this problem?
        * For example: "This system houses our accounts payable
          database. When the system crashes we are unable to process
          payroll, and other payable functions. This is especially
          critical as we approach end of our quarter."
----
This is a regression issue which affects servers already shipped.
----

**** Provide supporting info ****

 1. State other actions already taken in working the problem:
        * tech-list, google searches, fulltext, consulting with
          another engineer
        * Provide any relevant data found

 2. Attach sosreport
Attached screen-noise-investigation_file.tar.bz2 including sosreport-Suruga3B-248113-e3e7e9.tar.bz2.

 3. Attach other supporting data

Also rhel4.8beta_x86_64_screen.png (screen shot which show garbled screen) is included in screen-noise-investigation_file.tar.bz2.

 4. Provide issue repro information:
        * List steps or...
        * ...reference the specific ticket update which contains the
          steps.
        * Provide location and access information for repro machine,
          if available
----
How reproducible:
Always

Steps to Reproduce:
1. Install RHEL4.8 Beta on x86_64.
2. After the installation is completed, reboot the system.
3. Display the X graphical login screen.
----

 5. List any known hot-fix packages on the system
N/A

 6. List any customer applied changes from the last 30 days
N/A

**** Regressions ****

 1. What is the last known working version (specific
    name-version-release) of the package?
xorg-x11-6.8.2-1.EL.52

 2. What is the specific name-version-release of the package where
    the customer discovered the regression?
xorg-x11-6.8.2-1.EL.62

 3. Please paste the contents of the change log between these two
    versions. Not the entire changelog contents. (rpm -qp [package]
    --changelog
----
2009-03-06 22:00:00
Adam Jackson <ajax@redhat.com> 6.8.2-1.EL.62:
- xorg-x11-6.8.2-mga-g200se-dont-force-16bpp.patch: Fix option parsing to
work (and not be quite so crashy). (#485156)

2009-02-12 22:00:00
Adam Jackson <ajax@redhat.com> 6.8.2-1.EL.60:
- xorg-x11-6.8.2-mga-g200se-dont-force-16bpp.patch: Do vram probe
earlier, and fix inverted test sense. (#485156)

2009-02-12 22:00:00
Adam Jackson <ajax@redhat.com> 6.8.2-1.EL.61:
- xorg-x11-6.8.2-dev-input-mice.patch: Try /dev/input/mice when
searching for automatic mouse device. (#485305)

2009-01-28 22:00:00
Dave Airlie <airlied@redhat.com> 6.8.2-1.EL.59:
- xorg-x11-6.8.2-fix-powerpc-fonts.patch (#300911)

2009-01-27 22:00:00
Kristian Høgsberg <krh@redhat.com> 6.8.2-1.EL.58:
- Fix segfault on xfs drone server exit path.
- Update Sun6 keyboard patch to not drop the \| key.

2009-01-23 22:00:00
Dave Airlie <airlied@redhat.com> 6.8.2-1.EL.57:
- xorg-x11-6.8.2-xkbcomp-add-ibm_spacesaver.patch (#454831)
- xorg-x11-6.8.2-mga-g200se-dont-force-16bpp.patch (#469651)

2009-01-12 22:00:00
Adam Jackson <ajax@redhat.com> 6.8.2-1.EL.56:
- xorg-x11-6.8.2-g200-ev-wb.patch: Add support for Maxim and Winbond
variants. (#445498, #454780)

2009-01-08 22:00:00
Adam Jackson <ajax@redhat.com> 6.8.2-1.EL.55:
- Fix libGLU.a build on x86_64. (#432087)

2008-12-08 22:00:00
Adam Jackson <ajax@redhat.com> 6.8.2-1.EL.53:
- xorg-x11-6.8.2-drm-device-permissions.patch: Fix initial DRI device
permissions. (#462106)

2008-12-08 22:00:00
Adam Jackson <ajax@redhat.com> 6.8.2-1.EL.54:
- xorg-x11-6.8.2-fb-traps-crash.patch: Fix crash in trapezoid rendering
triggered by Firefox, among other things. (#463137)
----

 4. Have you been able to narrow the regression down to a specific version?
        * If so, which one?

 5. Have you been able to narrow the regression down to a specific
    patch committed? If so, which one?

 6. Provide the exact steps to reproduce the regression so
    SEG/engineering can narrow down where the regression was
    introduced if not already known and/or analyse how the
    regression is occurring.
Please see above **** Provide supporting info ****, section 4.

Thanks in advance.

Regards,
Masaki Furuta
Comment 1 RHEL Product and Program Management 2009-03-23 12:41:33 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 2 Adam Jackson 2009-03-25 10:31:52 EDT
Please test:

http://people.redhat.com/~ajackson/xorg-x11-6.8.2-1.EL.62.jx1/
Comment 3 Adam Jackson 2009-03-26 17:06:37 EDT
Oops, incomplete fix.  Please test:

http://people.redhat.com/~ajackson/xorg-x11-6.8.2-1.EL.62.jx2/
Comment 5 Ben Levenson 2009-04-09 10:59:39 EDT
This should be fixed in xorg-x11-6.8.2-1.EL.63. Please retest. Thanks.
Comment 7 Chris Ward 2009-04-14 09:44:31 EDT
Closing. Fixed in xorg-x11-6.8.2-1.EL.63
Comment 9 Chris Ward 2009-04-15 05:06:51 EDT
This issue was never accepted into the release and was confirmed to be fixed as of xorg-x11-6.8.2-1.EL.63. If you encounter any issues, please let me know asap.
Comment 10 Issue Tracker 2009-04-19 22:33:04 EDT
Ueda-san,

This will go including RHEL4.8 and I'll keep it open till RHEL4.8
released.
If you encounter any issues, please let me know asap.

Regards,
Masaki Furuta



This event sent from IssueTracker by mfuruta@redhat.com 
 issue 277451
Comment 12 Chris Ward 2009-04-20 03:23:43 EDT
Furuta-san,

xorg-x11-6.8.2-1.EL.63 should fix this issue. If it does, it will remain fixed in the GA, without this bugzilla. If it is not fixed, please let me know ASAP.

Grab those packages here, in case you aren't able to access them.

http://people.redhat.com/cward/4.8/xorg-x11/
Comment 13 Issue Tracker 2009-04-20 04:18:07 EDT
Hi Ueda-san,

As we know BZ had already closed, but here's inputs from our engineering
and the fix will be included in RHEL4.8GA as you tested on RHEL4.8
Snapshot3(xorg-x11-6.8.2-1.EL.63) on 04-13-2009 08:59am JST. So please be
no worried about it.

---
xorg-x11-6.8.2-1.EL.63 should fix this issue. If it does, it will remain
fixed in the GA, without this bugzilla. If it is not fixed, 
---

Thanks in advance.

Regards,
Masaki Furuta

Category set to: Hardware::Video

This event sent from IssueTracker by mfuruta@redhat.com 
 issue 277451

Note You need to log in before you can comment on or make changes to this bug.