Bug 491729 - Installing Rawhide (clearpart --linux) on top of RAID0 formatted system fails
Installing Rawhide (clearpart --linux) on top of RAID0 formatted system fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Joel Andres Granados
Fedora Extras Quality Assurance
anaconda_trace_hash:42c5e49babe5d1546...
:
: 492855 495608 (view as bug list)
Depends On:
Blocks: AnacondaStorage F11AnacondaBlocker
  Show dependency treegraph
 
Reported: 2009-03-23 15:01 EDT by James Laska
Modified: 2013-09-02 02:33 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-06 17:22:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (130.17 KB, text/plain)
2009-03-23 15:01 EDT, James Laska
no flags Details
Attached traceback automatically from anaconda. (127.69 KB, text/plain)
2009-03-23 15:05 EDT, James Laska
no flags Details
Attached traceback automatically from anaconda. (164.34 KB, text/plain)
2009-03-27 12:24 EDT, Jesse Keating
no flags Details
Attached traceback automatically from anaconda. (167.85 KB, text/plain)
2009-04-01 15:16 EDT, Michael Madore
no flags Details
Attached traceback automatically from anaconda. (277.08 KB, text/plain)
2009-04-14 17:46 EDT, cje
no flags Details
The patch that solves the issue. (795 bytes, application/octet-stream)
2009-04-16 06:54 EDT, Joel Andres Granados
no flags Details

  None (edit)
Description James Laska 2009-03-23 15:01:18 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.35 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicelibs/mdraid.py", line 131, in mddestroy
    raise MDRaidError("mddestroy failed for %s" % device)
  File "/usr/lib/anaconda/storage/formats/mdraid.py", line 87, in destroy
    mdraid.mddestroy(self.device)
  File "/usr/lib/anaconda/storage/deviceaction.py", line 326, in execute
    self.origFormat.destroy()
  File "/usr/lib/anaconda/storage/devicetree.py", line 660, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 184, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 115, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
MDRaidError: mddestroy failed for /dev/vda2
Comment 1 James Laska 2009-03-23 15:01:25 EDT
Created attachment 336356 [details]
Attached traceback automatically from anaconda.
Comment 2 James Laska 2009-03-23 15:05:46 EDT
Created attachment 336358 [details]
Attached traceback automatically from anaconda.
Comment 3 James Laska 2009-03-23 15:07:56 EDT
Consistently hitting this bug while testing that rawhide can install on top of
previous installations.  This test matrix focused on installing distros on top
of raid0 storage, then installing rawhide.

First install raid0 (release noted below), then clearpart rawhide
GUEST   TEST                FROM                TO      RESULT
=================================================================
vguest1 clearpart --linux   RHEL-4-U7           rawhide FAIL (bug#491729)
vguest2 clearpart --linux   RHEL-5-Server-U3    rawhide FAIL (bug#491729)
vguest3 clearpart --linux   F-10-GOLD           rawhide FAIL (bug#491729)
vguest4 clearpart --linux   F-9-GOLD            rawhide FAIL (bug#491729)
Comment 4 Jesse Keating 2009-03-27 12:24:23 EDT
Created attachment 337035 [details]
Attached traceback automatically from anaconda.
Comment 5 Michael Madore 2009-04-01 15:16:55 EDT
Created attachment 337625 [details]
Attached traceback automatically from anaconda.
Comment 6 Chris Lumens 2009-04-06 11:14:26 EDT
*** Bug 492855 has been marked as a duplicate of this bug. ***
Comment 7 cje 2009-04-14 17:46:15 EDT
Created attachment 339589 [details]
Attached traceback automatically from anaconda.
Comment 8 cje 2009-04-14 23:52:23 EDT
might be stating the obvious but from bug 469466 a workaround is to dd from /dev/zero to initialise the disks.  then reboot.  not pretty - just in case anyone desperately needs to get past this bug before it's fixed.
Comment 9 Joel Andres Granados 2009-04-16 06:54:37 EDT
Created attachment 339825 [details]
The patch that solves the issue.

This error is caused from previous mdadm command failures where the activation of the devices did not fully complete.  On my tests, when I included the "--run" argument in the create command, this bug went away.
Comment 10 Joel Andres Granados 2009-04-17 07:34:27 EDT
This patch just went in.  It will be present in anaconda version  11.5.0.46.
Comment 11 Joel Andres Granados 2009-04-17 09:50:23 EDT
*** Bug 495608 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.