Bug 49218 - Anaconda exception at grub installation
Anaconda exception at grub installation
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
: 50260 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-16 22:41 EDT by Ray Curtis
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-01 23:47:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Traceback file created (8.77 KB, text/plain)
2001-07-16 22:44 EDT, Ray Curtis
no flags Details
Beta2 install log (48.60 KB, text/plain)
2001-07-18 20:26 EDT, Ray Curtis
no flags Details
Traceback after the full install got almost completed. (9.17 KB, text/plain)
2001-07-28 21:35 EDT, Ray Curtis
no flags Details

  None (edit)
Description Ray Curtis 2001-07-16 22:41:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010716

Description of problem:
For the first install using beta2 everything went perfectly up until
it got to post install where it gave a traceback.

How reproducible:
Always

Steps to Reproduce:
1. Normal install of workstation using Gnome
2.
3.
	

Actual Results:  Traceback given during post install.

Additional info:
Comment 1 Ray Curtis 2001-07-16 22:44:41 EDT
Created attachment 23767 [details]
Traceback file created
Comment 2 Jeremy Katz 2001-07-17 11:49:40 EDT
To try to pin this down some...  IDE or SCSI drives?  Any hardware RAID
controllers?  Software RAID used for / or /boot?
Comment 3 Ray Curtis 2001-07-17 12:07:24 EDT
Look at beta hardware description #19, this was done installing to 
disk /dev/sdb.
This machine has three drives, hda, sda, sdb.
This is a very similiar problem encountered with beta1, look to
bug #46810

Comment 4 Ray Curtis 2001-07-17 12:21:26 EDT
Sorry didn't say but NO RAID at all.
Comment 5 Glen Foster 2001-07-17 14:55:43 EDT
This defect considered MUST-FIX for Fairfax gold-release.
Comment 6 Jeremy Katz 2001-07-18 19:43:08 EDT
It's a bit different from the traceback in beta1 -- did you try to install the
bootloader to the MBR or the boot partition?
Comment 7 Ray Curtis 2001-07-18 20:26:22 EDT
Created attachment 24068 [details]
Beta2 install log
Comment 8 Ray Curtis 2001-07-20 11:54:43 EDT
Finally got it to install, hate to tell you what I did. I thought I had
tried all the modes, since I normally start with the text mode.
Anyway going back once again to the text mode and it allowed me the
choice of whether to use grub or lilo and it installed just fine.
However in the graphic mode this option never comes up, so I assume it
defaulted to grub and installing to the MBR but it gave the traceback
attached.
Comment 9 Jeremy Katz 2001-07-20 15:11:18 EDT
Can you reproduce it in GUI mode still with beta2 and the update disk at
ftp://people.redhat.com/msf/update-disk-07192001.img ?
Comment 10 Ray Curtis 2001-07-20 17:07:04 EDT
Sorry to be dense but how do you use this update img ? 
Comment 11 Jeremy Katz 2001-07-20 17:10:02 EDT
To quote from msf's message to testers-list --

"Just use this like any updates disk for the installer, ie., put a 'updates' at
the end of the command line you give the boot disk (use the beta 2 boot disk, it
is not changed) and you will be prompted to insert the update disk.

To make the update disk, download the file above and

dd if=update-disk-07182001.img of=/dev/fd0 bs=1440k"
Comment 12 Ray Curtis 2001-07-20 17:45:51 EDT
Sorry I had already done that, it just won't boot from the disk. I tried
it on a couple of different machines.
Comment 13 Jeremy Katz 2001-07-20 17:47:18 EDT
You boot with the normal boot disk (/cdrom) and just type linux updates at the
syslinux prompt and insert the update disk when prompted
Comment 14 Ray Curtis 2001-07-20 18:44:55 EDT
Ok this image works just fine in the Graphic mode.
Comment 15 Ray Curtis 2001-07-28 21:35:01 EDT
Created attachment 25290 [details]
Traceback after the full install got almost completed.
Comment 16 Ray Curtis 2001-07-28 21:41:45 EDT
Got this same respsonse doing a full install on beta 3 [Roswell] using this
same hardware, beta hardware description #19.
It goes through the complete install, up to the install of lilo,grub never
asking which one I  want then crashes with the traceback attached.

I then went back and tried to use the old update.img I used to install with
beta2 but this crashed right away, I didn't save that traceback but assumed
since it was the one you gave me for beta2 it wouldn't work.
Comment 17 Ray Curtis 2001-07-29 11:08:00 EDT
Not sure if I did this last one right, but since this started as a 
beta2 bug, I just reopened this bug for beta3 since it appears to
be the same.
Or should it have just been opened as a new bug under beta3 ?
Comment 18 Jeremy Katz 2001-07-31 16:51:26 EDT
*** Bug 50260 has been marked as a duplicate of this bug. ***
Comment 19 Jeremy Katz 2001-07-31 16:59:44 EDT
There should be a screen right after the partitioning screen which offers you
various bootloader options, including at the top of the screen, which bootloader
you wish to use.  And you don't see this screen?
Comment 20 Ray Curtis 2001-07-31 17:24:29 EDT
No, after the Disk setup screen, I see the "boot loader password configuration
screen"which says I have already picked GRUB and only allows me to 
input a grub password.

This is the same thing that happened with beta2 until the updated img
was issued.
Comment 21 Ray Curtis 2001-07-31 17:27:02 EDT
Something I forgot to mention, this is using beta3 and the hardware is
beta hardware description #19 which has 3 drives in the machine.
hda has windows installed.
sda has debian installed.
sdb is being used for beta testing.
Comment 22 Ray Curtis 2001-08-01 23:47:01 EDT
One last thing I noticed I didn't mention, this only seems to occur
in Gui or expert modes, text seems to work fine.
Text mode gives me the choice of lilo or grub during the install process.
Comment 23 Jeremy Katz 2001-08-04 15:50:54 EDT
Tracked to being due to expert mode magic... fixed in CVS

Note You need to log in before you can comment on or make changes to this bug.