This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 492516 - anaconda crash on preupgrade F10->rawhide
anaconda crash on preupgrade F10->rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
i386 Linux
low Severity high
: ---
: ---
Assigned To: Joel Andres Granados
Fedora Extras Quality Assurance
anaconda_trace_hash:edd80e61140010870...
:
: 492705 (view as bug list)
Depends On: 492634
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-27 03:58 EDT by Mihai Harpau
Modified: 2009-06-30 10:55 EDT (History)
23 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-25 13:38:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (56.09 KB, text/plain)
2009-03-27 03:59 EDT, Mihai Harpau
no flags Details
Attached traceback automatically from anaconda. (58.39 KB, text/plain)
2009-03-27 09:01 EDT, Ville-Pekka Vainio
no flags Details
Attached traceback automatically from anaconda. (55.73 KB, text/plain)
2009-03-27 12:09 EDT, Will Woods
no flags Details
Attached traceback automatically from anaconda. (59.87 KB, text/plain)
2009-03-27 16:29 EDT, J. Ali Harlow
no flags Details
Attached traceback automatically from anaconda. (47.23 KB, text/plain)
2009-03-28 05:28 EDT, Timon
no flags Details
Attached traceback automatically from anaconda. (52.29 KB, text/plain)
2009-03-29 06:34 EDT, Lorenzo Villani
no flags Details
Attached traceback automatically from anaconda. (50.08 KB, text/plain)
2009-03-29 11:25 EDT, eric@christensenplace.us
no flags Details
Attached traceback automatically from anaconda. (57.13 KB, text/plain)
2009-03-29 15:29 EDT, Pasi Karkkainen
no flags Details
Attached traceback automatically from anaconda. (57.74 KB, text/plain)
2009-03-31 05:37 EDT, Scott
no flags Details
Attached traceback automatically from anaconda. (48.49 KB, text/plain)
2009-03-31 15:04 EDT, Julien Humbert
no flags Details
Attached traceback automatically from anaconda. (54.72 KB, text/plain)
2009-03-31 21:46 EDT, Naoki
no flags Details
Attached traceback automatically from anaconda. (53.14 KB, text/plain)
2009-04-01 03:30 EDT, ufa
no flags Details
Attached traceback automatically from anaconda. (55.64 KB, text/plain)
2009-04-01 08:17 EDT, Stefan Becker
no flags Details
Attached traceback automatically from anaconda. (57.31 KB, text/plain)
2009-04-01 12:16 EDT, Earth
no flags Details
Attached traceback automatically from anaconda. (58.35 KB, text/plain)
2009-04-02 07:56 EDT, Martin Bürge
no flags Details
Attached traceback automatically from anaconda. (56.30 KB, text/plain)
2009-04-02 16:27 EDT, Callum Lerwick
no flags Details
Attached traceback automatically from anaconda. (56.96 KB, text/plain)
2009-04-04 08:13 EDT, arnav
no flags Details
Attached traceback automatically from anaconda. (55.33 KB, text/plain)
2009-04-05 16:03 EDT, Frank Murphy
no flags Details
Attached traceback automatically from anaconda. (39.93 KB, text/plain)
2009-04-06 18:46 EDT, Tom Gutwin
no flags Details
Attached traceback automatically from anaconda. (56.62 KB, text/plain)
2009-04-06 20:56 EDT, Naoki
no flags Details
Attached traceback automatically from anaconda. (56.91 KB, text/plain)
2009-04-07 21:18 EDT, Naoki
no flags Details

  None (edit)
Description Mihai Harpau 2009-03-27 03:58:51 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.38 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/upgrade.py", line 235, in upgradeMountFilesystems
    anaconda.id.upgradeRoot[0],
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 227, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/gui.py", line 1350, in setScreen
    (step, anaconda) = self.anaconda.dispatch.currentStep()
  File "/usr/lib/anaconda/gui.py", line 1513, in setup_window
    self.setScreen()
  File "/usr/lib/anaconda/gui.py", line 1523, in run
    self.setup_window(runres)
  File "/usr/lib/anaconda/gui.py", line 1270, in run
    self.icw.run (self.runres)
  File "/usr/bin/anaconda", line 1029, in <module>
    anaconda.intf.run(anaconda)
IndexError: list index out of range
Comment 1 Mihai Harpau 2009-03-27 03:59:00 EDT
Created attachment 336972 [details]
Attached traceback automatically from anaconda.
Comment 2 Ville-Pekka Vainio 2009-03-27 09:01:05 EDT
Created attachment 337004 [details]
Attached traceback automatically from anaconda.
Comment 3 Joel Andres Granados 2009-03-27 11:03:38 EDT
This should be better in the next version of anaconda 11.5.0.39
Comment 4 Mihai Harpau 2009-03-27 11:27:46 EDT
And that version of anaconda will be available after F11Beta will appear?
Comment 5 Will Woods 2009-03-27 12:09:57 EDT
Created attachment 337032 [details]
Attached traceback automatically from anaconda.
Comment 6 Will Woods 2009-03-27 15:10:14 EDT
The code mentioned probably won't fix preupgrades, but it will handle the exception better.

Bug 492634 blocks preupgrade to rawhide.
Comment 7 J. Ali Harlow 2009-03-27 16:29:13 EDT
Created attachment 337060 [details]
Attached traceback automatically from anaconda.
Comment 8 Timon 2009-03-28 05:28:32 EDT
Created attachment 337096 [details]
Attached traceback automatically from anaconda.
Comment 9 Lorenzo Villani 2009-03-29 06:34:52 EDT
Created attachment 337159 [details]
Attached traceback automatically from anaconda.
Comment 10 eric@christensenplace.us 2009-03-29 11:25:21 EDT
Created attachment 337174 [details]
Attached traceback automatically from anaconda.
Comment 11 Pasi Karkkainen 2009-03-29 15:29:30 EDT
Created attachment 337180 [details]
Attached traceback automatically from anaconda.
Comment 12 Joel Andres Granados 2009-03-30 06:07:45 EDT
*** Bug 492705 has been marked as a duplicate of this bug. ***
Comment 13 Scott 2009-03-31 05:37:27 EDT
Created attachment 337287 [details]
Attached traceback automatically from anaconda.
Comment 14 Julien Humbert 2009-03-31 15:04:52 EDT
Created attachment 337389 [details]
Attached traceback automatically from anaconda.
Comment 15 Ray Todd Stevens 2009-03-31 16:13:44 EDT
I just retried after cleaning up everything and doing a fresh preugrade after a fresh yum update.   Anaconda version was 11 5 0 38.

Still a problem.   Really can't try anything else until this is fixed.
Comment 16 Naoki 2009-03-31 21:46:41 EDT
Created attachment 337423 [details]
Attached traceback automatically from anaconda.
Comment 17 ufa 2009-04-01 03:30:57 EDT
Created attachment 337455 [details]
Attached traceback automatically from anaconda.
Comment 18 Stefan Becker 2009-04-01 08:17:02 EDT
Created attachment 337500 [details]
Attached traceback automatically from anaconda.
Comment 19 Stefan Becker 2009-04-01 08:19:51 EDT
Cause in my case: /var/cache/yum/preupgrade is located on LVM. But at the time when anaconda wants to access it, it has not opened the LVM volumes yet and therefore it can't find the partitions referenced by the UUID= in the method string.
Comment 20 Earth 2009-04-01 09:16:04 EDT
Observed similarly on x86_64. I too have / (including /var) on lvm
Comment 21 Pasi Karkkainen 2009-04-01 09:25:23 EDT
What's the 'second best' method to upgrade from F10 to rawhide? Boot from rawhide ISO image (or F11 beta) and try to upgrade from there? or yum upgrade?
Comment 22 ufa 2009-04-01 09:33:08 EDT
Happened on my F10 amd64.
Comment 23 Ville-Pekka Vainio 2009-04-01 11:55:01 EDT
(In reply to comment #21)
> What's the 'second best' method to upgrade from F10 to rawhide? Boot from
> rawhide ISO image (or F11 beta) and try to upgrade from there? or yum upgrade?  

I downloaded the Rawhide boot.iso from a nearby mirror and did a netinstall with it.
Comment 24 Earth 2009-04-01 12:16:57 EDT
Created attachment 337574 [details]
Attached traceback automatically from anaconda.
Comment 25 Stefan Becker 2009-04-01 18:30:16 EDT
(In reply to comment #21)
> What's the 'second best' method to upgrade from F10 to rawhide? Boot from
> rawhide ISO image (or F11 beta) and try to upgrade from there? or yum upgrade?  

Transfer the contents of /var/cache/yum/preupgrade to a local web/ftp server and change the repo reference in the upgrade GRUB entry from hd:... to http://<ip address>/path/on/web/server/preupgrade. Not nice, but it works.
Comment 26 Martin Bürge 2009-04-02 07:56:06 EDT
Created attachment 337788 [details]
Attached traceback automatically from anaconda.
Comment 27 Callum Lerwick 2009-04-02 16:27:09 EDT
Created attachment 337910 [details]
Attached traceback automatically from anaconda.
Comment 28 arnav 2009-04-04 08:13:45 EDT
Created attachment 338155 [details]
Attached traceback automatically from anaconda.
Comment 29 Frank Murphy 2009-04-05 16:03:58 EDT
Created attachment 338255 [details]
Attached traceback automatically from anaconda.
Comment 30 Callum Lerwick 2009-04-05 17:59:24 EDT
This seems to have been fixed for me as of 11.5.0.40 but I get a different crash instead, bz #493685
Comment 31 Julien Humbert 2009-04-05 18:49:38 EDT
Upgrade is working for me as of Anaconda 11.5.0.40.
Comment 32 Tom Gutwin 2009-04-06 18:46:00 EDT
Created attachment 338411 [details]
Attached traceback automatically from anaconda.
Comment 33 Naoki 2009-04-06 20:56:24 EDT
Created attachment 338419 [details]
Attached traceback automatically from anaconda.
Comment 34 Naoki 2009-04-07 21:18:30 EDT
Created attachment 338642 [details]
Attached traceback automatically from anaconda.
Comment 35 Joel Andres Granados 2009-04-16 07:42:21 EDT
Just got passed storage with anaconda-11.5.0.44.  This seems to be addressed.
Comment 36 Ray Todd Stevens 2009-04-17 14:44:43 EDT
I have a bug actually before this (496311), so it might have been headed down the tubes before this point, but right now anaconda 11.5.0.44 can't seem to find my md0 volume.
Comment 37 Bug Zapper 2009-06-09 08:43:53 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.