Bug 493078 - Fedora 11 Live Beta doesn't boot in VMWare
Fedora 11 Live Beta doesn't boot in VMWare
Status: CLOSED DUPLICATE of bug 493282
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
rawhide
i686 Linux
high Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-31 10:59 EDT by Anderson Silva
Modified: 2009-04-28 15:55 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-28 15:55:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vmware screenshot with F11 beta live hanging (12.77 KB, image/png)
2009-04-01 19:34 EDT, Anderson Silva
no flags Details

  None (edit)
Description Anderson Silva 2009-03-31 10:59:29 EDT
Description of problem:

NOTE: I am not sure what component is the culprit, I am picking grub since it is the first thing that I see that freaks out.

I've downloaded the new F11 beta live image, and I've tried to boot it to install into two different machines. An Eee PC 1000, and at boot time, the screen goes gray, and if I hit scape the prompt: boot: shows up and there is not much else I can do from there. It doesn't even give me the GRUB screen.

I also tried booting it on a virtual machine (on vmware desktop 6.5), and the install seems to just feezes up after loading initrd0.img...........

Version-Release number of selected component (if applicable):


How reproducible: Every time. 


Steps to Reproduce:
1. On Eee PC: install image on usb thumbdrive: livecd-iso-to-disk /home/ansilva/F11-Beta-i686-Live.iso /dev/sdb1
2. On Eee PC: Change BIOS to boot off USB disk
3. Boots, and see gray screen. It doesn't even give me the Grub screen.
4. On Vmware Desktop 6.5: Create new VM
5. Set 4e9a3d21dbe4fafe5b4aec41098eb03a  F11-Beta-i686-Live.iso as the boot CD
6. Boot VM, and it freezes at loading initrd0.img........... (on Vmware it gives me the grub screen)
  
Actual results:

I can't boot into F11


Expected results:

I should be able to boot into F11

Additional info:
Comment 1 Anderson Silva 2009-03-31 11:01:55 EDT
On an extra note, this happened to me on Fedora Alpha as well... My apologies in advance for not filing the bug sooner.
Comment 2 Mads Villadsen 2009-03-31 17:00:46 EDT
This happens for me as well on a dell latitude d820. Perhaps something to do with kernel mode setting on intel graphics?
Comment 3 Jon Nettleton 2009-04-01 10:55:44 EDT
I have experienced this problem as well. I have tested on intel, sis, and via video chipsets with the same results.  I am trying to use a usb stick to boot off of.  The image used to create it boots fine in a VM.
Comment 4 Jon Nettleton 2009-04-01 11:32:17 EDT
I think we are duplicate of this bug.

https://bugzilla.redhat.com/show_bug.cgi?id=492370

Updating syslinux on my F10 box fixed me up.
Comment 5 Anderson Silva 2009-04-01 13:22:19 EDT
I had the problem from a usb stick, but also from booting from VMware without using livecd-iso-to-disk

I don't think it's a duplicate.
Comment 6 Anderson Silva 2009-04-01 15:09:31 EDT
Just saw someone reporting the same thing I saw with vmware at: https://bugzilla.redhat.com/show_bug.cgi?id=493282
Comment 7 Jon Nettleton 2009-04-01 16:32:08 EDT
I think we are dealing with two different problems.  The grey screen at boot is the syslinux issue.  The VMWare image is probably something different as it gets to trying to mount the initrd.
Comment 8 Anderson Silva 2009-04-01 18:51:14 EDT
ah, ok that's fair, I am going try to upgrade my syslinux on f10 and use livecd-iso-to-disk and try to boot my Eee PC again, I will report later tonight.
Comment 9 Anderson Silva 2009-04-01 19:34:57 EDT
Created attachment 337688 [details]
vmware screenshot with F11 beta live hanging

Jon, you are correct. I did the work around for syslinux stated at: https://bugzilla.redhat.com/show_bug.cgi?id=492370

And I've been able to boot and install Fedora 11 Beta on my Eee PC.

So, the vmware workstation is indeed something else.

I've removed 'quiet' and 'rhgb' from grub on VMWare, here is where it dies (see screenshot attached).
Comment 10 Joshua Covington 2009-04-02 13:33:02 EDT
I have the same problem here with custom livecd. The problem seems to come from syslinux-3.73 because 3.61 works fine for me. In order to boot the livecd when asked on the command line type in linux0. This is the default label from syslinux.conf file, which contains the menu entries. Or you can type in one of the other options. my bug here: https://bugzilla.redhat.com/show_bug.cgi?id=493628
Comment 11 Michel Duquaine 2009-04-06 11:50:57 EDT
I tried to install F11-Beta-i686-Live.iso on an usb via livecd-iso-to-disk but it does not work: white screen and if I press ESC, I only see "boot:".

I used the same iso via VirtualBox and it works.
Comment 12 Christopher Beland 2009-04-24 05:22:50 EDT
Given that non-VMware issues seem to be different and are tracked elsewhere, I'm tweaking the title of this bug to focus on the VMWare aspect.
Comment 13 Jeremy Katz 2009-04-28 15:55:54 EDT
Marking a dupe for the vmware bits (the syslinux bits are also tracked elsewhere)

*** This bug has been marked as a duplicate of bug 493282 ***

Note You need to log in before you can comment on or make changes to this bug.