This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 492370 - livecd-iso-to-disk.sh requires syslinux 3.73 for burning rawhide images
livecd-iso-to-disk.sh requires syslinux 3.73 for burning rawhide images
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
: Reopened
: 493417 493628 496066 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-26 12:30 EDT by Tomeu Vizoso
Modified: 2009-06-24 15:04 EDT (History)
13 users (show)

See Also:
Fixed In Version: 020.1-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-02 12:34:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tomeu Vizoso 2009-03-26 12:30:21 EDT
So it cannot be run on F10, Ubuntu 8.10, etc in order to create bootable media containing F11.

As an easy workaround, if syslinux < 3.73, then in syslinux.cfg change 'default vesamenu.c32' to 'default linux0'.

We'll loose graphical bootloader, but at least it will boot.
Comment 1 Jens Petersen 2009-03-30 08:29:23 EDT
Or at least add "Requires: syslinux >= 3.73"?
Comment 2 Jeremy Katz 2009-03-30 11:43:08 EDT
I'd rather not have the script have to do this sort of munging.  hpa -- is it expected that com32 modules might not work between different versions of syslinux?  If so, I suspect the "best" thing to do will be to copy the versions of the modules in from the version of syslinux being used to create the liveusb stick
Comment 3 Jeremy Katz 2009-04-02 14:24:09 EDT
*** Bug 493417 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2009-04-02 14:25:19 EDT
*** Bug 493628 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2009-04-02 16:59:51 EDT
git livecd-iso-to-disk will now copy over the com32 modules from its version of syslinux and you can grab the script from
    http://katzj.fedorapeople.org/livecd-iso-to-disk.sh

This feels kind of kludgey, but I can't think of a better way to handle the fact that the com32 modules might be from a newer syslinux
Comment 6 Adam Williamson 2009-04-08 12:38:01 EDT
I don't really think this should be CLOSED yet. The fundamental problem - you can't build live USB images for F11-era live CDs using a normal F10 installation - is still there, AFAICT. We need to ship some kind of update to F10 to close the issue properly...

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Jeremy Katz 2009-04-16 11:59:45 EDT
*** Bug 496066 has been marked as a duplicate of this bug. ***
Comment 8 Joshua Rosen 2009-04-17 08:40:46 EDT
Closing this bug without fixing it is insane. If you can't build an F11 Live USB on F10 how do you expect anyone to test F11 Betas or to install F11 when the final version is released?
Comment 9 Adam Williamson 2009-04-17 13:07:36 EDT
Joshua: there is a fairly simple workaround documented right in the F11 beta release notes - update syslinux from Rawhide before building the image - but I agree it should be fixed (viz. previous comment).

What we actually need is for people to test the script Jeremy linked to in his last comment - http://katzj.fedorapeople.org/livecd-iso-to-disk.sh - with a standard Fedora 10 and confirm that it works. If it does, he will ship that as an update.

Going ahead and modifying status on this...

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Joshua Rosen 2009-04-19 07:41:36 EDT
The new script works fine, I built the F11 Live USB on an F9 system and it booted correctly. 

As an unrelated aside, please add gparted and Xemacs to the default Live system. You do have something call palimpest on there which looks really scary, gparted is a reliable utility that has a straight forward user interface that allows you to create, resize and reformat partitions which is an essential function for any system recovery disk. Xemacs is necessary so that you can edit config files, also a required function for a system recovery disk. Finally I think it would be a good idea to reroll the LiveCD iso once a quarter. The initial release of any Fedora is always riddled with bugs, three months after the initial release it tends to be pretty solid, at the end of it's live it's usually very stable. A rerolled Live iso would incorporate those bug fixes, it would also include the latest kernel which is important for handling new hardware that's released in the interim.
Comment 11 Adam Williamson 2009-04-19 12:05:50 EDT
"As an unrelated aside"

Bugzilla is not the place for unrelated asides.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Jeremy Katz 2009-04-21 14:14:02 EDT
Backported the patch to an f10 branch and have a package building which will be submitted for updates-testing and then updates after making sure nothing else broke in the process
Comment 13 Fedora Update System 2009-04-21 16:15:47 EDT
livecd-tools-020.1-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/livecd-tools-020.1-1.fc10
Comment 14 Fedora Update System 2009-04-21 21:09:51 EDT
livecd-tools-020.1-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update livecd-tools'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3858
Comment 15 Christopher Beland 2009-04-24 05:39:44 EDT
Would it be possible to get this problem fixed on Fedora 9 as well?  (That's where I just encountered it.)  That would make it easier to get Fedora 9 users to test bugs using Fedora 11 LiveUSBs.  Thanks!
Comment 16 Joshua Rosen 2009-04-24 08:36:07 EDT
I agree you should release the fix for F9 also, I ran your script on F9 and it worked fine so you should be able to use the same fix.
Comment 17 Michel Duquaine 2009-04-26 07:36:04 EDT
I installed the livecd-tools-020.1-1.fc10 on Fedora 10 and created a liveusb based on Fedora-11-Snap1-i686-Live.iso: works fine!

Feedback provides in bodhi (http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3858).

[michel@apollo ~]$ yum list installed | grep livecd
livecd-tools.i386                       020.1-1.fc10                   installed
Comment 18 Adam Williamson 2009-04-29 12:37:49 EDT
*** Bug 494000 has been marked as a duplicate of this bug. ***
Comment 19 Fedora Update System 2009-05-02 12:34:21 EDT
livecd-tools-020.1-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2009-06-24 15:04:32 EDT
liveusb-creator-3.7-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/liveusb-creator-3.7-1.fc11

Note You need to log in before you can comment on or make changes to this bug.