Bug 493732 - Traceback from ppc bootloader install
Traceback from ppc bootloader install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ppc Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:667c39a61848f036e...
:
: 493731 494018 (view as bug list)
Depends On:
Blocks: F11AnacondaBlocker
  Show dependency treegraph
 
Reported: 2009-04-02 17:09 EDT by Jesse Keating
Modified: 2013-01-09 22:29 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-06 17:49:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (134.87 KB, text/plain)
2009-04-02 17:09 EDT, Jesse Keating
no flags Details
Attached traceback automatically from anaconda. (181.60 KB, text/plain)
2009-04-05 10:23 EDT, Peter McNabb
no flags Details
Attached traceback automatically from anaconda. (175.36 KB, text/plain)
2009-04-05 13:33 EDT, Peter McNabb
no flags Details
anacdump.txt (143.58 KB, application/octet-stream)
2009-04-09 14:42 EDT, Geoff Levand
no flags Details

  None (edit)
Description Jesse Keating 2009-04-02 17:09:21 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.39 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/booty/util.py", line 4, in getDiskPart
    path = storage.devicetree.getDeviceByName(dev).path[5:]
  File "/usr/lib/anaconda/booty/ppc.py", line 68, in writeYaboot
    (name, partNum) = getDiskPart(bootDev, self.storage)
  File "/usr/lib/anaconda/booty/ppc.py", line 172, in write
    chainList, defaultDev, justConfig)
  File "/usr/lib/anaconda/bootloader.py", line 191, in writeBootloader
    justConfigFile)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1323, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1344, in handleRenderCallback
    self.currentWindow.renderCallback()
AttributeError: 'NoneType' object has no attribute 'path'
Comment 1 Jesse Keating 2009-04-02 17:09:28 EDT
Created attachment 337925 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-04-02 17:15:03 EDT
*** Bug 493731 has been marked as a duplicate of this bug. ***
Comment 3 Chris Lumens 2009-04-03 09:49:13 EDT
This should be fixed in the next build of anaconda.
Comment 4 Chris Lumens 2009-04-03 14:03:54 EDT
*** Bug 494018 has been marked as a duplicate of this bug. ***
Comment 5 Peter McNabb 2009-04-05 10:23:42 EDT
Created attachment 338232 [details]
Attached traceback automatically from anaconda.
Comment 6 Peter McNabb 2009-04-05 13:33:25 EDT
Created attachment 338248 [details]
Attached traceback automatically from anaconda.
Comment 7 Geoff Levand 2009-04-09 14:42:00 EDT
Created attachment 338975 [details]
anacdump.txt

anaconda 11.5.0.41 still broken.
Comment 8 Jesse Keating 2009-05-06 17:49:08 EDT
I tested this yesterday and rawhide installs just fine on PPC now.  Bootloader installs without a hitch.

Note You need to log in before you can comment on or make changes to this bug.