Bug 493792 - [ml_IN][Anaconda] Failed to load ml_IN Font at the time of Installation
[ml_IN][Anaconda] Failed to load ml_IN Font at the time of Installation
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: i18n, Reopened
Depends On:
Blocks: 493794
  Show dependency treegraph
 
Reported: 2009-04-03 02:02 EDT by Pravin Satpute
Modified: 2009-04-06 10:29 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 493794 (view as bug list)
Environment:
Last Closed: 2009-04-06 10:29:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for fixing package name change problem, also adding lklug package in package list (1.82 KB, patch)
2009-04-03 04:36 EDT, Pravin Satpute
no flags Details | Diff

  None (edit)
Description Pravin Satpute 2009-04-03 02:02:55 EDT
Description of problem:
while selecting Malayalam and Sinhala language for installation, unable to see messages, might be due to not loading of required fonts.

Version-Release number of selected component (if applicable):
anaconda-11.5.0.38-1

How reproducible:
everytime

Steps to Reproduce:
1.start boot
2.select lang Malayalam/Sinhala
3.
  
Actual results:
Not showing Malayala and sinhala language messages

Expected results:
It should show Malayalam and Sinhala messages like other language 

Additional info:
same problem in F11 Beta

smc-meera font name got changed recently from smc-fonts-meera to smc-meera-fonts,
might be problem happening because of that
i saw changelog in anacode, looks this is updated
Comment 1 Pravin Satpute 2009-04-03 04:34:57 EDT
while looking carefully into anaconda source code i found

as per new font naming guideline's most of the fonts name got changes,
still anaconda trying to install smc-fonts-meera though name of package is changed to smc-meera-fonts

unfortunately smc-meera-fonts doesn't have provide field like other lohit fonts that why problem is happening 

anyway i am fixing this in smc-meera-fonts also

that is the problem for malayalam

about sinhala, i found there is not package name lklug-fonts in anaconda's package list

thats why problem with sinhala

attaching patch for resolving this
Comment 2 Pravin Satpute 2009-04-03 04:36:34 EDT
Created attachment 338001 [details]
patch for fixing package name change problem, also adding lklug package in package list
Comment 3 Pravin Satpute 2009-04-03 04:47:38 EDT
mistakenly changed state to modified
reverting back
Comment 4 Pravin Satpute 2009-04-03 05:36:40 EDT
fixed smc-meera-fonts issue - bug 493814
Comment 5 Nicolas Mailhot 2009-04-03 07:19:02 EDT
The answer to bug #493814 is to check the Fedora 11 comps file has the correct "default" declarations in the @fonts group, and remind Anaconda people they're supposed to use this list for default installs.

Changes in default font packages happen every Fedora release, it's useless to try to hide them from anaconda.
Comment 6 Nicolas Mailhot 2009-04-03 07:20:51 EDT
(also, if you have a different behaviour for the smc renaming than for other fonts you'll just confuse anaconda people)
Comment 7 Chris Lumens 2009-04-03 10:04:30 EDT
Oh good, it had been at most a couple weeks since the last inexplicable font package change.  I was beginning to worry something had happened to you guys.

This should be fixed in the next build of anaconda.  Thanks for the patch.
Comment 8 Parag Nemade 2009-04-06 00:58:13 EDT
Looks like you were quick this time fixing bug. Actually I was requesting to add few more Indic fonts. See bug 494261.

When will new build appear on koji? I see only

koji latest-pkg dist-f11 anaconda
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
anaconda-11.5.0.40-1                      dist-f11              dcantrel
Comment 9 Chris Lumens 2009-04-06 10:29:31 EDT
It will be fixed in .41, which will be the next build of anaconda.

Note You need to log in before you can comment on or make changes to this bug.