This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 494122 - 3.12.2.99.3-5 is mega-broken (rpm and firefox die)
3.12.2.99.3-5 is mega-broken (rpm and firefox die)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nss (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kai Engert (:kaie)
Fedora Extras Quality Assurance
:
: 494291 (view as bug list)
Depends On: 494266
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-04 14:39 EDT by Sean Middleditch
Modified: 2009-06-18 02:31 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-18 02:31:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sean Middleditch 2009-04-04 14:39:21 EDT
Installing nss-3.12.2.99.3-5.fc11.x86_64 kills Firefox (no pages load, just blank tabs) and kills RPM (it cannot install any package due to a cpio MD5 failure error).

I had to boot into the Beta CD's rescue mode and install the Beta's nss package (nss-3.12.2.0-4.fc11.x86_64) using the rpm in the rescue mode.  Downgrading that one package fixed both Firefox and rpm, so I'm quite confident it's an nss issue.  I did try downgrading rpm and rpm-libs first, but that did not resolve the issue, and upgrading to the latest rawhide rpm/rpm-libs after downgrading nss still results in a working rpm.

Upside: it's been a while since I had to manually repair a borked system with non-functional broken rpm, so that was fun.  :p
Comment 1 Panu Matilainen 2009-04-06 01:56:30 EDT
Ok, the issue has to do with nss-softokn-freebl getting split to a separate sub-package. I see nss-3.12.2.99.3-5.fc11 has:

Requires:         nss-softokn-freebl >= %{version}

This doesn't guarantee that the correct package gets installed on multilib systems, as nss-softokn-freebl.i586 will match the dependency just as well as nss-softokn-freebl.x86_64. On a simple chroot install test, the right package gets pulled in on install, but I'd guess if you have both 32bit and 64bit versions of nss installed, yum doesn't have much chance of getting it right.

I'd suggest turning the dependency to:

Requires:         nss-softokn-freebl%{_isa} >= %{version}

That'll make sure correct version of nss-softokn-freebl gets pulled in on multilib systems too. Alternatively "Requires: /%{_lib}/libfreebl3.so" will do more or less the same.
Comment 2 Panu Matilainen 2009-04-06 05:27:28 EDT
*** Bug 494291 has been marked as a duplicate of this bug. ***
Comment 3 Kai Engert (:kaie) 2009-04-06 06:35:34 EDT
Panu, thanks a lot, I've started an updated NSS build with your proposed fix.
Comment 4 Kai Engert (:kaie) 2009-04-06 08:15:15 EDT
The build succeeded on i386 and x86_64, but ppc build failed with a test suite failure.

According to koji root.log it pulled in identical architecture packages for both nss and the new nss-softokn-freebl.

When running the test suite we operate within the build area, not based on installed packages, so I hope it was a random failure and have resubmitted the build for a second build attempt.
Comment 5 Panu Matilainen 2009-04-06 08:45:20 EDT
Ppc test suite failing, hum... seeing that NSS depends on sqlite, I hope it's not linked to bug 494266 in turn :-/
Comment 6 Kai Engert (:kaie) 2009-04-06 09:38:50 EDT
The dependency on sqlite could well be the cause for this failure, thanks for the pointer.

Shall I temporarily disable the NSS self-test test suite run at build time, in order to get an NSS package with fixed dependencies built?
Comment 7 Panu Matilainen 2009-04-06 10:37:21 EDT
As this breaks the ability to update anything at all in the worst case, better to limit the damage to ppc I think. So yeah, please temporarily disable the self-test (at least on ppc).

Btw looking at the dates of nss and sqlite updates, nss-3.12.2.99.3-5.fc11 was built just before the new sqlite hit rawhide so it's very likely the NSS test-suite breakage is due the broken new sqlite (ugh)
Comment 8 Kai Engert (:kaie) 2009-04-06 11:01:16 EDT
ok, done. this build succeeded:
https://koji.fedoraproject.org/koji/taskinfo?taskID=1279703

Is this bug fixed?
Comment 9 Karol Trzcionka 2009-04-06 16:05:25 EDT
yes, it fixes this bug
To update it ("rpm --nomd5" doesn't work):
cd /
rpm2cpio PATH_TO_RPM/nss-3.12.2.99.3-7.fc11.`uname -m`.rpm | cpio -i
rpm2cpio PATH_TO_RPM/nss-softokn-freebl-3.12.2.99.3-7.fc11.`uname -m`.rpm | cpio -i
rpm2cpio PATH_TO_RPM/nss-tools-3.12.2.99.3-7.fc11.`uname -m`.rpm | cpio -i
Comment 10 Sean Middleditch 2009-04-08 17:40:14 EDT
Verified this fixes it for me.

I have to ask, though -- if nss requires nss-softokn-freebl to get a usable system, why break it off into a separate package?  That seems like extra maintenance overhead and package database overhead for no gain...
Comment 11 Kai Engert (:kaie) 2009-04-09 14:04:29 EDT
Because the glibc package wants to have the smallest possible dependencies, and glibc will require on freebl, but not depend on the rest of nss.
Comment 12 Kai Engert (:kaie) 2009-04-09 21:05:09 EDT
Adding dependency to bug 494266
Once that gets fixed, we must reenable the test suite, do another build,
then we can mark this one fixed.
Comment 13 Bug Zapper 2009-06-09 09:16:58 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Kai Engert (:kaie) 2009-06-18 02:31:05 EDT
I had re-enabled the test suite a while ago.
Closing bug.

Note You need to log in before you can comment on or make changes to this bug.