This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 494266 - sqlite-3.6.12 broken on ppc
sqlite-3.6.12 broken on ppc
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sqlite (Show other bugs)
rawhide
powerpc Linux
low Severity urgent
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
: 494396 494856 (view as bug list)
Depends On:
Blocks: F11Blocker/F11FinalBlocker 494122
  Show dependency treegraph
 
Reported: 2009-04-06 02:17 EDT by Jeremy Huddleston
Modified: 2013-01-10 00:08 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 03:56:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeremy Huddleston 2009-04-06 02:17:34 EDT
Description of problem:

Install current ppc rawhide.

Run 'yum search b43' when you boot (you need to switch to a text console because gnome terminal fails to start as well)

Starting program: /usr/bin/python yum search b43
[Thread debugging using libthread_db enabled]
/usr/bin/python: can't open file 'yum': [Errno 2] No such file or directory

Program exited with code 02.
(gdb) runQuit
(gdb) quit
[root@localhost ~]# gdb --args /usr/bin/python /usr/bin/yum search b43
GNU gdb (GDB) Fedora (6.8.50.20090302-12.fc11)
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "ppc-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Missing separate debuginfos, use: debuginfo-install python-2.6-7.fc11.ppc
(gdb) run
Starting program: /usr/bin/python /usr/bin/yum search b43
[Thread debugging using libthread_db enabled]
Loaded plugins: refresh-packagekit
rawhide/metalink                                                                                                                         | 6.5 kB     00:00     

Program received signal SIGSEGV, Segmentation fault.
0x0e8c6e70 in ?? () from /usr/lib/libsqlite3.so.0
(gdb) bt
#0  0x0e8c6e70 in ?? () from /usr/lib/libsqlite3.so.0
#1  0x0e8c78a8 in ?? () from /usr/lib/libsqlite3.so.0
#2  0x0e8e7284 in ?? () from /usr/lib/libsqlite3.so.0
#3  0x0e90bb88 in ?? () from /usr/lib/libsqlite3.so.0
#4  0x0e9390dc in ?? () from /usr/lib/libsqlite3.so.0
#5  0x0e926864 in sqlite3_step () from /usr/lib/libsqlite3.so.0
#6  0x0e98b878 in pysqlite_step () from /usr/lib/python2.6/lib-dynload/_sqlite3.so
#7  0x0e98891c in _pysqlite_query_execute () from /usr/lib/python2.6/lib-dynload/_sqlite3.so
#8  0x0e98913c in pysqlite_cursor_execute () from /usr/lib/python2.6/lib-dynload/_sqlite3.so
#9  0x0fe8c43c in PyCFunction_Call () from /usr/lib/libpython2.6.so.1.0
#10 0x0fefc57c in PyEval_EvalFrameEx () from /usr/lib/libpython2.6.so.1.0
#11 0x0fefd870 in PyEval_EvalCodeEx () from /usr/lib/libpython2.6.so.1.0
#12 0x0fefc108 in PyEval_EvalFrameEx () from /usr/lib/libpython2.6.so.1.0
#13 0x0fefd870 in PyEval_EvalCodeEx () from /usr/lib/libpython2.6.so.1.0
#14 0x0fe73154 in ?? () from /usr/lib/libpython2.6.so.1.0
#15 0x0fe3bb24 in PyObject_Call () from /usr/lib/libpython2.6.so.1.0
#16 0x0fefac28 in PyEval_EvalFrameEx () from /usr/lib/libpython2.6.so.1.0
#17 0x0fefd870 in PyEval_EvalCodeEx () from /usr/lib/libpython2.6.so.1.0
#18 0x0fefc108 in PyEval_EvalFrameEx () from /usr/lib/libpython2.6.so.1.0
#19 0x0fe64e30 in ?? () from /usr/lib/libpython2.6.so.1.0
#20 0x0fef7f04 in PyEval_EvalFrameEx () from /usr/lib/libpython2.6.so.1.0
#21 0x0fefc5cc in PyEval_EvalFrameEx () from /usr/lib/libpython2.6.so.1.0
#22 0x0fefc5cc in PyEval_EvalFrameEx () from /usr/lib/libpython2.6.so.1.0
#23 0x0fefc5cc in PyEval_EvalFrameEx () from /usr/lib/libpython2.6.so.1.0
#24 0x0fefd870 in PyEval_EvalCodeEx () from /usr/lib/libpython2.6.so.1.0
#25 0x0fefc108 in PyEval_EvalFrameEx () from /usr/lib/libpython2.6.so.1.0
#26 0x0fefd870 in PyEval_EvalCodeEx () from /usr/lib/libpython2.6.so.1.0
#27 0x0fefc108 in PyEval_EvalFrameEx () from /usr/lib/libpython2.6.so.1.0
#28 0x0fefd870 in PyEval_EvalCodeEx () from /usr/lib/libpython2.6.so.1.0
#29 0x0fefd974 in PyEval_EvalCode () from /usr/lib/libpython2.6.so.1.0
#30 0x0ff1e25c in ?? () from /usr/lib/libpython2.6.so.1.0
#31 0x0ff1e3a4 in PyRun_FileExFlags () from /usr/lib/libpython2.6.so.1.0
#32 0x0ff1fb70 in PyRun_SimpleFileExFlags () from /usr/lib/libpython2.6.so.1.0
#33 0x0ff20544 in PyRun_AnyFileExFlags () from /usr/lib/libpython2.6.so.1.0
#34 0x0ff2ea1c in Py_Main () from /usr/lib/libpython2.6.so.1.0
#35 0x10000654 in main ()
Comment 1 Jeremy Huddleston 2009-04-06 02:50:07 EDT
Ditto for firefox (just trying to show how critical this issue is):

[jeremy@localhost ~]$ firefox -g
MOZILLA_FIVE_HOME=/usr/lib/firefox-3.1b3
  LD_LIBRARY_PATH=/usr/lib/firefox-3.1b3:/usr/lib/firefox-3.1b3/plugins:/usr/lib/firefox-3.1b3
DISPLAY=localhost:10.0
FONTCONFIG_PATH=/etc/fonts:/usr/lib/firefox-3.1b3/res/Xft
DYLD_LIBRARY_PATH=/usr/lib/firefox-3.1b3:/usr/lib/firefox-3.1b3
     LIBRARY_PATH=/usr/lib/firefox-3.1b3:/usr/lib/firefox-3.1b3/components:/usr/lib/firefox-3.1b3
       SHLIB_PATH=/usr/lib/firefox-3.1b3:/usr/lib/firefox-3.1b3
          LIBPATH=/usr/lib/firefox-3.1b3:/usr/lib/firefox-3.1b3
       ADDON_PATH=/usr/lib/firefox-3.1b3
      MOZ_PROGRAM=/usr/lib/firefox-3.1b3/firefox
      MOZ_TOOLKIT=
        moz_debug=1
     moz_debugger=
which: no ddd in (/usr/lib/qt-3.3/bin:/usr/kerberos/bin:/usr/lib/ccache:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/jeremy/bin)
/usr/bin/gdb /usr/lib/firefox-3.1b3/firefox -x /tmp/mozargs.TRbQyc
GNU gdb (GDB) Fedora (6.8.50.20090302-12.fc11)
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "ppc-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Missing separate debuginfos, use: debuginfo-install firefox-3.1-0.11.beta3.fc11.ppc
(gdb) run
Starting program: /usr/lib/firefox-3.1b3/firefox 
[Thread debugging using libthread_db enabled]
Xlib:  extension "Generic Event Extension" missing on display "localhost:10.0".
Xlib:  extension "RANDR" missing on display "localhost:10.0".
Xlib:  extension "Generic Event Extension" missing on display "localhost:10.0".
Xlib:  extension "Generic Event Extension" missing on display "localhost:10.0".
Xlib:  extension "Generic Event Extension" missing on display "localhost:10.0".
Xlib:  extension "Generic Event Extension" missing on display "localhost:10.0".
[New Thread 0x491ff480 (LWP 3213)]
[New Thread 0x49bff480 (LWP 3214)]
[New Thread 0x4a7ff480 (LWP 3215)]

Program received signal SIGSEGV, Segmentation fault.
0x0e17ae70 in ?? () from /usr/lib/libsqlite3.so.0
(gdb) bt
#0  0x0e17ae70 in ?? () from /usr/lib/libsqlite3.so.0
#1  0x0e17b8a8 in ?? () from /usr/lib/libsqlite3.so.0
#2  0x0e19b284 in ?? () from /usr/lib/libsqlite3.so.0
#3  0x0e1bfb88 in ?? () from /usr/lib/libsqlite3.so.0
#4  0x0e1ed0dc in ?? () from /usr/lib/libsqlite3.so.0
#5  0x0e1da864 in sqlite3_step () from /usr/lib/libsqlite3.so.0
#6  0x0e1def90 in sqlite3_exec () from /usr/lib/libsqlite3.so.0
#7  0x0ef4e088 in ?? () from /usr/lib/xulrunner-1.9.1/libxul.so
#8  0x0ef92464 in ?? () from /usr/lib/xulrunner-1.9.1/libxul.so
#9  0x0ef770c0 in ?? () from /usr/lib/xulrunner-1.9.1/libxul.so
#10 0x0ef77a74 in ?? () from /usr/lib/xulrunner-1.9.1/libxul.so
#11 0x0ef78d98 in ?? () from /usr/lib/xulrunner-1.9.1/libxul.so
#12 0x0ef9d25c in ?? () from /usr/lib/xulrunner-1.9.1/libxul.so
#13 0x0f0cdb5c in ?? () from /usr/lib/xulrunner-1.9.1/libxul.so
#14 0x0f10e96c in ?? () from /usr/lib/xulrunner-1.9.1/libxul.so
#15 0x0f1101d8 in ?? () from /usr/lib/xulrunner-1.9.1/libxul.so
#16 0x0f0c5e68 in ?? () from /usr/lib/xulrunner-1.9.1/libxul.so
#17 0x0f0c4ba0 in ?? () from /usr/lib/xulrunner-1.9.1/libxul.so
#18 0x0ef9b928 in ?? () from /usr/lib/xulrunner-1.9.1/libxul.so
#19 0x0ef97e98 in ?? () from /usr/lib/xulrunner-1.9.1/libxul.so
#20 0x0ef9d0a4 in ?? () from /usr/lib/xulrunner-1.9.1/libxul.so
#21 0x0f0cdb5c in ?? () from /usr/lib/xulrunner-1.9.1/libxul.so
#22 0x0f10ea94 in ?? () from /usr/lib/xulrunner-1.9.1/libxul.so
#23 0x0f1105ac in ?? () from /usr/lib/xulrunner-1.9.1/libxul.so
#24 0x0e512cfc in ?? () from /usr/lib/xulrunner-1.9.1/libxul.so
#25 0x0f12ade4 in NS_InvokeByIndex_P () from /usr/lib/xulrunner-1.9.1/libxul.so
#26 0x0e527858 in ?? () from /usr/lib/xulrunner-1.9.1/libxul.so
#27 0x0e531c50 in ?? () from /usr/lib/xulrunner-1.9.1/libxul.so
#28 0x0f963120 in js_Invoke () from /usr/lib/xulrunner-1.9.1/libmozjs.so
#29 0x0f956384 in ?? () from /usr/lib/xulrunner-1.9.1/libmozjs.so
#30 0x0f963170 in js_Invoke () from /usr/lib/xulrunner-1.9.1/libmozjs.so
#31 0x0e522d98 in ?? () from /usr/lib/xulrunner-1.9.1/libxul.so
#32 0x0e51d8d8 in ?? () from /usr/lib/xulrunner-1.9.1/libxul.so
#33 0x0f12acc0 in ?? () from /usr/lib/xulrunner-1.9.1/libxul.so
#34 0x0f12ae5c in SharedStub () from /usr/lib/xulrunner-1.9.1/libxul.so
Comment 2 Jeremy Huddleston 2009-04-06 02:58:39 EDT
Here are some slightly more useful debug symbols:

[jeremy@localhost ~]$ gdb --args /usr/bin/python /usr/bin/yum search b43
GNU gdb (GDB) Fedora (6.8.50.20090302-12.fc11)
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "ppc-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Missing separate debuginfos, use: debuginfo-install python-2.6-7.fc11.ppc
(gdb) run
Starting program: /usr/bin/python /usr/bin/yum search b43
[Thread debugging using libthread_db enabled]
Loaded plugins: refresh-packagekit

Program received signal SIGSEGV, Segmentation fault.
sqlite3MemSize (pPrior=0x4b0) at sqlite3.c:12057
12057	  return (int)p[0];
(gdb) bt
#0  sqlite3MemSize (pPrior=0x4b0) at sqlite3.c:12057
#1  0x0e8c78a8 in sqlite3DbMallocSize (db=<value optimized out>, p=<value optimized out>) at sqlite3.c:15366
#2  0x0e8e7284 in sqlite3VdbeMemGrow (pMem=0x10501570, n=408, preserve=<value optimized out>) at sqlite3.c:44314
#3  0x0e90bb88 in allocateCursor (p=0x105014b0, iCur=<value optimized out>, nField=10, iDb=0, isBtreeCursor=<value optimized out>) at sqlite3.c:49461
#4  0x0e9390dc in sqlite3VdbeExec (p=0x105014b0) at sqlite3.c:52212
#5  0x0e926864 in sqlite3Step (p=<value optimized out>) at sqlite3.c:48397
#6  sqlite3_step (p=<value optimized out>) at sqlite3.c:48469
#7  0x0e98b878 in pysqlite_step () from /usr/lib/python2.6/lib-dynload/_sqlite3.so
#8  0x0e98891c in _pysqlite_query_execute () from /usr/lib/python2.6/lib-dynload/_sqlite3.so
#9  0x0e98913c in pysqlite_cursor_execute () from /usr/lib/python2.6/lib-dynload/_sqlite3.so
#10 0x0fe8c43c in PyCFunction_Call () from /usr/lib/libpython2.6.so.1.0
#11 0x0fefc57c in PyEval_EvalFrameEx () from /usr/lib/libpython2.6.so.1.0
#12 0x0fefd870 in PyEval_EvalCodeEx () from /usr/lib/libpython2.6.so.1.0
#13 0x0fefc108 in PyEval_EvalFrameEx () from /usr/lib/libpython2.6.so.1.0
#14 0x0fefd870 in PyEval_EvalCodeEx () from /usr/lib/libpython2.6.so.1.0
#15 0x0fe73154 in ?? () from /usr/lib/libpython2.6.so.1.0
#16 0x0fe3bb24 in PyObject_Call () from /usr/lib/libpython2.6.so.1.0
#17 0x0fefac28 in PyEval_EvalFrameEx () from /usr/lib/libpython2.6.so.1.0
#18 0x0fefd870 in PyEval_EvalCodeEx () from /usr/lib/libpython2.6.so.1.0
#19 0x0fefc108 in PyEval_EvalFrameEx () from /usr/lib/libpython2.6.so.1.0
#20 0x0fe64e30 in ?? () from /usr/lib/libpython2.6.so.1.0
#21 0x0fef7f04 in PyEval_EvalFrameEx () from /usr/lib/libpython2.6.so.1.0
#22 0x0fefc5cc in PyEval_EvalFrameEx () from /usr/lib/libpython2.6.so.1.0
#23 0x0fefc5cc in PyEval_EvalFrameEx () from /usr/lib/libpython2.6.so.1.0
#24 0x0fefc5cc in PyEval_EvalFrameEx () from /usr/lib/libpython2.6.so.1.0
#25 0x0fefd870 in PyEval_EvalCodeEx () from /usr/lib/libpython2.6.so.1.0
#26 0x0fefc108 in PyEval_EvalFrameEx () from /usr/lib/libpython2.6.so.1.0
#27 0x0fefd870 in PyEval_EvalCodeEx () from /usr/lib/libpython2.6.so.1.0
#28 0x0fefc108 in PyEval_EvalFrameEx () from /usr/lib/libpython2.6.so.1.0
#29 0x0fefd870 in PyEval_EvalCodeEx () from /usr/lib/libpython2.6.so.1.0
#30 0x0fefd974 in PyEval_EvalCode () from /usr/lib/libpython2.6.so.1.0
#31 0x0ff1e25c in ?? () from /usr/lib/libpython2.6.so.1.0
#32 0x0ff1e3a4 in PyRun_FileExFlags () from /usr/lib/libpython2.6.so.1.0
#33 0x0ff1fb70 in PyRun_SimpleFileExFlags () from /usr/lib/libpython2.6.so.1.0
#34 0x0ff20544 in PyRun_AnyFileExFlags () from /usr/lib/libpython2.6.so.1.0
#35 0x0ff2ea1c in Py_Main () from /usr/lib/libpython2.6.so.1.0
#36 0x10000654 in main ()
Comment 3 Jeremy Huddleston 2009-04-06 03:00:57 EDT
Reverting to these fixed the issue:
sqlite-3.6.10-4.fc11.ppc.rpm
sqlite-debuginfo-3.6.10-4.fc11.ppc.rpm
sqlite-devel-3.6.10-4.fc11.ppc.rpm
Comment 4 Panu Matilainen 2009-04-06 08:42:55 EDT
Switching component to sqlite so I can actually see this.

Seems to be limited to ppc but funky segfaults from test-suite too, ugh.
Comment 5 Panu Matilainen 2009-04-06 14:23:04 EDT
*** Bug 494396 has been marked as a duplicate of this bug. ***
Comment 6 Panu Matilainen 2009-04-07 04:54:25 EDT
Please test the updated sqlite package from here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1281864

This is just an emergency band-aid (building with -fno-strict-aliasing appears to avoid the worst brokenness in 3.6.12) and not a real fix but should give a reasonably functional sqlite until the real issue is found.
Comment 7 Josh Boyer 2009-04-07 09:57:24 EDT
[jwboyer@localhost ~]$ sudo rpm -Uvh sqlite-3.6.12-2.fc11.ppc.rpm 
Freeing read locks for locker 0x29d: 13894/4160655360
Freeing read locks for locker 0x29f: 13894/4160655360
Preparing...                ########################################### [100%]
   1:sqlite                 ########################################### [100%]
[jwboyer@localhost ~]$ sudo yum clean metadata
3 metadata files removed
1 sqlite files removed
0 metadata files removed
[jwboyer@localhost ~]$ sudo yum update
rawhide/metalink                                         | 3.7 kB     00:00     
rawhide                                                  | 3.4 kB     00:00     
rawhide/primary_db                                       |  10 MB     00:08     
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package DeviceKit-disks.ppc 0:004-0.4.20090406git.fc11 set to be updated
--> Processing Dependency: libatasmart >= 0.5 for package: DeviceKit-disks
--> Processing Dependency: libatasmart.so.0 for package: DeviceKit-disks
<snip>

Seems to work well enough for yum to run now.  The older package would cause yum to crash after downloading the metadata.

I tested this on my Apple G5
Comment 8 Roman Rakus 2009-04-08 08:14:08 EDT
*** Bug 494856 has been marked as a duplicate of this bug. ***
Comment 9 Roman Rakus 2009-04-08 08:18:47 EDT
Also work on Apple iBook G4
Comment 10 Panu Matilainen 2009-04-14 03:56:38 EDT
FWIW, the problematic change in sqlite has a comment about "working around C aliasing rules" so -fno-strict-aliasing seems to be appropriate for now. Need to report this upstream but for Fedora purposes I think we can consider this fixed now.

Note You need to log in before you can comment on or make changes to this bug.