Bug 494766 - Can't activate vertical or horizontal scroll on AlpsPS/2 ALPS GlidePoint
Can't activate vertical or horizontal scroll on AlpsPS/2 ALPS GlidePoint
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-synaptics (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
: 494742 498766 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-07 22:43 EDT by Gustavo Maciel Dias Vieira
Modified: 2009-05-04 19:56 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-04 19:53:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The output of synclient -l showing the defaults for this hardware. (2.05 KB, text/plain)
2009-04-07 22:43 EDT, Gustavo Maciel Dias Vieira
no flags Details
The output from evtest (758 bytes, text/plain)
2009-04-08 09:29 EDT, Gustavo Maciel Dias Vieira
no flags Details
Output of evtest (759 bytes, text/plain)
2009-04-12 19:25 EDT, Adam Huffman
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 21214 None None None Never

  None (edit)
Description Gustavo Maciel Dias Vieira 2009-04-07 22:43:11 EDT
Created attachment 338646 [details]
The output of synclient -l showing the defaults for this hardware.

I can't activate vertical or horizontal scroll on AlpsPS/2 ALPS GlidePoint.

The default configuration has VertEdgeScroll parameter enabled, but vertical scroll does not work. Enabling HorizEdgeScroll also won't enable horizontal scrolling  

I'm seeing this in rawhide with xorg-x11-drv-synaptics-1.1.0-1.fc11.x86_64

The attachment shows the output of synclient -l.

I suspected that the edges could be wrong and tried to set the values from my working F10 configuration. I wasn't able to set RightEdge or BottomEdge. No error, the parameters just never changed from zero.

And now for the really fun part. I set LeftEdge to 120 (as in F10) and *TopEdge* to 830 (the value of RightEdge in F10) and my vertical scroll magically worked. Horizontal scrolling, obviously, stayed broken.
Comment 1 Peter Hutterer 2009-04-08 02:32:09 EDT
Please download http://people.freedesktop.org/~whot/evtest.c, compile it with "gcc -o evtest evtest.c" and then run it as root with "./evtest /dev/input/eventX" where X is the number for the device. You can get the number by looking at /proc/bus/input/devices. Then attach the output of evtest here.
Comment 2 Peter Hutterer 2009-04-08 02:32:26 EDT
*** Bug 494742 has been marked as a duplicate of this bug. ***
Comment 3 Gustavo Maciel Dias Vieira 2009-04-08 09:29:21 EDT
Created attachment 338708 [details]
The output from evtest
Comment 4 Gustavo Maciel Dias Vieira 2009-04-08 09:33:34 EDT
This touchpad is found in a HP Pavilion dv4-1125br. Maybe all dv4s have similar hardware. It has physical dimensions of 8.4cm x 4cm.
Comment 5 Alex Wauck 2009-04-08 15:07:39 EDT
I have this problem with a HP dv2500t.  It may be a general HP thing.
Comment 6 Alex Wauck 2009-04-08 17:45:21 EDT
Modifying device properties via synclient works.  I use the following in a bash script:
synclient VertTwoFingerScroll=1
synclient HorizTwoFingerScroll=1
synclient EmulateTwoFingerMinW=0
synclient EmulateTwoFingerMinZ=100

This results in horizontal and vertical two-finger (emulated) scrolling.  I would imagine something similar could be done for side-of-pad scrolling.  I also tried modifying /usr/share/hal/fdi/policy/20thirdparty/10-synaptics.fdi and placing it in /etc/hal/fdi/policy/, but that didn't work.
Comment 7 Adam Huffman 2009-04-12 19:23:19 EDT
I'm seeing this too and the same workaround listed in the Description worked i.e. setting TopEdge and LeftEdge.

There's no xorg.conf and this did used to work under F10.  

The hardware is a Vaio VGN SZ3-XWP.
Comment 8 Adam Huffman 2009-04-12 19:25:41 EDT
Created attachment 339268 [details]
Output of evtest
Comment 9 Peter Hutterer 2009-04-13 23:48:36 EDT
(In reply to comment #0)
> I suspected that the edges could be wrong and tried to set the values from my
> working F10 configuration. I wasn't able to set RightEdge or BottomEdge. No
> error, the parameters just never changed from zero.
> 
> And now for the really fun part. I set LeftEdge to 120 (as in F10) and
> *TopEdge* to 830 (the value of RightEdge in F10) and my vertical scroll
> magically worked. Horizontal scrolling, obviously, stayed broken.  

64-bit issue in synclient. thanks for reporting, fixed in 1.1.0-2.

http://koji.fedoraproject.org/koji/taskinfo?taskID=1296305

what's the highest value of RightEdge where you consider edge scrolling working properly? maybe we need to tweak the proportions a bit.
Comment 10 Clemens Eisserer 2009-04-14 03:38:24 EDT
For me "synclient RightEdge=890" is required to make vertical scrolling work again on my Alps glidepoint. The latop is an Toshiba Tecra A8.
Comment 11 Gustavo Maciel Dias Vieira 2009-04-14 08:03:00 EDT
Bug is fixed in 1.1.0-2. Thanks!

Vertical scrolling starts working with RightEdge at about 950, but with the finger touching the border (like my old synaptics). This touchpad, however, has a cute sliding bar printed on it. For the vertical scrolling to match this bar I need to set RightEdge to 900. As this pad has a wide proportion, 900 seems fine to me.

Horizontal scrolling starts working with BottomEdge at 670. But, 630 seems a more comfortable value. In this case, the finger must be very close to the border, but this seems OK as the vertical area is at a premium here.
Comment 12 Gustavo Maciel Dias Vieira 2009-04-14 08:15:29 EDT
By the way, setting TopEdge and LeftEdge to 120 (they are 40), makes dragging beyond the border possible (by holding the finger at the border). Apparently, this doesn't reduce the area I can use to move the pointer. So, if you could use these parameters as defaults I would be very, very happy. :)
Comment 13 Peter Hutterer 2009-04-16 01:55:10 EDT
(In reply to comment #12)
> By the way, setting TopEdge and LeftEdge to 120 (they are 40), makes dragging
> beyond the border possible (by holding the finger at the border). Apparently,
> this doesn't reduce the area I can use to move the pointer. So, if you could
> use these parameters as defaults I would be very, very happy. :)  

yes, the edge areas should only come into effect when you're touching in that area, not when you're dragging into this area. This applies to right/bottom edges as well.
It doesn't apply to scrolling though, if you leave the defined edge area, scrolling stops - hence the problems you guys experience.
Comment 14 Peter Hutterer 2009-04-16 02:49:15 EDT
Opened an upstream bug to see how we could modify the defaults to be more generally applicable across different hardware.

http://bugs.freedesktop.org/show_bug.cgi?id=21214
Comment 15 Peter Hutterer 2009-04-22 18:39:43 EDT
please try the scratch build below. it increases the edges to 7% instead of the previous 4%. does that work for you guys?

http://koji.fedoraproject.org/koji/taskinfo?taskID=1315945
Comment 16 Adam Huffman 2009-04-24 15:52:37 EDT
Am unable to upgrade to that package as the version is the same as the installed one.
Comment 17 Peter Hutterer 2009-04-25 01:07:22 EDT
oops. updated scratch build.

http://koji.fedoraproject.org/koji/taskinfo?taskID=1320015
Comment 18 Adam Huffman 2009-04-27 08:02:56 EDT
For me at least, that's much better, though still not as good as it was before.  Edge scrolling does work, albeit somehow not as smoothly as in the past.
Comment 19 Gustavo Maciel Dias Vieira 2009-04-28 14:42:54 EDT
(In reply to comment #15)
> please try the scratch build below. it increases the edges to 7% instead of the
> previous 4%. does that work for you guys?

The new values for my setup are RightEdge = 952 and BottomEdge = 714. Consistent with my last experiments (comment #11), these numbers give a barely usable but unreliable vertical scroll and a horizontal scroll that does not work at all.

For my hardware I would need about 10% for horizontal edges (vertical scroll) and 15% for vertical edges. Ideally a bit more (see above).

Thanks anyway for the great work.
Comment 20 Ed Marshall 2009-04-29 19:30:46 EDT
I'm having this same problem, using xorg-x11-drv-synaptics-1.1.0-3.fc11.x86_64; by default, RightEdge is set to 983, which is too far off the actual pad to be usable. Setting it to 915 or so is about perfect; 925 is right at the edge of the pad. I get intermittent operation anything above that, usually only an upward motion.

BottomEdge ends up being set to 725 with this version, but I haven't tested horizontal scrolling just yet.

This is the pad on a Dell Inspiron 1721 laptop. Relevant snippet from Xorg.0.log:

(II) config/hal: Adding input device AlpsPS/2 ALPS GlidePoint
(II) LoadModule: "synaptics"
(II) Loading /usr/lib64/xorg/modules/input//synaptics_drv.so
(II) Module synaptics: vendor="X.Org Foundation"
        compiled for 1.6.1, module version = 1.1.0
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 4.0
(II) Synaptics touchpad driver version 1.1.0
(**) Option "Device" "/dev/input/event6"
(II) AlpsPS/2 ALPS GlidePoint: x-axis range 0 - 1023
(II) AlpsPS/2 ALPS GlidePoint: y-axis range 0 - 767
(II) AlpsPS/2 ALPS GlidePoint: pressure range 0 - 127
(II) AlpsPS/2 ALPS GlidePoint: finger width range 0 - 0
(II) AlpsPS/2 ALPS GlidePoint: buttons: left right middle
(--) AlpsPS/2 ALPS GlidePoint touchpad found
(**) AlpsPS/2 ALPS GlidePoint: always reports core events
(II) XINPUT: Adding extended input device "AlpsPS/2 ALPS GlidePoint" (type: TOUCHPAD)
(**) AlpsPS/2 ALPS GlidePoint: (accel) keeping acceleration scheme 1
(**) AlpsPS/2 ALPS GlidePoint: (accel) filter chain progression: 2.00
(**) AlpsPS/2 ALPS GlidePoint: (accel) filter stage 0: 20.00 ms
(**) AlpsPS/2 ALPS GlidePoint: (accel) set acceleration profile 0
(--) AlpsPS/2 ALPS GlidePoint touchpad found

From /proc/bus/input/devices:

I: Bus=0011 Vendor=0002 Product=0008 Version=7325
N: Name="AlpsPS/2 ALPS GlidePoint"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input6
U: Uniq=
H: Handlers=mouse2 event6 
B: EV=f
B: KEY=420 670000 0 0 0 0
B: REL=3
B: ABS=1000003
Comment 21 Ed Marshall 2009-04-29 20:51:00 EDT
Just tried xorg-x11-drv-synaptics-1.1.0-4.fc11.x86_64 from koji; it moved RightEdge to 952 (and BottomEdge to 714), which still isn't quite close enough. I can make it scroll if I press hard enough on the edge of the pad, but obviously that's not quite right. ;-)
Comment 22 Peter Hutterer 2009-04-30 23:55:01 EDT
Next try (same release version as the previous scratch package)

This one should detect whether it's an ALPS or a synaptics pad and then apply model-specific defaults (15% or 7%).

http://koji.fedoraproject.org/koji/taskinfo?taskID=1331165

Please let me know how you go with this one.
Comment 23 Ed Marshall 2009-05-01 10:50:54 EDT
With this version, things look good:

Parameter settings:
    LeftEdge                = 153
    RightEdge               = 870
    TopEdge                 = 115
    BottomEdge              = 652
[...]

It's actually a bit lower than it really needs to be, but behavior is very consistent now. :-)
Comment 24 Clemens Eisserer 2009-05-02 15:58:39 EDT
still does not work out of the box with latest packages (2009-05-02). Setting RightEdge=890 makes it work properly.
Comment 25 Peter Hutterer 2009-05-03 20:10:28 EDT
Clemens - the version in Comment #22 should give you a RightEdge of 870. Please verify this after starting X with synclient -l. If the edge is higher, your touchpad either has a different range or you may still be running the old version.

If it is not 870, please attach the evtest output to this bugreport.
Comment 26 Thorsten Leemhuis 2009-05-04 11:30:20 EDT
had the same problem but the RPM mentioned in Comment #22 fixes it for me, so +1 for getting that into rawhide from me. thx for your work peter, much appreciated
Comment 27 Clemens Eisserer 2009-05-04 11:45:46 EDT
+1 works perfectly with the RPM :)
Comment 28 Peter Hutterer 2009-05-04 19:53:37 EDT
Fixed with xorg-x11-drv-synaptics 1.1.0-4. Thanks for testing.

http://koji.fedoraproject.org/koji/taskinfo?taskID=1336105
Comment 29 Rodd Clarkson 2009-05-04 19:56:16 EDT
*** Bug 498766 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.